Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Pascalloux
2019-06-20 11:38:27

Petit up pour ceux qui rencontrerait le même soucis :

J'ai mis un php.ini comme suit :

<?php

max_execution_time = 1800;

mysql.connect_timeout = -1;

?>

Avec les deux lignes pas de soucis de requête stoppé, j'ai toujours le message d'erreur en tête de page, mais la requête ce clôture bien et l'archive ce finalise correctement.

Test réalisé avec une archive généré de 3.8GO.

merci à ddtddt pour ton aide

Pascalloux
2019-06-09 15:51:46

Oui au début j'ai mis ce php.ini :

<?php

mysql.connect_timeout = -1

?>

Mais l'erreur arrivait dès 35 sec... en remplaçant par  max_execution_time = 1800; ça fonctionne, mais j'ai ce message...

ddtddt
2019-06-08 07:41:13

Bonjour

tu as essayer d'ajouter aussi

mysql.connect_timeout = -1

Pascalloux
2019-06-07 13:54:16

Super merci bcp !!! ça fonctionne avec ce php.ini tout simple :

<?php

max_execution_time = 1800;

?>

cependant j'ai un message d'erreur :
"
Warning: mysqli::query(): MySQL server has gone away

Warning:  [mysql error 2006] MySQL server has gone away

UPDATE piwigo_download_sets SET nb_zip = "1" WHERE id = 1091; in /espaceclient/include/dblayer/functions_mysqli.inc.php on line 845
"

L’archive ce génère correctement et n'est pas corrompue, mais j'ai ce petit message.

Une idée :/ ?

ddtddt
2019-06-07 12:32:23

Bonjour,

dans le php.ini

mysql.connect_timeout = -1

Cela va servir à définir un temps limite d'exécution infini pour mysql.

ou

max_execution_time = 1800

1800 est en seconde

Pascalloux
2019-06-07 11:36:00

Bonjour à tous et à toutes !

Je fait un petit topic (il ne me semble par avoir vue de topic déjà existant à ce sujet - ce que je trouve étonnant mais bon !)

En fait mon problème est simple :

Je souhaite pouvoir générer des archives d'environs 2 GO (les photos sont en HD ca monte vite en poids)
Lorsque je lance la première archive elle ce crée, puis ce remplis et après 50 secondes précisément, je me retrouve avec une erreur 500 internal error.

J'imagine donc que c'est une limite de temps accordé aux requêtes.

Je ne trouve pas vraiment d'info sur le web pour ce soucis, peut être une motif à faire au niveau de zip archive ? ajouter un php.ini ? ajouter une commande dans le local file ?

Merci par avance pour vos réponses!

Version de Piwigo: 2.9.5
Version de PHP: 7.2
Version de MySQL: 5.7

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact