Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

djom
2017-03-14 01:19:49

Le problème est résolu après avoir ouvert un ticket chez hostpapa pour redémarrer Apache : leur réponse :
"J'ai désactivé une règle positive de mod_security qui était à l'origine de ce comportement"
C'était donc lié au Web Application Firewall de l'hébergeur.

Maintenant, pourrait-on améliorer le comportement de piwigo pour qu'il puisse intercepter et afficher ce genre d'erreur 403 au lieu de figer la barre de progression d'upload ?Je pose la question, je ne sais pas si c'est faisable, mais ce serait bien, non ?

djom
2017-03-08 04:25:30

On dirait que c'est un problème côté serveur. En reproduisant le problème avec la console de Chrome activée j'ai :

1u1auth.js:90 POST http://toutee.com/piwigo/ws.php?method= … ormat=json 403 (Forbidden)

et

admin.php?page=photos_add:466 Uncaught TypeError: Cannot read property 'id' of null

cf le log complet :

Code:

1u1auth.js:90 POST http://toutee.com/piwigo/ws.php?method=pwg.images.upload&format=json 403 (Forbidden)
send @ 1u1auth.js:90
exec @ 1u1auth.js:89
shimExec @ 1u1auth.js:89
exec @ 1u1auth.js:89
r @ 1u1auth.js:90
u @ 1u1auth.js:90
send @ 1u1auth.js:90
p @ 1u1auth.js:104
k @ 1u1auth.js:104
(anonymous) @ 1u1auth.js:104
(anonymous) @ 1u1auth.js:89
i @ 1u1auth.js:89
(anonymous) @ 1u1auth.js:89
(anonymous) @ 1u1auth.js:89
i @ 1u1auth.js:89
r @ 1u1auth.js:89
dispatchEvent @ 1u1auth.js:89
trigger @ 1u1auth.js:89
g @ 1u1auth.js:104
start @ 1u1auth.js:104
(anonymous) @ admin.php?page=photos_add:382
dispatch @ jquery.min.js?v2.8.6:4
r.handle @ jquery.min.js?v2.8.6:4

admin.php?page=photos_add:466 Uncaught TypeError: Cannot read property 'id' of null
    at o.Uploader.UploadComplete (admin.php?page=photos_add:466)
    at o.Uploader.<anonymous> (1u1auth.js:104)
    at Array.<anonymous> (1u1auth.js:89)
    at i (1u1auth.js:89)
    at Object.r [as inSeries] (1u1auth.js:89)
    at o.Uploader.dispatchEvent (1u1auth.js:89)
    at o.Uploader.trigger (1u1auth.js:89)
    at o.Uploader.g (1u1auth.js:104)
    at 1u1auth.js:104
UploadComplete @ admin.php?page=photos_add:466
(anonymous) @ 1u1auth.js:104
(anonymous) @ 1u1auth.js:89
i @ 1u1auth.js:89
r @ 1u1auth.js:89
dispatchEvent @ 1u1auth.js:89
trigger @ 1u1auth.js:89
g @ 1u1auth.js:104
(anonymous) @ 1u1auth.js:104
djom
2017-03-04 17:26:27

Bonjour,
Non pas de problème d'espace car j'ai un espace illimité chez mon hébergeur. De plus je viens d'ajouter des photos en ftp sans problème.
C'est vraiment avec le formulaire Web que ça coince. J'ai essayé avec Firefox et avec Chrome. J'ai fait les opérations de maintenance sur la base de donnée. No luck.
Je me demande s'il y a des fichiers de log quelque part qui pourraient me mettre sur la piste ?

ddtddt
2017-03-04 09:34:31

Bonjour,

Espace de stockage plein ?

djom
2017-03-04 05:26:49

Bonsoir,

Pour une raison inconnue je ne suis plus en mesure d'ajouter des photos à un album existant via l'administration (Photos -> Ajouter -> Formulaire web), poutrtant cela fonctionne depuis des années.
Je clique sur "Ajouter des photos", je choisis une photo, elle apparait bien dans la liste, puis je clique sur "Démarrer le transfert".. le transfert commence et gèle à 21% de progression. Ensuite il ne se passe rien.
En glisser/déposer dans la fenêtre, même problème. La barre orange de progression se fige.
Que me suggérez-vous ?

Version de Piwigo: 2.8.6
Version de PHP: 5.6.28
Version de MySQL: 5.5.52-cll
URL Piwigo: http://toutee.com/piwigo/

Merci d'avance.

Jérôme

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact