Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

newdeclic
2016-01-18 14:11:57

Merci plg, ok pas de problème pour les éventuelles remarques suivantes

A+

plg
2016-01-18 14:09:46

@newdeclic : j'ai corrigé le bug. J'avais oublié de créer les nouveaux éléments en base de données pour les nouvelles clefs d'identification sur une installation neuve. [Github] Piwigo issue #404

Merci de créer une sujet de discussion par problème rencontré, sinon on s'en sortira pas :-)

BrandonCougar
2016-01-18 07:58:16

pour info, j'ai vu que Grum Plugin Class 3 était utilisé par AMM et aussi Astat2 donc j'ai vérifié qu'il fonctionnait toujours... et oui il fonctionne. Juste un petit décalage vers le haut de la ligne explicative des onglets du plugin comme illustré par la capture ci-dessous :

http://fr.piwigo.org/forum/showimage.php?pid=216930&filename=Piwigo+2.8+-+AStat2.jpg

BrandonCougar
2016-01-18 07:26:03

oui oui j'ai bien Grum Plugin Class 3 v3.5.8 installé et activé sur les 2.

En fait le menu apparait et fonctionne correctement. C'est sur la partie Admin du plugin que ça râle.

gbo
2016-01-17 16:51:26

je viens d'installer la 28rc1:

Lors de la synchronisation j'ai le message ci-dessous.
( ! ) Notice: Undefined variable: formats_to_delete in F:\Site\_28rc1\admin\site_update.php on line 673
Call Stack
#    Time    Memory    Function    Location
1    0.0000    325088    {main}( )    ..\admin.php:0
2    0.1404    4311048    include( 'F:\Site\_28rc1\admin\site_update.php' )    ..\admin.php:301

-------------------------------------
J'ai aussi l'erreur de Maj de la table history si je ne suis pas en administrateur.

[mysql error 1054] Unknown column 'auth_key_id' in 'field list'

-------------------------------------
Dans la gestion des options, la case à cocher pour les commentaire n'est pas en ligne avec les autres.



je continuerai les tests en fin de soirée.

mistic100
2016-01-17 16:26:16

vous n'auriez pas juste oublié le plugin Grum Plugin Classes par hasard ? necessaire à AMM

mistic100
2016-01-17 16:24:44

on me dit dans l'oreillette qu'en fait si, plg essaye toujours de le maintenir fonctionnel en attendant d'avoir une alternative (il y a déjà Menu Random Photo pour le bloc de photo aléatoire)

mais les "bugs" fonctionnels et d'UX ne seront pas corrigés

BrandonCougar
2016-01-17 11:10:21

mistic100 a écrit:

AMM ne sera plus mis à jour, il est trop gros trop compliqué et son créateur ne participe plus

C'est vrai que ça a l'air d'être une usine à gaz, même d'un point de vue de son utilisation mais j'avais réussi à en faire ce que je voulais.

Dommage, j'essaierai de trouver d'autres solutions.

mistic100
2016-01-17 11:05:17

AMM ne sera plus mis à jour, il est trop gros trop compliqué et son créateur ne participe plus

BrandonCougar
2016-01-17 10:52:22

Je rencontre maintenant une erreur avec le plugin Advance Menu Manager. Sur les 2 galeries sous 2.8 j'ai l'erreur, pas sur celles en 2.7.4 (le tout en local avec la config décrite dans le post précédent).

http://fr.piwigo.org/forum/showimage.php?pid=216918&filename=Piwigo+2.8+-+Erreur+AdvanceMenuManager.jpg

BrandonCougar
2016-01-17 10:24:39

Bonjour,

j'ai testé la 2.8 en local sur 2 des 4 galeries que j'administre.

J'ai fait une mise à jour manuelle sans problème. J'ai une multitude de plugins installés et hormis pour exif viewer où une mise à jour m'a été proposée et que j'ai installée avec succès pour le reste tout semble fonctionner correctement.

Je rencontre quand même un souci pour l'une des 2 galeries mais je suppose que c'est plus lié à mon environnement local.

Comme illustré ci-dessous j'ai un warning sur la page d'ajout de photo et il est indiqué que mon navigateur ne supporte pas HTML5 alors que sur l'autre galerie je n'ai l'erreur (et j'ai testé l'ajout d'une photo avec succès).
http://fr.piwigo.org/forum/showimage.php?pid=216917&filename=Warning+Piwigo+2.8+-+Ajout+de+photo.jpg


Le message indiquant que mon navigateur ne supporte pas HTML5 (l'erreur que l'on voit en dessous est le warning de la capture précédente) :
http://fr.piwigo.org/forum/showimage.php?pid=216917&filename=Piwigo+2.8+-+Pas+de+HTML5.jpg


Ma config locale :
http://fr.piwigo.org/forum/showimage.php?pid=216917&filename=Piwigo+2.8+-+Config+locale.jpg

newdeclic
2016-01-16 18:38:18

Merci pour la rapide réaction :)

mistic100
2016-01-16 17:30:25

J'ai notifié le dev
[Github] Piwigo issue #392

newdeclic
2016-01-16 15:46:48

Bonjour,

J'ai installé ma galerie de test pour Piwigo 2.8.0RC1.

Cette installation a été réalisée sur un sous-domaine (hébergement 1and1) avec PHP 5.6.15 et MySQL 5.5.46

le site est situé à l'adresse :

http://www.piwigotest28.newdeclic.com/ vérouillé car l'ip donnée dans le msg d'erreur ci-dessous donne un accés direct à ma box :(

L'installation s'est déroulé sans problème et sans message d'erreur (à part le time zone comme d'hab je crois avec 1and1) problème réglé avec la configuration locale.

Aucun autre plugin installé ( à part ceux "livrés" dans l'instal).

Cependant un problème est apparu lors de la deconnexion :
------------------------------------------------------------------------*
1ère erreur
------------------------------------------------------------------------
[mysql error 1054] Unknown column 'auth_key_id' in 'field list'

INSERT INTO piwigo_history
  (
    date,
    time,
    user_id,
    IP,
    section,
    category_id,
    image_id,
    image_type,
    format_id,
    auth_key_id,
    tag_ids
  )
  VALUES
  (
    CURRENT_DATE,
    CURRENT_TIME,
    2,
    'Xxx.xxx.xxx.xxx',   j'ai enlevé l'adresse ip
    'categori',
    NULL,
    NULL,
    NULL,
    NULL,
    NULL,
    NULL
  )
;

#1    my_error /homepages/40/d507972891/htdocs/piwigotestrc28/include/dblayer/functions_mysqli.inc.php(134)
#2    pwg_query /homepages/40/d507972891/htdocs/piwigotestrc28/include/functions.inc.php(467)
#3    pwg_log /homepages/40/d507972891/htdocs/piw

-----------------------------------------------
puis une 2ème erreur à la connexion :
-----------------------------------------------
Catchable fatal error: session_regenerate_id(): Failed to create(read) session ID: user (path: /tmp) in /homepages/40/d507972891/htdocs/piwigotestrc28/include/functions_user.inc.php on line 951

cette 2ème erreur n'a pas permis la reconnexion.

A force de tentative j'ai réussi à me reconnecter et cette 2ème erreur ne s'est pas reproduite.

J'ai téléchargé environ 200 photos sur 2 albums publics sans encombre.

J'ai créé 2 groupes (Administrateurs et Membres)

J'ai testé la notification d'album, voici les constatations :

1 envoi d'une notification vers le groupe administrateurs, sa fonctionne (test aussi du lien dans le mail ok)
2 envoi d'une notification au groupe  membres ici ça ne semble pas fonctionner erreur suivante :

---------------------------------------------
3ème erreur
----------------------------------------------
Piwigo a rencontré une erreur non récupérable

[mysql error 1146] Table 'db609606641.piwigo_user_auth_keys' doesn't exist

SELECT
    COUNT(*),
    NOW(),
    ADDDATE(NOW(), INTERVAL 259200 SECOND)
  FROM piwigo_user_auth_keys
  WHERE auth_key = 'zTEIugWFNROeXSkIjOtwxJYcHhdVpM'
;

#1    my_error /homepages/40/d507972891/htdocs/piwigotestrc28/include/dblayer/functions_mysqli.inc.php(134)
#2    pwg_query /homepages/40/d507972891/htdocs/piwigotestrc28/include/functions_user.inc.php(1578)
#3    create_user_auth_key /homepages/40/d507972891/htdocs/piwigotestrc28/include/functions_mail.inc.php(541)
#4    pwg_mail_group /homepages/40/d507972891/htdocs/piwigotestrc28/admin/album_notification.php(174)
#5    include /homepages/40/d507972891/htdocs/piwigotestrc28/admin/album.php(88)
#6    include /homepages/40/d507972891/htdocs/piwigotestrc28/admin.php(301)

----------------------------------------

Voilà, ma première modeste contribution, qui j'espère pourra être utile à l'équipe Piwigo.(je peux donner un accès éventuellement).

A+

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact