Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

flop25
2014-04-15 07:58:12

^_^ Tu as pu dormir sereinement
bonne journée

Toomka
2014-04-15 00:02:50

Merci flop25, je viens de trouver. J'avais bien regardé du coté des caractères spéciaux mais je me suis fait avoir par un CR après mon <?php au lieu d'un CR LF !!!

La bonne prise de tête, surtout qu'il a fallu que je recrais mon fichier pour que ça fonctionne (j'ai pas compris pourquoi notepad++ n'a pas voulu me faire le retour à la ligne).

Toomka
2014-04-14 23:20:38

Oui normalement le fichier admin.php commence par :

Code:

<?php 
if (!defined('PHPWG_ROOT_PATH')) die('Hacking attempt!');

Bizarrement comme ça j'ai l'erreur alors qu'avec :

Code:

<?php echo '';
if (!defined('PHPWG_ROOT_PATH')) die('Hacking attempt!');

je n'ai aucun problème.

Pour info j'ai fait des tests en supprimant le if (!defined... et php me sort des erreurs sur la ligne suivante. J'ai regardé les caractères invisibles au cas ou et je n'ai rien vu de bizarre !

flop25
2014-04-14 22:56:35

Toomka a écrit:

Bonjour,

J'ai ajouté dans mon plugin la possibilité d'avoir les auteurs des photos affichés dans chaque catégorie (sur mainpage_categories.tpl).

J'ai un bug vraiment étrange, dans mon fichier ThumbnailTooltip/admin/admin.php si je n'affiche pas un echo ''; en tout début de fichier j'ai :

Code:

Parse error: syntax error, unexpected 'die' (T_EXIT) in /xxx/xxx/plugins/ThumbnailTooltip/admin/admin.php on line 1

Avez-vous une idée d'ou cela pourrait venir (je suis bien en php 5.4) ?

PS : en local tout fonctionne normalement sans le echo '';

il y a un die() dans le code

Toomka
2014-04-14 20:05:07

Bonjour,

J'ai ajouté dans mon plugin la possibilité d'avoir les auteurs des photos affichés dans chaque catégorie (sur mainpage_categories.tpl).

J'ai un bug vraiment étrange, dans mon fichier ThumbnailTooltip/admin/admin.php si je n'affiche pas un echo ''; en tout début de fichier j'ai :

Code:

Parse error: syntax error, unexpected 'die' (T_EXIT) in /xxx/xxx/plugins/ThumbnailTooltip/admin/admin.php on line 1

Avez-vous une idée d'ou cela pourrait venir (je suis bien en php 5.4) ?

PS : en local tout fonctionne normalement sans le echo '';

Toomka
2014-03-26 23:50:06

Un grand merci Mistic, j'aurai pas trouvé sans toi. Effectivement c'est bien Mod qui fout le bordel. Sans et en republiant le plugin, ça fonctionne beaucoup mieux ;)

Suppression de ma dernière rev (1.4.3), installe de la version 1.4.2, ajout d'une nouvelle rev en 1.4.3, upgrade sur ma galerie, tout est ok :)

mistic100
2014-03-26 23:43:59

ah mais oui, vous vous etes mit dans la catégorie "MOD", votre plugin n'est pas un MOD
alors ça ne marche pas

(il faut qu'on la vire cette catégorie)

Toomka
2014-03-26 23:37:54

mistic100 a écrit:

quand vous ajoutez une nouvelle version il faut choisir "Créer une archive par SVN"

C'est bien ce que je fais.

mistic100
2014-03-26 23:34:10
mistic100
2014-03-26 23:33:10

mistic100 a écrit:

(si vous publiez depuis SVN)

quand vous ajoutez une nouvelle version il faut choisir "Créer une archive par SVN"

Toomka
2014-03-26 23:31:54

J'ai bien remis dans le main comme tu as dit (cf. http://piwigo.org/svn/extensions/Thumbn … in.inc.php), mais du coup sur la page des plugins sur ma galerie, il ne remplace pas le auto par le numéro de version ?!! J'ai encore oublié quelque chose ?

mistic100
2014-03-26 23:26:14
Toomka
2014-03-26 23:25:24

Merci pour ta réponse Mistic, par contre pour être sûr, je mets auto dans main.inc.php ou dans PEM ? (parce que j'ai fais le test pour les 2 et ça n'a pas fonctionné)

mistic100
2014-03-26 23:16:46

ben oui

il y a 1.4.0 dans le main, c'est la seul info qu'a Piwigo, et comme c'est inférieur à 1.4.3 il demande de mettre à jour

MAIS, mettez "auto" comme version, PEM changera tout seul (si vous publiez depuis SVN)

Toomka
2014-03-26 23:14:36

Bonsoir,

J'ai un soucis sur mon plugin que je n'arrive pas à résoudre. J'ai ajouté une nouvelle version de l'extension sur PEM, en utilisant les révisions. Lorsque je mets à jour mon plugin sur ma galerie celui ci m'indique toujours que ma version est en 1.4.0 et qu’il faut que je fasse la mise à jour (en 1.4.3) !

Ai-je oublié quelque chose (changer le numéro de version dans le fichier main.inc.php) ?

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact