Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Zen-Luck
2013-09-17 01:19:55

Bonjour Mascarille,
Je viens de lire le fil concernant la modification (recherche "ET" ... etc.).
Où place-t-on ce code que je voudrais essayer et qui semble répondre à ma préoccupation?

Cordialement,
Jean-Luc

Zen-Luck
2013-09-17 01:14:18

Merci, grâce à vos explications, j'ai compris la limitation de la recherche (Menu Rechercher). En résumé, la recherche d'une expression dans les légendes des photos ne produit pas exactement le résultat escompté. Il ne s'agit donc pas d'une anomalie mais d'une caractéristique... Je vais voir comment je peux répondre à mes visiteurs qui m'ont signalé le "problème" et ne comprennent pas pourquoi cela ne marche pas bien...

Le système de tags (mots-clés), je le réserve aux dates, circonstances et lieux de prises de vues des photos de mon site ce qui me semble la destination la mieux appropriée.
Le site est tout récent et n'a pas encore sa taille définitive c-à-d que le nombre de photos va augmenter et je me vois mal mettre tous les mots de chaque légende dans des tags (dans ce cas, à quoi servirait encore la fonction de Recherche). Il faudrait presque avoir une sous-classification des tags pour les différencier... On est ici face à deux conceptions opposées de la fonction recherche mais conceptions coexistantes au sein du même logiciel, selon qu'on utilise les tags ou la méthode de recherche 'classique' (Menu Rechercher). A méditer...

Cordialement,
Jean-Luc

Mascarille
2013-09-16 09:33:38

Bonjour,
je ne sais pas précisément comment est programmée la fonction recherche, mais il probable qu'elle met en oeuvre les fonctions SQL de recherche qui sont disponibles avec leurs contraintes et donc pas forcément adaptées à votre demande.
Faites une recherche sur la toile "SQL recherche texte" et vous verrez...
Contrairement à votre titre, ce n'est donc pas une anomalie, mais lié aux fonctions disponibles dans SQL.

Dans votre cas, toutes les photos comportant l'un OU l'autre des critères de recherche dans TOUS LES CHAMPS précisés dans la documentation sont sélectionnés.

Vous pouvez écrire un plugin et programmer les fonctions de recherche "ET" uniquement dans LE champ commentaire situé sous la photo.
exemple de code http://forum.ovh.com/showthread.php?t=17127

Pour les tags, 190 photos est-ce pharaonique ? ça me parait plus facile à mettre en oeuvre.

Bonne journée

Zen-Luck
2013-09-16 00:18:47

Bonjour,
ma recherche est particulière car elle concerne deux mots séparés par un espace (prénom + nom).
Y a-t-il un moyen pour que la recherche s'effectue sur ces deux mots ensemble c-à-d considérer les deux mots comme une seule unité de recherche (comme la syntaxe possible lors de la recherche sur Google)? Je ne vois pas d'explication à ce sujet dans l'aide.

Les tags ne sont pas possibles car ils nécessiteraient d'entrer tous les noms des personnes visibles sur les photos ce qui est un travail pharaonique.

Cordialement,
Jean-Luc

Mascarille
2013-09-15 23:06:06

Bonjour,
la recherche est plus complexe que ça : elle porte sur de nombreux champs et comporte de nombreuses restrictions (longueur > 3 par exemple). Voir la doc
http://fr.piwigo.org/doc/doku.php?id=ut … che_rapide
Dans votre exemple, il vaudrait mieux utiliser les tags (Vous pouvez vous faciliter le travail en utilisant la gestion par lots).
Bonne soirée

Zen-Luck
2013-09-15 02:18:50

Bonjour,
sur mon site www.album-stan-kis.be, j'ai mis en légende des photos le prénom et le nom des personnes identifiées.
Lorsque j'effectue une recherche sur une personne, Piwigo m'affiche des photos qui ne contiennent pas les mots recherchés.
Exemple :
je cherche les photos où figure Marc DASSY.
Je tape Marc DASSY ou "Marc DASSY" dans le champ de la recherche et Piwigo me montre bien les photos où figure cette personne (un enfant) mais aussi deux autres photos où elle ne figure pas (son prénom + son nom ne figurent pas dans la légende sous la photo).

Comment régler ce problème ?

Cordialement,
Jean-Luc

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact