Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Gotcha
2011-02-20 18:41:29

Merci beaucoup Claude :-)

cljosse
2011-02-19 11:24:18

Environnement.
Vista + IE8
Tests avec :
mode navigateur IE7,mode document Normes IE7
                                mode document Quirks

mode navigateur IE8,mode document Normes IE7
                                mode document Quirks
                                mode document IE8

+ test avec IETester.

test Opera,seaMonkey,Firefox,Chrome,Safari
Tout est ok
Mais je n'ai pas xp sous la main pour faire les tests sous XP

A+

Gotcha
2011-02-19 02:07:54

cljosse a écrit:

local/css qu'il faudrait mettre.

Non car pour l'administration, le fichier local-layout.css se trouve dans le même répertoire que default-layout.css

Les thèmes de l'administration ne réagissent pas tout à fait pareil que pour les thèmes "publiques" de la galerie. L'administration n'a pas de dossier local et la personnalisation des thèmes ne se fait pas par LocalFiles Editor.

Pour les lignes mentionnés, je pense qu'elles sont obsolètes en effet...

Pour le code, as-tu un environnement Win XP + IE7 ?
Dans l'affirmative, peux-tu tester le code suivant :

Code:

/* fix ONLY IE7 footer */
*:first-child+html #the_page {min-height:100%; position:relative; padding:0;margin:0;} 
*:first-child+html #menubar { margin: 0; }
*:first-child+html #footer { left: 0; }

Le code que tu donne ne donne pas un bon rendu sous Firefox notement avec une longue liste de plugins.

cljosse
2011-02-18 17:18:35

Pour corriger ce problème de décalage sous IE7 j'avais mis ce code:
dans le fichier admin/themes/defaut/local-layout.css

Code:

#the_page {min-height:100%; position:static; width:100%; padding:0;margin:0;}
#footer {
    position: relative;
    left: auto;
}

A propos il me semble qu'il y a une erreur dans le fichier admin/themes/defaut/layout.css
ligne 10
@import "../../../template-common/default-layout.css";
/* Override properties with import local file */
@import "../../../template-common/local-layout.css";

vu que le répertoire template-common n'existe plus.
ce serait plutot:
local/css qu'il faudrait mettre.

Gotcha
2011-02-18 10:28:14
Gotcha
2011-02-05 12:25:20

Mascarille a écrit:

==> le dysfonctionnement, que j'avais remarqué hier, comme Gotcha - pourquoi hier ?[...]

post:161039


Mascarille a écrit:

Dans la mesure ou l'administration est réservée à l'administrateur, le choix d'une autre version ou d'un autre navigateur reste la solution.

+1

Je ne sais pas débugger avec IE.

Mascarille
2011-02-04 14:56:45

Bonjour,

avec le débugger de IE9, on peut faire varier
- le mode navigateur = IE7, IE8 ou IE9

- le mode document = IE7, IE8, IE9

==> le dysfonctionnement, que j'avais remarqué hier, comme Gotcha - pourquoi hier ? - se produit lorsque l'on paramètre mode document = IE7, quelque soit le mode navigateur (je suppose que le mode document prend la main sur le mode navigateur)

mais tout est correct en IE8 et IE9.

Dans la mesure ou l'administration est réservée à l'administrateur, le choix d'une autre version ou d'un autre navigateur reste la solution.

Cordialement

Emile

bvl
2011-02-04 08:02:50

Bonjour,

Résolu pour moi aussi en passant à ie8 (et test en ie9 béta)
(No pb avec FireFox et chrome)

Merci.

ALPH
2011-02-03 15:08:28

Bonjour,

Résolu pour moi, mais pas pour ceux qui doivent, ou sont obligés, de rester en IE 7 sous XP (ou autre configuration).

Merci pour eux.

A. PHILIPPE

ALPH
2011-02-03 11:47:55

Bonjour,

Je viens d'installer IE 8 >> plus de pb

A. PHILIPPE

ALPH
2011-02-02 23:54:36

mouai ....

Je ne dois pas être le seul dans ce cas. Est-il encore judicieux de mettre à jour XP avec IE 8 sur une machine qui a 7ou 8 ans ?

Ce comportement a été introduit avec la v2.1.6

Merci d'une réponse

A. PHILIPPE

Gotcha
2011-02-02 23:48:20

Dans ce cas je préconiserai une mise à jour de votre navigateur IE7.

Mais sinon, Firefox c'est un très bon choix !!

8-)

ALPH
2011-02-02 23:44:48

Je suis encore sous IE 7 sous XP

A. PHILIPPE

Gotcha
2011-02-02 23:42:30

Alors en effet j'arrive à reproduire le problème avec le moteur graphique de IE sous Firefox (c'est un plugin pour Firefox) mais je ne reproduis pas le problème avec le vrai navigateur IE8 (x64).

Gotcha
2011-02-02 23:40:01

Il est vrai qu'hier j'ai jonglé avec IE et Chrome...

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact