Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

vimages
2011-03-28 13:02:14

hé bien cette fois-ci je crois bien devoir présenter des excuses.

étant trop pressé.. voir tendu, par tout plein de choses, j'ai loupé un truc..
donc, le temps de midi, les choses se sont posées et voilà...
tout marche bien, IPTC compris...

excusez moi..
je passe en mode résolu.

amitiés,
éric.

Zaphod
2011-03-28 12:58:54

Etonnant, car chez moi la dernière fois que j'ai essayé... les mots clés étaient bien synchronisés par pLoader, et mon mapping IPTC était tout à fait pris en compte.
(c'est donc différent de PiwigoExport pour lequel le mapping est pris en compte, mais écrasé)

Gotcha
2011-03-28 12:11:01

Sujet évoqué récemment pour l'outil PiwigoExport. Je ne savais pas que ca affectait aussi pLoader.

post:164793

vimages
2011-03-28 11:55:51

Bonjour,
je découvre le problème...

je viens d'uploader des photos avec pLoader sur une galerie...
je croyais que pLoader utiliserait mon fichier conf.. mais que dalle, les iptc ne sont pas du tout synchronisées...!!! Bien sur une post synchronisation de donne rien vu que les fichiers ne sont pas dans arborescence de la galerie mais à l'extérieur.

Alors j'aimerais savoir de me dire qu'elle solution vous avez, et que je n'ai pas su trouver. Car dans l'état actuel des choses, c'est un manque bloquant.


merci amitiés,
éric.

Eric
2011-01-05 11:03:01

Ok, pigé. Même si pLoader ne détecte pas le données IPTC, les photos transférées doivent conserver leurs IPTC.
Je vais refaire des essais sur ma galerie locale.

Zaphod
2011-01-05 10:17:20

Ca n'est pas un comportement normal en tous cas, car chez moi la reconnaissance des IPTC se fait tout à fait bien sur les photos transférées via pLoader...

plg
2011-01-05 09:05:44

Eric a écrit:

Donc le pb est bien sur pLoader et la détection des tags IPTC. Ouverture de bug ou est-ce lié à [Bugtracker] ticket 922 ?

pLoader ne détecte pas les métadonnées IPTC (juste quelques métadonnées EXIF). Il ne les supprime pas non plus. Il faut regarder sur la photo envoyée sur ta galerie si les IPTC sont toujours présentes ou non.

La photo que tu m'as envoyé, elle a été redimensionnée par pLoader 1.6, et dans Piwigo elle a toujours ses IPTC et Piwigo a réussi à y lire les tags.

Eric
2011-01-05 00:14:08

plg a écrit:

Alors je confirme que pLoader ne détecte pas les tags IPTC dans la photo. Cependant, si par exemple Piwigo est configuré ainsi :

Code:

$conf['use_iptc'] = true;
$conf['use_iptc_mapping'] = array(
  'keywords' => '2#025',
  );

alors les tags IPTC de ta photo sont automatiquement convertis en tags Piwigo.

Oui, il va de soit que la conf 'use_iptc' est active ainsi que le mapping des tags IPTC. C'est le cas pour ma galerie. D'ailleurs, sans cette option, même la synchro des métadata après upload par FTP ne fonctionnerait pas.
Or, c'est ce que j'utilise personnellement parce que je suis admin. Pour les contributeurs "externes", je leur propose bien sur pLoader ;-)

Donc le pb est bien sur pLoader et la détection des tags IPTC. Ouverture de bug ou est-ce lié à [Bugtracker] ticket 922 ?

plg
2011-01-04 23:59:42

Alors je confirme que pLoader ne détecte pas les tags IPTC dans la photo. Cependant, si par exemple Piwigo est configuré ainsi :

Code:

$conf['use_iptc'] = true;
$conf['use_iptc_mapping'] = array(
  'keywords' => '2#025',
  );

alors les tags IPTC de ta photo sont automatiquement convertis en tags Piwigo.

Eric
2011-01-04 23:52:34

Photo envoyée par PM.

plg
2011-01-04 23:41:14

Hum... pas normal tout ça. Tu pourrais me donner une photo pour que je teste ?

En théorie, si votre photo comporte des métadonnées, alors il faut considérer que ce que vous définissez dans pLoader va être écrasé par la synchro automatique des métadonnées faite dans Piwigo lorsqu'on ajoute une photo (que ce soit via pLoader ou n'importe quel logiciel distant ou le formulaire web).

Eric
2011-01-04 23:31:33

Re !

Autre retour sur pLoader 1.6 pour Windows (bah oui, les photos des fêtes de fin d'année déboulent ^^) : Lorsque les méta-données IPTC comprennent des mots-clés (saisis via XnView), il n'y a pas de correspondance effectuée avec les tags déjà présents sur la galerie.

Par exemple, si un mot-clé "toto" est présent dans les données IPTC d'une photo et que "toto" existe dans les tags de la galerie, on pourrait s'attendre à ce que la case "toto" soit cochée dans l'onglet "Tags" de pLoader. Mais ce n'est pas le cas...

A ce stade, il y a deux comportements d'utilisateurs possibles:
1- L'utilisateur ne s'en inquiète pas et lance le transfert sans cocher les cases des tags souhaités en pensant qu'il les retrouvera quand même après le transfert -> Pas bon ! Car les méta-données ne sont pas synchronisées et il faut que l'admin de la galerie se les fade à la mano :-(

2- L'utilisateur grogne un coup et coche les cases des tags en rapport pour chaque photo. S'il n'en a que quelques unes, çà va. Mais à partir d'un certain nombre... -> Pas bon pour les relations user vs admin ;-))

Plusieurs discussions ont déjà eu lieu sur le sujet et, notamment, [Bugtracker] ticket 922. Quoi de neuf de ce côté ?

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact