Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

mko
2010-12-02 13:33:46

pour la présentation de ma galerie, j'y vais bientôt !!!
merci encore pour toute ton aide.

Gotcha
2010-12-01 21:08:40

J'ai tout simplement outre-passé la condition d'identification en modifiant la procédure de mise à jour :-)

Je ne vous l'avais pas dit par courriel, mais vous avez de très belles photos et fait rare pour être souligné : droits libres !!! (enfin, presque ^^)

N'hésitez pas à présenter votre galerie dans : http://fr.piwigo.org/forum/viewforum.php?id=7

;-)

mko
2010-12-01 00:50:40

merci à Gotcha pour son aide précieuse ce jour. Il a réussit à mettre à jour piwigo chez lui et m'a transmis les fichiers pour réaliser cette opération en local chez moi puis sur mon site internet. Je le remercie grandement (et même plus que cela)

Je ne suis par contre pas sur de maitriser l'ensemble des modifications qu'il a réalisé pour venir à bout de mon problème... apparemment le problème d'identification a été résolu en faisant la mise à jour du site. Mais je n'ai aucune idée comment il a pu faire cette mise à jour sans s'identifier...

Gotcha
2010-11-30 14:22:22

ddtddt a écrit:

Gotcha a écrit:

Oui il y a bien un espace sans que celui-ci ne m'est était préjudiciable jusqu'à aujourd'hui.

Et en supprimant l'espace ?

Toujours pareil :-(

Je vais tenter une MAJ de Piwigo car la galerie est à la version 2.0.2
A voir...

ddtddt
2010-11-30 14:11:01

Gotcha a écrit:

Oui il y a bien un espace sans que celui-ci ne m'est était préjudiciable jusqu'à aujourd'hui.

Et en supprimant l'espace ?

Gotcha
2010-11-30 14:05:35

Oui il y a bien un espace sans que celui-ci ne m'est était préjudiciable jusqu'à aujourd'hui.

En suivant les pistes de mko, je suis tombé sur :
http://php.net/manual/fr/function.set-m … untime.php

Reste à savoir quoi en faire...

ddtddt
2010-11-30 14:02:58

Gotcha a écrit:

J'ai besoin de pistes...

un espace dans ton nom de répertoire (chemin complet)

Gotcha
2010-11-30 12:15:19

Je fais le petit up pour dire que chez moi aussi je rencontre le même problème avec la copie local du site de mko.

J'arrive à contourner le problème mais je reste bloqué au niveau de l'identification. Impossible de se logger.
Piwigo me dit "mot de passe invalide" alors qu'il est bon et vérifié par ailleurs !

:-(

J'ai besoin de pistes...

ddtddt
2010-11-30 07:09:03

mko a écrit:

- essayé avec la version 5.2.1 le probleme reste identique (page blanche).
- essayé avec la version 3.0 phpmyadmin refuse d'importer ma bdd :(

Le problème est php pas MySql.

Cela peux provenir également du X64

Je ne peux pas essayer aujourd'hui, si tu n'as pas réusis ce soir est ce que tu peux faire un petit up ?

mko
2010-11-30 02:01:46

ddtddt a écrit:

Il me semble que tu peux réactiver la fonction set_magic_quotes_runtime() dans les extension php et cela devrais résoudre le problème

la fonction est bien activée.

mko
2010-11-30 02:00:23

Gotcha a écrit:

mko a écrit:

une idée du problème ?

Je ne sais pas mais par contre j'essayerais de trouver une version moins récente de EasyPHP.

- essayé avec la version 5.2.1 le probleme reste identique (page blanche).
- essayé avec la version 3.0 phpmyadmin refuse d'importer ma bdd :(

ddtddt
2010-11-29 21:51:34

Il me semble que tu peux réactiver la fonction set_magic_quotes_runtime() dans les extension php et cela devrais résoudre le problème

Gotcha
2010-11-29 19:51:21

mko a écrit:

une idée du problème ?

Je ne sais pas mais par contre j'essayerais de trouver une version moins récente de EasyPHP.

mko
2010-11-28 15:53:06

je viens de :

- Installer EasyPHP.
- copier tout mon site dans /rep_installation_easyphp/www
- copie de ma base de données.
- création de la table dans la bdd avec le meme nom que sur mon hébergeur.
- importation de ma bdd
- modification de mon fichier include/mysql.inc.php qui ressemble à ca :

"<?php
$cfgBase = mkofrphoto
$cfgUser = 'root';
$cfgPassword = 'mysql';
$cfgHote = 'localhost';

$prefixeTable = 'phpwebgallery_';

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

// Ligne à rajouter pour permettre la mise à jour !
define('PHPWG_IN_UPGRADE', true);
?>"

en local, je lance donc le site par F7 via mon firefox préféré, et j'obtiens cela :

Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\Program Files (x86)\EasyPHP-5.3.3.1\www\include\common.inc.php on line 31

dans le fichier commonc.inc.php j'ai ligne 31 :
set_magic_quotes_runtime(0); // Disable magic_quotes_runtime
apparemment c'est fonction n'est pas à utiliser avec la version de PHP que j'ai...
si je modifie cette ligne cela les instructions trouvées la http://www.siteduzero.com/forum-83-4458 … cated.html

=> j'arrive à une page blanche...

pour info ayant W7 64bits et easyphp 5.3.3 j'ai modifié le fichier host selon l'indication figurant là : http://fr.piwigo.org/forum/viewtopic.ph … 45&p=2 (en fait la ligne 127.0.0.1 localhost n'avait deja pas de #)

une idée du problème ?

mko
2010-11-28 15:19:05

non je n'ai pas crée mon propre theme j'ai repris un theme (yoga) et je l'ai modifié. Peut etre effectivement est de créer mon propre theme pour pouvoir faire une reinstallation sans soucis. le fichier config_local.inc.php est bien modifié par mes soins. je n'ai pas utilisé de template extension, j'ai modifié le fichier de config directement.

je viens de procéder à la sauvegarde complète de ma galerie en local. je vais tenter une mise à jour en local via EasyPHP.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact