Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Bratis
2010-11-19 19:23:54

Cool, merci à vous deux.

ce matin, j'ai eu à nouveau un moment de doute avec mes tags ... ils n'étaient, semblait-t-il, pas synchronisés. En fait, c'est picasa qui fait ce qu'il veut des tags ... il les affiche comme il faut, mais les enregistre "je sais pas où" dans le fichier ! Et l'erreur semble aléatoire, non reproductible ! Très déçu par ce logiciel. Il m'était utile pour tag et géoréférencé 10-20 photos par semaine... je vais sans doute chercher autrechose, sans attendre la version suivante.

tosca29
2010-11-19 14:20:34

Gotcha a écrit:

Bratis a écrit:

Un peu HS, désolé : Qu'utilises-tu pour lire les exif et IPTC comme cela ?

Ce n'est pas HS du tout

Au passage après ce post qui va faciliter la mise à jour de mes tags dans piwigo grace à ceux déjà renseignés dans lightroom,
voici un lien que j'utilise de temps en temps et qui permet de connaitre tout les détails d'une image..
Que ce soit en ligne ou en local ;)

Jeffrey's Exif viewer si ça peut servir à quelqu'un..
En tout cas la démarche des tags de LR dans piwigo, elle me sert :)
Merci !

Gotcha
2010-11-19 09:51:13

Bratis a écrit:

Gotcha a écrit:

Informations are read from sample.jpg


IPTC Fields in sample.jpg
2#000 = 
2#025 = 30 A 35 ANS,30-35 ANS,60 A 65 ANS,60-65
...
EXIF Fields in sample.jpg
...

Un peu HS, désolé : Qu'utilises-tu pour lire les exif et IPTC comme cela ?

Ce n'est pas HS du tout car j'ai utilisé un petit outil fourni par Piwigo. A savoir : ./tools/metadata.php

Pour l'utiliser, il suffit de déposer dans le dossier ./tools une photo renommée en "sample.jpg" et de lancer metadata.php

;-)

Bon bah par contre, pourquoi la synchronisation classique ne fonctionne pas, ca ca reste un mystère :-s

ddtddt
2010-11-18 09:07:33

Peux tu passer le sujet en résolu

Lien dans le premier post ;-)

sebaphoto
2010-11-18 08:45:07

Bonjour,

Cela fonctionne, j'ai importé de nouvelles images via ploader et c'est ok. Je vais pouvoir avancer dans la création de ma photothèque (entre 3 et 4000 photos...)
Merci à tous!

Bratis
2010-11-18 07:26:30

Gotcha a écrit:

Informations are read from sample.jpg


IPTC Fields in sample.jpg
2#000 = 
2#025 = 30 A 35 ANS,30-35 ANS,60 A 65 ANS,60-65
...
EXIF Fields in sample.jpg
...

Un peu HS, désolé : Qu'utilises-tu pour lire les exif et IPTC comme cela ?

Zaphod
2010-11-18 00:57:27

A priori la synchro ne marche que sur les catégories physiques.
En revanche en faisant éditer l'image, synchroniser, ça devrait marcher...
Mais il faut le faire pour chaque image.

Zaphod
2010-11-18 00:46:38

La synchro ça marche avec les photo envoyées via pLoader ?

Sinon moi généralement je coche aussi ça :
Ecraser les données existantes avec des données vides

Mais le problème ne doit pas venir de là.


Il faudrait essayer de transférer de nouvelles photos via pLoader voir si le mapping se fait.

Gotcha
2010-11-18 00:30:18

Bratis a écrit:

Bonjour,
Je les trouve dans les IPTC au même endroit que dans mes photos. Le mappage essayé doit être le bon.

En effet, le mappage est correct.

Informations are read from sample.jpg


IPTC Fields in sample.jpg

2#000 = 
2#025 = 30 A 35 ANS,30-35 ANS,60 A 65 ANS,60-65 ANS,AGRICULTEUR,AIDE,AUTOMNE,CASQUETTE,CEREALE,CEREALIER,CHAMP,COMBINE,CONCEPT,COUP DE MAIN,ENTRAIDE,EXPLOITATION,FILS,GENERATION,GRANDES CULTURES,HOMME,HUMAIN,MAIN D OEUVRE,MSA,NEW HOLLAND,ORGANISATION,ORGE,ORGE BRASSICOLE,ORGE DE BRASSERIE,PERE,PLAINE,RENOUVELLEMENT,RETRAITE,ROGER,SEMIS,SEMOIR,SYMBOLE,TRANSMISSION
2#055 = 20101022
2#080 = SEBASTIEN CHAMPION
2#090 = SAINT JEAN DU LIVERSAY
2#095 = 17 CHARENTES MARITIMES/POITOU CH
2#101 = FRANCE
2#105 = PERE ET FILS : TRANSMISSION D EXPLOITATION
2#116 = SEBASTIEN CHAMPION ARCHIVE
2#120 = PERE ET FILS : TRANSMISSION D EXPLOITATION


EXIF Fields in sample.jpg

Array
(
    [FileName] => sample.jpg
    [FileDateTime] => 1290034822
    [FileSize] => 253759
    [FileType] => 2
    [MimeType] => image/jpeg
    [SectionsFound] => ANY_TAG, IFD0, THUMBNAIL, EXIF
    [COMPUTED] => Array
        (
            [html] => width="800" height="533"
            [Height] => 533
            [Width] => 800
            [IsColor] => 1
            [ByteOrderMotorola] => 0
            [ApertureFNumber] => f/8.0
            [FocusDistance] => 6.51m
            [Copyright] => SEBASTIEN CHAMPION ARCHIVE
            [Thumbnail.FileType] => 2
            [Thumbnail.MimeType] => image/jpeg
        )

    [ImageDescription] => PERE ET FILS : TRANSMISSION D EXPLOITATION
    [Make] => Canon
    [Model] => Canon EOS 5D Mark II
    [XResolution] => 300/1
    [YResolution] => 300/1
    [ResolutionUnit] => 2
    [DateTime] => 2010:11:15 15:56:33
    [Artist] => SEBASTIEN CHAMPION
    [Copyright] => SEBASTIEN CHAMPION ARCHIVE
    [Exif_IFD_Pointer] => 290
    [THUMBNAIL] => Array
        (
            [Compression] => 6
            [XResolution] => 72/1
            [YResolution] => 72/1
            [ResolutionUnit] => 2
            [JPEGInterchangeFormat] => 798
            [JPEGInterchangeFormatLength] => 16925
        )

    [ExposureTime] => 1/125
    [FNumber] => 8/1
    [ExposureProgram] => 3
    [ISOSpeedRatings] => 200
    [ExifVersion] => 0221
    [DateTimeOriginal] => 2010:10:22 10:57:49
    [DateTimeDigitized] => 2010:10:22 10:57:49
    [ShutterSpeedValue] => 6965784/1000000
    [ApertureValue] => 6/1
    [ExposureBiasValue] => 1/3
    [MaxApertureValue] => 4/1
    [SubjectDistance] => 651/100
    [MeteringMode] => 5
    [Flash] => 16
    [FocalLength] => 95/1
    [SubSecTimeOriginal] => 13
    [SubSecTimeDigitized] => 13
    [FocalPlaneXResolution] => 3861000/1459
    [FocalPlaneYResolution] => 2574000/958
    [FocalPlaneResolutionUnit] => 2
    [CustomRendered] => 0
    [ExposureMode] => 0
    [WhiteBalance] => 1
    [SceneCaptureType] => 0
)

Donc je ne sais pas d'où vient le problème mais visiblement le plugin Advenced Metadata est plus performant.

Mes photos sur ma galerie proviennent toutes de Lightroom et je n'avais encore jamais vu un problème comme le votre.
Heureusement, avec Ametadata vous avez une solution :-)

Bratis
2010-11-17 22:04:05

Bonjour,
Je les trouve dans les IPTC au même endroit que dans mes photos. Le mappage essayé doit être le bon.

sebaphoto
2010-11-17 21:58:54

Les mots clés apparaissent bien dans la galerie sous la photo, en dessous du titre de la photo mais pas dans les tags.

sebaphoto
2010-11-17 21:52:50

Bonsoir,
je les ai chargées via ploader. Dans l'explorateur windows, elles ont leurs mots clés après l'export de lightroom. Est ce que cela viendrait de plaoder?

Gotcha
2010-11-17 21:04:37

sebaphoto a écrit:

Voici le lien vers ma galerie d'essai : http://photo.sebastienchampion.fr/index.php?

Merci.

Bon bah le hic c'est que je ne trouve pas de tags (mots clés) dans vos photos :-(

sebaphoto
2010-11-17 20:55:33

Voici le lien vers ma galerie d'essai : http://photo.sebastienchampion.fr/index.php?

Gotcha
2010-11-17 20:49:10

sebaphoto a écrit:

Synchroniser les informations des éléments de la base de données à partir des méta-données des fichiers Synchroniser les méta-données (filesize, width, height, high_filesize, date_creation, keywords, author, name, comment) COCHE

Donc normalement, Piwigo va chercher les tags dans vos photos si les tags se trouve bien dans l'emplacement 2#025 de vos photos.

Pourriez vous nous fournir une photo que vous n'arrivez pas à synchroniser SVP ? Merci :-)

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact