Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

grodid
2010-11-16 08:48:29

Comme je considère que la partie de la discussion dévolue à Linux-Fedora est close, je vais marquer ce topic comme résolu.

Si la saga sur OpenSUSE appelle de nouveaux développements, je pense qu'il vaudrait mieux ouvrir un nouveau fil qui lui soit consacré.

Cordialement,    G.

jdd
2010-11-13 16:38:58

c'est bien ce que j'essaie de faire.

Mais il ne semble pas y avoir de wx.pm sous openSUSE, je ne sais pas pourquoi :-(

ca m'gace d'autant plus que j'avais réussi à faire marcher ploader dans la version précédente !

grodid
2010-11-13 15:43:07

Ah bon, d'accord. Respects. Je ne voulais pas te vexer.

Mais cela ne m'explique pas pourquoi les paquets relatifs à wxPerl ne sont pas complets sous OpenSUSE.
J'ai mis très longtemps sous Fedora avant de trouver le bon paquet 'tête de liste' pour cette série de librairies,
et AMHA, c'est le même pb dans ton cas, rien de plus.

Je suis de plus persuadé que ça serait cool d'ajouter la liste des paquets OpenSUSE à cette série de posts, pour élargir les
plateformes possibles pour pLoader dans le monde Linux.

G.

jdd
2010-11-13 15:03:51

t'inquiète pas, je fais partie des fondateurs d'openSUSE, je connais bien :-).

En fait, ce qu'il faudrait c'est une version compilée en statique, qui intègre toutes les libraries (sauf gcc), comme pour windows.

grodid
2010-11-13 14:32:37

Oui, je vois un peu ce qui t'arrive ...

Est-ce que tu utilises YaST sur OpenSUSE ?
Quelle version de OpenSUSE utilises-tu ?
Pourrais-tu parcourir en vitesse ce lien : http://en.opensuse.org/Package_management ?

En gros, il va falloir, à partir de la liste fournie par Clément (voir ma 1ère réponse) que tu devines le nom
des paquets YaST que tu dois installer, et que tu complètes après avec ce qui manquera.

Je ne peux guère t'aider plus, je n'ai pas d'OpenSUSE sous la main ...

Si qqun pouvait nous aider à traduire le nom des paquets Ubuntu ou Fedora en OpenSUSE ...

G.

jdd
2010-11-13 14:19:01

grodid a écrit:

Hummm ...
As-tu installé les RPMs dont j'ai fourni la liste ?
Dans cette dernière, c'est wxGTK-devel qui est mentionné : est-il installé ?
Si tu utilises yum (ou son équivalent sur Suse que je ne connais pas), les dépendences sont résolues automatiquement.

G.

je n'ai pas les mêmes paquets... pas de wx-base, par exemple. j'ai installé tout ce qui ressemble à wx :-)

et je n'ai wx.pm dans aucun paquet, il faut que je l'installe depuis cpan, mais il a lui-meme d'autres dépendances...

grodid
2010-11-13 14:13:07

Hummm ...
As-tu installé les RPMs dont j'ai fourni la liste ?
Dans cette dernière, c'est wxGTK-devel qui est mentionné : est-il installé ?
Si tu utilises yum (ou son équivalent sur Suse que je ne connais pas), les dépendences sont résolues automatiquement.

G.

jdd
2010-11-13 14:03:16

grodid a écrit:

Je confirme que c'est bien la commande à utiliser depuis le dossier src.

G.

ok.

le message, c'est ca:

perl ./ploader.pl
Can't locate Wx.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.12.1 /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.1 /usr/lib/perl5/5.12.1/i586-linux-thread-multi /usr/lib/perl5/5.12.1 .) at ./ploader.pl line 23.
BEGIN failed--compilation aborted at ./ploader.pl line 23.

à priori tous les modules wx sont installés, peut-être une version trop vieille?:

wxGTK
Version: 2.8.10.1-11.2

si j'essaie d'installer wx.pm depuis le web, ca m'entraine dans une chaine de dépendances à résoudre trop complexe pour moi (pour le moment)

merci
jdd

grodid
2010-11-13 13:24:16

Je confirme que c'est bien la commande à utiliser depuis le dossier src.

G.

jdd
2010-11-13 11:37:40

ouf...

merci, je vais voir, j'en ai sans doute déjà la plupart d'installés

Peux-tu me donner quelques indications sur la façon de lancer ploader à partir de cette version svn?

perl ./ploader.pl s'arrète sans rien donner sauf un message d'erreur (que je peux recopier si c'est bien ca su'il faut faire)

merci

grodid
2010-11-13 11:12:33

Oui, bon, j'ai trop tardé, enfin voilà :

- faire l'import par svn de la dernière version taggée (cf plg ci-dessus)

- la liste des rpm fournie par Clément ici : http://fr.piwigo.org/forum/post.php?tid … qid=129253
est parfaite, sauf qu'elle concerne Ubuntu et que le nom des paquets est différent  =(

Ce jour là, j'ai du installer les paquets suivants :

Oct 05 20:28:29 Installed: wxBase-2.8.11-1.fc11.i586
Oct 05 20:28:33 Installed: wxGTK-2.8.11-1.fc11.i586
Oct 05 20:28:34 Installed: wxGTK-media-2.8.11-1.fc11.i586
Oct 05 20:28:34 Installed: 1:perl-ExtUtils-ParseXS-2.18-82.fc11.i586
Oct 05 20:28:37 Installed: 4:perl-devel-5.10.0-82.fc11.i586
Oct 05 20:28:39 Installed: perl-Test-Harness-3.16-82.fc11.i586
Oct 05 20:28:42 Installed: perl-ExtUtils-MakeMaker-6.36-82.fc11.i586
Oct 05 20:28:46 Installed: perl-Wx-0.91-5.fc11.i586
Oct 05 20:33:37 Installed: perl-File-Slurp-9999.13-5.fc11.noarch
Oct 05 20:41:20 Installed: perl-File-HomeDir-0.84-1.fc11.noarch
Oct 05 20:41:20 Installed: perl-Class-Accessor-0.31-5.fc11.noarch
Oct 05 21:04:17 Installed: perl-JSON-2.15-5.fc11.noarch
Oct 05 21:14:41 Installed: perl-Crypt-DES-2.05-8.fc11.i586
Oct 05 21:14:41 Installed: perl-Crypt-CBC-2.29-2.fc11.noarch
Oct 05 21:22:59 Installed: perl-MD5-2.03-3.fc11.noarch
Oct 05 21:40:36 Installed: perl-Image-ExifTool-8.00-1.fc11.noarch
Oct 05 21:44:20 Updated: ImageMagick-6.5.1.2-2.fc11.i586
Oct 05 21:44:21 Installed: ImageMagick-perl-6.5.1.2-2.fc11.i586
Oct 05 22:19:12 Installed: xorg-x11-proto-devel-7.4-15.fc11.noarch
Oct 05 22:19:16 Installed: freetype-devel-2.3.9-5.fc11.i586
Oct 05 22:19:16 Installed: libXau-devel-1.0.4-5.fc11.i586
Oct 05 22:19:16 Installed: libXdmcp-devel-1.0.2-8.fc11.i586
Oct 05 22:19:49 Installed: docbook-style-xsl-1.75.2-1.fc11.noarch
Oct 05 22:19:49 Installed: pixman-devel-0.14.0-2.fc11.i586
Oct 05 22:19:50 Installed: libdrm-devel-2.4.11-2.fc11.i586
Oct 05 20:28:42 Installed: perl-ExtUtils-MakeMaker-6.36-82.fc11.i586
Oct 05 20:28:46 Installed: perl-Wx-0.91-5.fc11.i586
Oct 05 20:33:37 Installed: perl-File-Slurp-9999.13-5.fc11.noarch
Oct 05 20:41:20 Installed: perl-File-HomeDir-0.84-1.fc11.noarch
Oct 05 20:41:20 Installed: perl-Class-Accessor-0.31-5.fc11.noarch
Oct 05 21:04:17 Installed: perl-JSON-2.15-5.fc11.noarch
Oct 05 21:14:41 Installed: perl-Crypt-DES-2.05-8.fc11.i586
Oct 05 21:14:41 Installed: perl-Crypt-CBC-2.29-2.fc11.noarch
Oct 05 21:22:59 Installed: perl-MD5-2.03-3.fc11.noarch
Oct 05 21:40:36 Installed: perl-Image-ExifTool-8.00-1.fc11.noarch
Oct 05 21:44:20 Updated: ImageMagick-6.5.1.2-2.fc11.i586
Oct 05 21:44:21 Installed: ImageMagick-perl-6.5.1.2-2.fc11.i586
Oct 05 22:19:12 Installed: xorg-x11-proto-devel-7.4-15.fc11.noarch
Oct 05 22:19:16 Installed: freetype-devel-2.3.9-5.fc11.i586
Oct 05 22:19:16 Installed: libXau-devel-1.0.4-5.fc11.i586
Oct 05 22:19:16 Installed: libXdmcp-devel-1.0.2-8.fc11.i586
Oct 05 22:19:49 Installed: docbook-style-xsl-1.75.2-1.fc11.noarch
Oct 05 22:19:49 Installed: pixman-devel-0.14.0-2.fc11.i586
Oct 05 22:19:50 Installed: libdrm-devel-2.4.11-2.fc11.i586
Oct 05 22:19:50 Updated: 2:libpng-1.2.43-1.fc11.i586
Oct 05 22:20:18 Updated: fontconfig-2.8.0-1.fc11.i586
Oct 05 22:20:27 Installed: glib2-devel-2.20.5-1.fc11.i586
Oct 05 22:20:28 Updated: libxcb-1.2-5.fc11.i586
Oct 05 22:20:29 Installed: wxGTK-gl-2.8.11-1.fc11.i586
Oct 05 22:20:31 Installed: opensp-1.5.2-11.fc11.i586
Oct 05 22:20:34 Installed: openjade-1.3.2-34.fc11.i586
Oct 05 22:20:35 Installed: gc-7.1-7.fc11.i586
Oct 05 22:20:41 Installed: fontconfig-devel-2.8.0-1.fc11.i586
Oct 05 22:20:42 Installed: 2:libpng-devel-1.2.43-1.fc11.i586
Oct 05 22:20:43 Installed: w3m-0.5.2-13.fc11.i586
Oct 05 22:20:43 Installed: perl-SGMLSpm-1.03ii-19.fc11.noarch
Oct 05 22:20:49 Installed: docbook-style-dsssl-1.79-6.fc11.noarch
Oct 05 22:20:50 Installed: docbook-utils-0.6.14-17.fc11.noarch
Oct 05 22:20:51 Installed: gtk-doc-1.11-4.fc11.noarch
Oct 05 22:20:53 Installed: atk-devel-1.25.2-2.fc11.i586
Oct 05 22:20:55 Installed: libxcb-devel-1.2-5.fc11.i586
Oct 05 22:21:06 Installed: libX11-devel-1.2.2-1.fc11.i586
Oct 05 22:21:07 Installed: libXext-devel-1.0.99.1-3.fc11.i586
Oct 05 22:21:07 Installed: libXfixes-devel-4.0.3-5.fc11.i586
Oct 05 22:21:07 Installed: libXrender-devel-0.9.4-5.fc11.i586
Oct 05 22:21:09 Installed: cairo-devel-1.8.8-1.fc11.i586
Oct 05 22:21:10 Installed: libXcursor-devel-1.1.9-4.fc11.i586
Oct 05 22:21:10 Installed: libXft-devel-2.1.13-2.fc11.i586
Oct 05 22:21:12 Installed: pango-devel-1.24.5-1.fc11.i586
Oct 05 22:21:12 Installed: libXrandr-devel-1.2.99.4-3.fc11.i586
Oct 05 22:21:13 Installed: libXcomposite-devel-0.4.0-7.fc11.i586
Oct 05 22:21:13 Installed: libXdamage-devel-1.1.1-6.fc11.i586
Oct 05 22:21:14 Installed: libXi-devel-1.2.1-1.fc11.i586
Oct 05 22:21:14 Installed: libXinerama-devel-1.0.3-4.fc11.i586
Oct 05 22:21:14 Installed: libXxf86vm-devel-1.0.2-2.fc11.i586
Oct 05 22:21:23 Installed: gtk2-devel-2.16.6-2.fc11.i586
Oct 05 22:21:29 Installed: mesa-libGL-devel-7.6-0.1.fc11.i586
Oct 05 22:21:30 Installed: mesa-libGLU-devel-7.6-0.1.fc11.i586
Oct 05 22:21:38 Installed: wxGTK-devel-2.8.11-1.fc11.i586

en ordre inverse, bien sûr.

S'il y a un pb avec les dépôts, faire signe.

J'espère que cela pourra aider.       G.

jdd
2010-11-13 10:22:33

Bonjour,
As-tu fait ton howto? je n'arrive pas à le faire tourner sur openSUSE et ca ne doit pas être très différent de fedora
merci
jdd

plg
2010-10-07 21:03:29

grodid a écrit:

PS Je marquerai cette discussion comme résolue qd j'aurais fourni le How-to.

super, merci grodid

grodid
2010-10-07 21:00:42

Oui, merci, c'était ça la bêtise.

Je vais m'efforcer de publier un petit How-to pour expliquer en détails l'installation de pLoader sur Linux-Fedora
(le nom des paquets à installer n'est pas du tout intuitif ;-)

Bravo à toute l'équipe,   G.

PS Je marquerai cette discussion comme résolue qd j'aurais fourni le How-to.

plg
2010-10-06 21:42:24

C'est parce que tu as fait un export SVN d'une version de développement qui n'est pas stable. Refait un export :

Code:

svn export http://piwigo.org/svn/extensions/pLoader/tags/1.6

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact