Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Gotcha
2010-08-01 00:15:24

P@t a écrit:

Pas d'installation auto de plugin en 1.7 gotcha!

Ok P@t.

cemoi
2010-07-31 19:22:25

>>>> Pas d'anomalie détectée après la mise à jour de l'application, le plugin "Check upgrades" a été désactivé.

Done!

Merci pour votre aide!

ps: http://cemoi2005.free.fr/gallerie/index.php?

cemoi
2010-07-31 19:09:04

le plugin semble compatible 1.7.0 ma version est bien celle là:

Version de PhpWebGallery

        * PhpWebGallery 1.7.0

j'ai télécharger ce plugin là: http://fr.piwigo.org/ext/extension_view.php?eid=302

la version 1.7.0 est incluse dedans:

Compatible avec: Piwigo releases 1.7.0, 1.7.1, 1.7.2, 1.7.3, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9, 2.0.10, 2.1.0, 2.1.1

Par contre c'est phpmygallery mais je presume que la denomination n'a que peu d'importance.

Ca donne toujours le même message d'erreure quand j'active le plugin je passe par cette page là:

http://matlane2000.free.fr/divers/vrac/ … allery.png

Il faut installer manuellement?

[edit]

je viens de comprendre! faut utiliser cette version du plugin:
http://fr.piwigo.org/ext/extension_view.php?eid=302

.... donc ça fait une difference entre phpmygallerie et piwigo

Merci.

P@t
2010-07-31 18:21:33

Pas d'installation auto de plugin en 1.7 gotcha!
Cemoi, attention de bien installer la version d'autoupdate compatible 1.7.x

Gotcha
2010-07-31 16:30:05

Je parlais du plugin Autoupgrade ^^
Pour installer un plugin depuis votre galerie, il faut aller :
[ Administration >> Plugins >> Gérer > Onglet "Autres plugins disponibles".

Est-ce votre migration c'est bien terminée ??

cemoi
2010-07-31 16:22:00

Merci beaucoup pour votre aide ça a effectivement fonctionné. Par contre je ne comprend pas bien votre dernière phrase: "Il conviendra de le réinstaller mais cette fois, en passant par Piwigo."

C'est ce que j'ai fait il me semble... voici ce que j'ai fait:

1- téléchargement de l'archive autoupdate.zip
2-desarchivement du fichier *.zip
3-upload du repertoire autoupdate dans le repertoire distant /plugins (par ftp)
4-connexion à phpwebgallery comme administrateur
5-Suivi de l'instruction donné ici: (http://fr.piwigo.org/basics/upgrade_automatic).
j'ai fait ça pour etre exact : Administration > Spéciales > Plugins > Administration et cliquez sur l'action installer sur la ligne du plugin Piwigo AutoUpgrade puis sur l'action Activer.

Au moment ou j'ai activé le plugin je n'ai plus eu accé à la partie administration avec le message:
Fatal error: Call to undefined function load_language() in /mnt/118/sdb/6/b/cemoi2005/gallerie/plugins/autoupdate/main.inc.php on line 22

Cette procédure n'est pas celle d'une installation du plugin en passant par phpwebgallery? Je vois pas tres bien comment faire du coup.

En vous remerciant de votre aide si précieuse.

Gotcha
2010-07-31 15:30:22

On va le désinstaller proprement...

Dans votre BDD, dans la table piwigo_plugins trouvez la ligne concernant "autoupdate". Sur cette ligne, éditez-là pour rendre le plugin "inactif".
Normalement, ça devrait suffire à vous redonnez la main sur la partie d'administration.

Une fois de retours dans votre administration, désinstallez le plugin.
Il conviendra de le réinstaller mais cette fois, en passant par Piwigo.

cemoi
2010-07-31 14:26:22

bonjour merci pour ces réponses j'ai fait le fichier .htacces pour passer en php5 apres verification c'est bon.

j'ai télécharger le plugin autoupdate et desarchivé ce dernier dans le reperoire /plugin de phpwebgallery
de là j'ai installer le plugin en passant par le panneau d'administration puis je l'ai activé.

au rechargement de la page du à l'activation du plugin je n'ai plus accé à la partie d'administration ça donne ça comme message:

Fatal error: Call to undefined function load_language() in /mnt/118/sdb/6/b/cemoi2005/gallerie/plugins/autoupdate/main.inc.php on line 22

sur la ligne 22 de ce fichier il y a ça:

  load_language('plugin.lang', dirname(__FILE__).'/');

es qu'il me faut préciser la langue dans le ficheir main.inc.php sur la ligne 22?

merci pour votre aide

Gotcha
2010-07-31 12:25:22

Ensuite, regarde ce sujet : topic:18038

Gotcha
2010-07-31 12:18:57
cemoi
2010-07-31 12:13:16

Merci je n'avais pas bien regardé le wiki ...

j'ai fait l'étape trois mais l'hébergement de free gratos ne remplit pas les conditions (php5+mysql5) j'ai ça;

Version de PhpWebGallery

        * PhpWebGallery 1.7.0
        * Dernière version ?

Environnement

        * System d'exploitation: Linux
        * PHP: 4.4.3-dev (Montrer les informations) [2010-07-31 12:02:15]
        * MySQL: 5.0.83-log [2010-07-31 12:02:15]


Es possible de upgrader quand meme?

Je me suis aventurer à tenter l'upgrade mais je ne peux pas exécuter le script prep21up.php ça donne ça comme message:

sur l'url http://monsite.fr/gallerie/prep21up.php

You must be connected as webmaster to run this script

je me suis connecté comme administrateur sur phpwebgallerie avant de tapre l'url.

quand je me connecte avec filezillz sur mon compte ftp je regarde les droits du fichiers  prep21up.php et ils sont: -rw-r--r--

forcément je suppose que ça pose un probléme car le fichier n'a pas les droits d'exécution je veux pour changer les droits sur ce fichier et là je m'apercçois que ce n'est pas possible ...

dans les log de filezilla ça donne ça:

Statut :    Définir les permissions de '/gallerie/prep21up.php' à '744'
Commande :    CWD /gallerie
Réponse :    250 CWD command successful.
Commande :    SITE CHMOD 744 prep21up.php
Réponse :    500 'SITE': command unrecognized.

:/

pour precision je suis en 1.7 et pas en 1.6.1 j'avais du upgradé 2fois ou trois fois déja...


Merci pour votre aide

rio
2010-07-30 23:12:41

http://fr.piwigo.org/basics/upgrade_manual
Étape 3, c'est expliqué.
Si tu as un doute, tu n'est pas sur, reviens et on voit ça ensemble ... avant de faire une bêtise ... :-))

:-))

cemoi
2010-07-30 19:32:26

Bonjour,
j'ai installé PhpWebGallery sur un compte free en 2000 une version 1.x.x (ça date je ne me rappel plus exactement) que j'ai déja upgradé en 1.4 puis en 1.6.1
J'avais fait un post à l'époque pour le passage de la 1.4 à la 1.6.1:
http://fr.piwigo.org/forum/viewtopic.php?id=8892

J'ai cherché dans les extension pour la migration et j'ai trouvé celle ci:
http://fr.piwigo.org/ext/extension_view.php?eid=391

Il n'ya que 2 fichiers dans l'archive et aucun readme...


Es la meilleure solution (dans le sens de la fiabilité) pour migré et si oui ou faut il mettre le fichier .php?

merci pour vos lumières.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact