Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

tosca
2010-07-07 17:27:17

Merci.

plg
2010-07-07 16:51:08

Code:

--- themes/default/template/header.tpl
+++ themes/default/template/header.tpl
@@ -5,7 +5,7 @@
 <meta name="generator" content="Piwigo (aka PWG), see piwigo.org">
 {if isset($meta_ref) } 
 {if isset($INFO_AUTHOR)}
-<meta name="author" content="{$INFO_AUTHOR|@replace:'"':' '}">
+<meta name="author" content="{$INFO_AUTHOR|@strip_tags:false|@replace:'"':' '}">
 {/if}
 {if isset($related_tags)}
 <meta name="keywords" content="{foreach from=$related_tags item=tag name=tag_loop}{if !$smarty.foreach.tag_loop.first}, {/if}{$tag.name}{/foreach}">
=== admin/picture_modify.php
==================================================================
--- admin/picture_modify.php 
+++ admin/picture_modify.php
@@ -236,7 +236,11 @@
 
     'REGISTRATION_DATE' => format_date($row['date_available']),
 
-    'AUTHOR' => isset($_POST['author']) ? $_POST['author'] : @$row['author'],
+    'AUTHOR' => htmlspecialchars(
+      isset($_POST['author'])
+        ? stripslashes($_POST['author'])
+        : @$row['author']
+      ),
 
     'DESCRIPTION' =>
       htmlspecialchars( isset($_POST['description']) ?
=== admin/element_set_unit.php
==================================================================
--- admin/element_set_unit.php
+++ admin/element_set_unit.php
@@ -67,7 +67,7 @@
     $data['author'] = $_POST['author-'.$row['id']];
     $data['level'] = $_POST['level-'.$row['id']];
 
-    foreach (array('name', 'author', 'level') as $field)
+    foreach (array('name', 'level') as $field)
     {
       if (!empty($_POST[$field.'-'.$row['id']]))
       {
@@ -238,7 +238,7 @@
             PHPWG_ROOT_PATH.'admin.php?page=picture_modify'.
             '&amp;image_id='.$row['id'],
         'NAME' => !empty($row['name'])?$row['name']:'',
-        'AUTHOR' => !empty($row['author'])?$row['author']:'',
+        'AUTHOR' => !empty($row['author'])?htmlspecialchars($row['author']):'',
         'LEVEL' => !empty($row['level'])?$row['level']:'0',
         'DESCRIPTION' => !empty($row['comment'])?$row['comment']:'',
         'DATE_CREATION_YEAR' => $year,
tosca
2010-07-07 09:44:07

plg a écrit:

Bon alors, j'ai une modif en local pour gérer le HTML dans le champ auteur. Mais j'hésite un peu à commiter... (je continue à réfléchir sur le sujet)

Peux-tu communiquer le code pour que j'applique le patch de mon côté.
Ca devient ingérable de perdre mes modifications à chaque fois que j'interviens en mise à jour sur une photo, ne serait-ce que pour ajouter un tag, ou l'affecter à une catégorie :/
Merci.

plg
2010-07-02 14:09:02

Sachant en fait que là, si on passe par picture_modify, on peut mettre du HTML et si on passe par element_set_unit, le HTML est automatiquement retiré. Ce n'est pas cohérent.

plg
2010-07-02 13:44:26

VDigital a écrit:

A nous de gérer le lien dans la base.

Je ne comprends pas ce que tu veux dire. Je pense que tu parles de la future implémentation de "Navigation par auteur" (je vais la faire pour la 2.2 je pense, tu fais parti de ceux qui la demande depuis un moment d'ailleurs).

J'ai un peu avancé dans ma réflexion et faut pas se prendre la tête. Là on peut déjà mettre du HTML dans le champ auteur, c'est juste qu'il ne s'affiche plus correctement dans le formulaire ensuite. C'est donc un petit bug, je vais le corriger. [Bugtracker] ticket 1757

tosca
2010-07-02 13:40:30

VDigital a écrit:

plg a écrit:

Bon alors, j'ai une modif en local pour gérer le HTML dans le champ auteur. Mais j'hésite un peu à commiter. Dans la mesure où je voudrais aussi très bientôt faire un système "navigation par auteur" et que je crains que si des gens aujourd'hui mettent du HTML dans le champ auteur, alors demain ça fasse un peu n'importe quoi pour le "navigation par auteur". (je continue à réfléchir sur le sujet)

A nous de gérer le lien dans la base.

Voir également post:147453
Je ne sais pas dans quelle mesure c'est lié, mais ça ressemble étrangement : on perd du code à la suite de caractères spéciaux.

VDigital
2010-07-02 13:37:58

plg a écrit:

Bon alors, j'ai une modif en local pour gérer le HTML dans le champ auteur. Mais j'hésite un peu à commiter. Dans la mesure où je voudrais aussi très bientôt faire un système "navigation par auteur" et que je crains que si des gens aujourd'hui mettent du HTML dans le champ auteur, alors demain ça fasse un peu n'importe quoi pour le "navigation par auteur". (je continue à réfléchir sur le sujet)

A nous de gérer le lien dans la base.

plg
2010-07-02 13:31:06

Bon alors, j'ai une modif en local pour gérer le HTML dans le champ auteur. Mais j'hésite un peu à commiter. Dans la mesure où je voudrais aussi très bientôt faire un système "navigation par auteur" et que je crains que si des gens aujourd'hui mettent du HTML dans le champ auteur, alors demain ça fasse un peu n'importe quoi pour le "navigation par auteur". (je continue à réfléchir sur le sujet)

plg
2010-07-01 10:00:57

tosca a écrit:

On peut recenser ce qui ne va pas dans le même style et ouvrir un bug ?

Oui, j'ai constaté ça et ce n'est pas très pratique. Je suis certain que ça marchait avant.

tosca
2010-07-01 07:44:37

Gotcha a écrit:

J'ai observé le même comportement mais avec Additionnal Page.
Le code inséré fonctionne, il est bien enregistré dans la BDD mais lors de l'affichage du champs, bah... ça coince...

Je ne vois pas de raison pour que ça reste comme ça :/
On peut recenser ce qui ne va pas dans le même style et ouvrir un bug ?

Gotcha
2010-07-01 00:56:09

J'ai observé le même comportement mais avec Additionnal Page.
Le code inséré fonctionne, il est bien enregistré dans la BDD mais lors de l'affichage du champs, bah... ça coince...

:-/

tosca
2010-06-30 09:06:27

Re-testé après mise en place de la 2.1.2, pensant que la correction de [Bugtracker] ticket 1705 améliorerait les choses, mais aucun changement pour le champ auteur :/

tosca
2010-06-30 07:38:40

Rectificatif : ce ne sont apparemment pas les balises HTML qui posent problème, mais la gestion des guillemets dans le champ auteur (seulement dans celui-là ?).

Exemples ci-dessous :
- police graissée avec balises HTML
- guillemets
- quotes

Le 1er et le 3è sont bien gérés ; seuls la version avec guillemets est mal restituée lors du réaffichage des informations de la photo.

tosca
2010-06-30 00:28:34

Pour cette catégorie, le champ auteur des photos est un hyperlien.

Pas de souci particulier pour saisir le lien.
Par contre, au réaffichage, le contenu du champ est tronqué (apparemment au premier '\' d'échappement) ; il est donc impossible de re-modifier les informations de la photo sans être obligé de resaisir en totalité le contenu du champ auteur.

Pourrait-on rectifier ce comportement, pour que le contenu du champ de formulaire reflète bien la totalité de ce qui est enregistré dans la base.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact