Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

tosca
2010-04-03 19:13:42

Gotcha a écrit:

@Tosca : compare ce que vient de me donner Grum avec ce que j'avais.
Et je vois que mon intuition n'était pas mauvaise.

Vu

Gotcha a écrit:

En fait, je m'aperçois que $ROOT_URL n'est pas forcément renseigné et même qu'elle est pratiquement tout le tout vide.
Encore un coup de PHP qui doit remplir cette variable sous certaines conditions ^^

Je pense que PHP ne doit pas être tout seul sur ce coup-là ... il y a bien un développeur qui y est pour quelque chose ;-)

Gotcha
2010-04-03 19:05:29

@Tosca : compare ce que vient de me donner Grum avec ce que j'avais.
Et je vois que mon intuition n'était pas mauvaise.

Bon, le comportement est toujours aussi étrange mais pour la question, le sujet est résolu.
Merci Grum.

En fait, je m'aperçois que $ROOT_URL n'est pas forcément renseigné et même qu'elle est pratiquement tout le tout vide.
Encore un coup de PHP qui doit remplir cette variable sous certaines conditions ^^

grum
2010-04-03 19:01:26

tu devrais avoir :

Code:

#scrolltotop {ldelim} bottom:14px; position:fixed; right:0; z-index:1000; opacity:0; {rdelim}
#scrolltotop a {ldelim} background-color:transparent;
  background-image: url("{$ROOT_URL}themes/{$themeconf.name}/images/top.png");
  background-position:left top; background-repeat:no-repeat; display:block;
  height:50px; text-indent:-9999px; width:44px; border:0; {rdelim}

sinon çà va pas bien marcher.

tosca
2010-04-03 18:59:20

Gotcha a écrit:

Ce qui est "étrange" ce sont ces accolades fermantes qui clos l'instruction l'instruction CSS sans trouvé celle qui ouvre...

Pas trouvé de laquelle tu parles ...

tosca
2010-04-03 18:57:36

grum a écrit:

sinon, après un {ldelim} il ne faut pas pas un {rdelim} ?

+1
ldelim = left delimitor = délimiteur de gauche
rdelim = right delimitor = délimiteur de droite
;-)

Gotcha
2010-04-03 18:53:05

Ok, Firebug me trouve bien l'icône, juste qu'elle ne s'affiche pas alors qu'elle est chargé. Mais ça, ca doit venir d'ailleurs, je commence seulement à adapter mes tpl.

En cherchant je suis tombé sur ça : http://www.smarty.net/manual/fr/languag … ldelim.php
Mais sans trop comprendre ce que je lis, je ne suis pas encore arrivé à obtenir quelque chose de favorable.

Ce qui est "étrange" ce sont ces accolades fermantes qui clos l'instruction l'instruction CSS sans trouvé celle qui ouvre... à moins que ce soit justement en rapport avec {ldelim}...

grum
2010-04-03 18:47:17

essaye

Code:

url("{$ROOT_URL}themes/{$themeconf.name}/images/top.png");

sinon, après un {ldelim} il ne faut pas pas un {rdelim} ?

Gotcha
2010-04-03 18:41:29

Merci Grum. J'avais bien vu mon erreur sur le "themes" mais je pensais que l'on pourrait appeler la variable $themeconf.parent en même temps ^^

Bon ça déjà c'est fair merci.

Par contre, la ligne

Code:

  background-image: url("{$ROOT_URL}/themes/{$themeconf.name}/images/top.png");

... ça ne m'aide pas :-(

grum
2010-04-03 18:32:22

Code:

{known_script id="jquery" src=$ROOT_URL|cat:"themes/default/js/jquery.packed.js"}

çà devrait être mieux

Gotcha
2010-04-03 17:57:09

Je suis en train d'adapter mes templates-extensions pour la version 2.1 afin de sortir mon propre thème.

Je me heurte à une difficulté (le code et moi...) qui se porte sur la variable $ROOT_URL dans mon footer.tpl

Extrait :

Code:

{* $ Id: footer.tpl 2010-04-03 Par Gotcha pour son thème "Sobre" $ *}
{known_script id="jquery" src=$ROOT_URL|@cat:"theme/{$themeconf.parent}/js/jquery.packed.js"}
 
<style type="text/css" media="screen">
#scrolltotop {ldelim} bottom:14px; position:fixed; right:0; z-index:1000; opacity:0; }
#scrolltotop a {ldelim} background-color:transparent;
  background-image: url("{$ROOT_URL}/themes/{$themeconf.name}/images/top.png");
  background-position:left top; background-repeat:no-repeat; display:block;
  height:50px; text-indent:-9999px; width:44px; border:0; }
</style>

Ce code ne fonctionne pas et évidement j'aimerai pourtant m'en servir lol

Est-ce que quelqu'un peux me sortir de l'embarras ?
Merci.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact