Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Gotcha
2010-03-03 20:21:48

Je m'en étais ouvert à plg en privé ce problème des "versions" entre ce qu'affichent les plugins et la réalité.

Eric
2010-03-03 18:30:14

En règle générale, les plugins sont tous compatibles avec les versions 2.0.x car il ne s'agit pas d'un changement de version majeure de Piwigo mais la correction de quelques bugs ou l'amélioration de fonctionnalités.

Mais il est vrai que le gestionnaire de plugins (PEM) n'est pas très "facile" quant à la mise à jour des compatibilités des plugins avec les versions de Piwigo.

[edit] Zut ! grillé... [/edit]

P@t
2010-03-03 18:28:48

Pas de soucis, c'est meme à priori 100% des extensions compatibles 2.0.8 qui sont compatibles avec la 2.0.9.
C'est valable en général pour les extensions compatibles 2.0.x....

Pour installer un plugin, un conseil, passe par l'installation automatique (panneau d'admin de ta galerie  => plugins => autre plugins disponibles)

datajulien
2010-03-03 17:56:47

Je dirais C, 99% des extensions compatibles 2.0.8 doivent etre compatibles 2.0.9

Photos of Vietnam
2010-03-03 17:45:38

La version 2.0.9 de Piwigo vient de sortir, donc forcément, il n'y a presque aucune extension compatible dans la rubrique "Extensions" du site. Que choisissez-vous ?

A - Je reste en 2.0.8 en attendant que les extensions soient compatibles avec la version suivante (avantages : on a toutes les extensions que l'on souhaite et aucun problème de compatibilité ; inconvénients : on n'a pas la dernière version tout de suite).

B - Je passe en 2.0.9 et j'attends que chaque extension 2.0.8 soit mise à jour pour 2.0.9 avant de l'utiliser (avantages : on a la dernière version tout de suite, et on ne perd pas de temps à chercher d'où vient une erreur à cause d'une incompatibilité ; inconvénients : il faut attendre les MAJ de chaque extension).

C - Je passe en 2.0.9 et j'utilise les extensions 2.0.8 (avantages : on a la dernière version tout de suite sans se priver des extensions ; inconvénients : s'il y a un problème de compatibilité on va perdre du temps, surtout si on ne connaît pas beaucoup le php, mais les puristes diront que c'est l'occasion d'apprendre...).

D - Je passe en 2.0.9 et je mets à jour moi-même les extensions dont j'ai besoin (pour ceux qui maîtrisent le php et qui ont du temps devant eux).

Pour que cette question serve à long terme, j'aimerais généraliser aux cas suivants. Quelle solution privilégier pour :
- le passage d'une version x.y.z à une version x.y.(z+1) (comme dans le cas présent) ;
- le passage d'une version x.y.z à une version x.(y+1).0 (comme ce sera le cas en avril d'après la dernière annonce) ;
- le passage d'une version x.y.z à une version (x+1).0.0 (comme lorsque sortira Piwigo 3.0) ?

Si vous avez des recommandations générales à suivre (du genre : "pour tel type de migration, on peut réutiliser les outils sans trop de problème mais pas les templates") ou si vous voyez d'autres arguments concernant les quatre solutions proposées (genre : "A c'est nul parce que si tout le monde faisait ça il y aurait plus personne pour développer Piwigo", ou encore "Moi je fais C et ce qui ne marche pas je supprime et si je ne trouve pas ce qui ne marche pas je supprime tout"), allez-y...

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact