Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

jauphrwa
2019-11-03 20:36:45

Mat9 a écrit:

Merci @jauphrwa !

Pour résumer : modifier le fichier "include/constants.php" pour remplacer la valeur de "PHPWG_VERSION" par "2.9.9" (et pas seulement "2.9" !) au lieu de "2.10.1".

Et suivre la correction du bug dans Digikam : https://bugs.kde.org/show_bug.cgi?id=412944

Pas exactement !

Modifier le fichier Piwigo include/ws_functions/pwg.php à la ligne 127 pour que la fonction ws_getVersion() (API pwg.getVersion) renvoie '2.9.9' à la place de l'originale PHPWG_VERSION :

Code:

function ws_getVersion($params, &$service)
{
  //return PHPWG_VERSION;
  // erAck: digikam Piwigo export plugin is stupid, 2.10.1 < 2.4 ...
  return '2.9.9';
}

Attention, certain API vont tout de même renvoyer la version installée mais nous voilà avec un upload depuis Digikam rétabli ! ;-)

Mat9
2019-11-03 19:17:10

Merci @jauphrwa !

Pour résumer : modifier le fichier "include/constants.php" pour remplacer la valeur de "PHPWG_VERSION" par "2.9.9" (et pas seulement "2.9" !) au lieu de "2.10.1".

Et suivre la correction du bug dans Digikam : https://bugs.kde.org/show_bug.cgi?id=412944

jauphrwa
2019-11-03 17:47:11

Si quelqu'un cherche encore, voici une solution temporaire :
https://piwigo.org/forum/viewtopic.php? … 65#p174665

jauphrwa
2019-11-03 15:55:22

Aaargh !
Anthony (Nuxien), comment as-tu fait?

Nicolas Gehin
2019-10-29 00:09:38

Bonjour

Idem que Mat9...

Bug avec l'envoi depuis Digikam 5.9 et 6.2

Et je suis moi aussi très intéressé par la solution de Nuxien !

Nicolas Gehin
2019-10-29 00:05:50

Idem

Mat9
2019-10-28 07:52:38

Bonjour,
Sur digiKam version 5.9.0.
Merci

k5
2019-10-27 20:55:48

Bonjour,
Sur digikam ?
cordialement
K5

Mat9
2019-10-27 19:10:39

Comment as-tu fait Nuxien ?

Quand j'essaye d'uploader les photos depuis Digikam dans Piwigo, il ne charge plus l'arborescence des dossiers de mon Piwigo, mais affiche le message suivant :

Impossible de se connecter au serveur distant « Piwigo ». L'import vers les versions < 2.4 de Piwigo n'est plus géré
Voulez-vous vérifier vos paramètres et réessayer ?

J'ai essayé de modifier le fichier "include/constants.php" la valeur de "PHPWG_VERSION" pour "2.9" au lieu de "2.10.1", mais c'est pire :

Impossible de se connecter au serveur distant « Piwigo ». L'URL « Piwigo » est probablement incorrecte
Voulez-vous vérifier vos paramètres et réessayer ?

Nuxien
2019-10-14 13:59:45

Avec la dernière version de Piwigo (2.10) le plugin Digikam ne fonctionne plus.
Pour le tester j'ai fait en sorte que piwigp renvoie 2.9 pour version et le plugin fonctionne alors très bien.

Anthony

Joel_C
2019-02-14 18:07:58

Ben voilà! Problème résolu. Les Tag créés sur Digikam apparaissent sur Piwigo et le tour est joué!
Merci!!

Joel_C
2019-02-12 09:38:10

Merci pour ce lien! Une vrai mine!!!
Je creuse de ce pas! ;)

ddtddt
2019-02-12 06:53:44
Joel_C
2019-02-11 22:31:33

Bonsoir, je suis un utilisateur, ancien de Digikam (antérieur à la version 1.0) mais un newbie tout frai de Piwigo.
L'installation du logiciel sur un espace dédié à mes albums photos date de samedi 9 février 2019. < pub>, mon hébergeur est la coopérative Ouvaton </pub>

http://frontwins.fr/Photos/

J'ai téléchargé quelques albums "pour voir" sur mon espace à partir du plug'in Digikam et cela fonctionne bien: en direct ou redimensionnement des photos. Cependant, même si le plugin détecte les métadonnées pendant le téléchargement, aucune ne semble exportée dans Piwigo une fois les photos en ligne. Ni dans mon espace administration, ni visible par les visiteurs.

Me faut il installer une extension adaptée? J'en ai trouvé quelques unes
- La première semble s'adresser aux utilisateurs de feu Picasa (que je trouvais bien foutu à l'époque).
- La seconde intitulée "Advanced Metadata" a sa version la plus récente qui date de 2012. Je ne suis pas sur qu'elle soit adaptée à la version actuelle de Piwigo.
- La troisième "Write Metadata", travaille dans le sens contraire à celui souhaité. Il écrit les méta données issues de Piwigo dans l'image.

quelqu'un aurait une idée à me suggérer?

fcoiffie
2018-02-28 09:43:45

Merci lexapiwi !
Même si j'ai été à l'origine du plugin, j'avoue que c'est l'équipe Digikam qui le maintient pour le garder fonctionnel.
Il faut savoir que le plugin permet également de transférer des vidéos.

Dans les principales demande que j'avais eu, je me souviens d'une demande de pouvoir gérer plusieurs comptes/sites ainsi que de pouvoir créer des albums directement à partir du plugin.

Son code source est accessible ici : https://cgit.kde.org/kipi-plugins.git/tree/piwigo

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact