Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

nicolas
2010-02-22 11:40:44

ms406ext_fr a écrit:

Nicolas, désolé mais je n'ai pas trouvé le temps ... cela remet mes essais au WE prochain. Jean

Pas de soucis. Je ne connais pas assez bien le packaging rpm pour t'en faire un !

ms406ext_fr
2010-02-22 10:49:13

Nicolas, désolé mais je n'ai pas trouvé le temps ... cela remet mes essais au WE prochain. Jean

nicolas
2010-02-18 10:59:19

ms406ext_fr a écrit:

Merci de la proposition. Je vais m'y essayer ce WE. Le pb est que j'utilise une Mandriva et non une Debian. Je verrai bien ce que je pourrai faire ;-)

Jean

Dans ce cas là, il va falloir faire un rpm !

ms406ext_fr
2010-02-18 07:25:59

Merci de la proposition. Je vais m'y essayer ce WE. Le pb est que j'utilise une Mandriva et non une Debian. Je verrai bien ce que je pourrai faire ;-)

Jean

nicolas
2010-02-17 22:01:19

Un peu d'aide pour l'installer ? Je viens de faire une première version du package debian, si l'envie te prend d'essayer :
http://piwigo.org/forum/viewtopic.php?p … 28#p111928

ms406ext_fr
2010-02-16 19:45:44

Bonjour,

   Petit complément sur mes petits pb, j'ai ceci dans les log (cela m'avait échappé hier ...) :

pLoader-2.0.7c_[10449]: segfault at 1c ip b5e369a8 sp bfd66980 error 6 in libjpeg.so.7.0.0[b5e1f000+34000]

ce qui ne me parle pas trop tout de même ;-)

Que faut il en penser ?

Merci !

ms406ext_fr
2010-02-15 20:46:48

Suite de l'histoire ... Content de l'ouverture de pLoader 2.0.7c j'avais mis en "sommeil" son utilisation.   Aujourd'hui j'ai eu besoin de l'utiliser et voici ce que j'obtiens  quelque soit l'exécutable utilisé lorsque j'ajoute (ou tente d'ajouter ) une photo JPG (en utilisant l'icône "+" et c'est idem par "sélectionner / glisser" )  :

[ms406@p72 ~]$ cd
[ms406@p72 ~]$ loaded_N_doc/2010/linux/pLoader-2.0.7c_linux/bin/pLoader.sh
loaded_N_doc/2010/linux/pLoader-2.0.7c_linux/bin/pLoader.sh: line 4: 10467 Erreur de segmentation  ./pLoader-2.0.7c_ubuntu9.10
[ms406@p72 ~]$                                                                                                               
[ms406@p72 ~]$ loaded_N_doc/2010/linux/pLoader-2.0.7c_linux/bin/pLoader-2.0.7c_ubuntu8.04
Erreur de segmentation
[ms406@p72 ~]$ loaded_N_doc/2010/linux/pLoader-2.0.7c_linux/bin/pLoader-2.0.7c_ubuntu8.10
Erreur de segmentation
[ms406@p72 ~]$ loaded_N_doc/2010/linux/pLoader-2.0.7c_linux/bin/pLoader-2.0.7c_ubuntu9.04
Erreur de segmentation
[ms406@p72 ~]$

Des idées ?

Merci,
Jean

ms406ext_fr
2010-02-12 16:55:39

Clément : un grand merci !

    Cela fonctionne maintenant. C'était bien la libtiff.so.4 qui manquait ... J'ai créé un lien symbolique "pointant" sur ma libtiff.so.3.9.1 existante et voilà :-) .

   Je ne sais pas si c'est très "règlementaire" et comment cela se comportera lors de la prochaine mise à jour mais en attendant je peux utiliser pLoader 2.0.7c grace à toi .

Jean

ms406ext_fr
2010-02-12 16:45:39

Merci Clément de cette rapide réponse. J'avais cherché un peu mais je suis pas un spécialiste ! Ces lib me semblent là (et d'ailleurs cela fonctionne en 2.0.7b) :

[root@p72 ~]# ls -l /usr/lib/libtiff*
lrwxrwxrwx 1 root root     16 2010-02-01 14:19 /usr/lib/libtiff.so.3 -> libtiff.so.3.9.1*
-rwxr-xr-x 1 root root 399788 2009-10-02 16:34 /usr/lib/libtiff.so.3.9.1*
lrwxrwxrwx 1 root root     18 2010-02-01 14:19 /usr/lib/libtiffxx.so.3 -> libtiffxx.so.3.9.1*
-rwxr-xr-x 1 root root   9516 2009-10-02 16:34 /usr/lib/libtiffxx.so.3.9.1*
[root@p72 ~]#

par contre il s'agit de la so.3.9.1 et peut être que pLoader "attend"  réellement la libtiff.so.4 (?)

Je vais essayer de créer un lien en  so.4 pour voir et je vous tiens au courant.

Clément
2010-02-12 14:30:08

Bonjour,

il manque une dépendance.
C'est bien un système de paquet rpm ?
Si oui, il semble qu'il faille installer le paquet libtiff quelque chose.
Par exemple libtiff-3.8.2-alt1.i586.rpm à ajuster en fonction de la version présente dans les dépots et de l'architecture.
Apparemment, il y a quelques informations sur cette page :
http://www.mandriva.com/security/adviso … A-2009:150

ms406ext_fr
2010-02-12 11:47:20

Bonjour à l'équipe et merci pour le pLoader 2.0.7c !

Après des essais sous M$ (et c'est Ok) je suis retourné à mon PC sous Linux / mdk2010.0 . Voici comment l'on peut résumer ce qui s'y passe :

[ms406@p72 ~]$
[ms406@p72 ~]$ loaded_N_doc/2010/linux/pLoader-2.0.7b_ubuntu/bin/pLoader.sh
[ms406@p72 ~]$
[ms406@p72 ~]$ loaded_N_doc/2010/linux/pLoader-2.0.7c_linux/bin/pLoader.sh
Can't load '/home/ms406/tmp/par-ms406/cache-5ed9adec065cf48a439026e62cc28464/16da9af7.so' for module Wx: libtiff.so.4: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type at /usr/lib/perl/5.8/DynaLoader.pm line 225.
at /usr/local/share/perl/5.8.8/PAR/Heavy.pm line 128
Compilation failed in require at script/ploader.pl line 26.
BEGIN failed--compilation aborted at script/ploader.pl line 26.
[ms406@p72 ~]$

L'on voit bien que sous la 2.0.7b cela fonctione toujours ( :-) ) mais ... la 2.0.7c à un petit soucis.  Si Ron pouvait me donner son avis d'expert cela m'aiderait.

Merci !

PS

des fois j'ai ceci quand je souhaite "répondre" à ce forum (avec perte du message bien sûr ...) :

Fatal error: Call to a member function check() on a non-object in /var/www/fr.piwigo.org/forum/post.php on line 122

là c'est juste pour "information" (donc aucune demande de ma part)

scor
2010-02-04 21:04:53

j'ai essayé l'autre jour, mais ça n'avait pas marché. Je reviendrai poster plus de détails quand j'aurai un peu plus de temps.

Clément
2010-02-04 08:46:34

La démarche que j'ai donné fonctionne pour Ubuntu (et Debain normalement), les paquets peuvent changer d'une distribution à l'autre, surtout que opensuse est basé sur red hat alors que Ubuntu est basé sur Debian.

Bonne chance pour compiler le programme et pense à donner la solution si tu y arrives ;)

ron
2010-01-22 00:11:58

pour une installation par cpan :

le premier module à installer est : Alien::wxWidgets, c'est lui qui va récupérer les sources wxWidgets pour les compiler.

ensuite tu peux installer Wx.

Avec cpan  quand tu as des erreurs "Make had returned bad status..." tu peux avoir plus d'infos avec :

Code:

> look Wx

ça te donne accès au répertoire de build. De là tu peux relancer :

Code:

> perl Makefile.PL
> make

et tu as les erreurs en direct, que tu peux poster ici.

scor
2010-01-21 23:17:00

bon, j'ai essayé sous opensuse 11.2 en vain.

d'abord, je n'ai pas trouvé les packages libwx-perl-processstream-perl libfile-slurp-perl libfile-homedir-perl libjson-perl libdigest-md5-file-perl libimage-exiftool-perl

seulement perl-File-Slurp

ensuite, j'ai essayé de passer par le CPAN et d'installer Wx

Code:

$ cpan
> install Wx

Ont suivi tout un tas de dépendances détectées automatiquement que j'ai acceptées, pour finir avec un

Code:

Make had returned bad status, install seems impossible

j'arrête là pour ce soir... :-(

Si quelqu'un a réussi à l'installer sous opensuse, je suis preneur...

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact