Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

vivreavecundiabete
2009-12-08 18:22:23

VDigital a écrit:

774   $str = $_SERVER['QUERY_STRING'];

Ligne identique en 2.0.3 (Je ne vois pas pourquoi on l'aurait changé).

Redirection modifiée?
.htaccess modifié?
Voir le support de l'hébergeur, peut-être?

Je vais voir du côté de mon hébergeur car je n'ai pas apporté de modification de redirection ou sur le fichier .htaccess

Merci

VDigital
2009-12-07 22:15:21

774   $str = $_SERVER['QUERY_STRING'];

Ligne identique en 2.0.3 (Je ne vois pas pourquoi on l'aurait changé).

Redirection modifiée?
.htaccess modifié?
Voir le support de l'hébergeur, peut-être?

LucMorizur
2009-12-07 22:11:01

A la ligne 774 de include/functions.inc.php , on voit effectivement un accès à $_SERVER['QUERY_STRING']. Il s'agit d'une variable d'environnement PHP. Si elle n'est pas définie, c'est a priori dû au paramétrage du serveur qui héberge ton site.

vivreavecundiabete
2009-12-07 21:32:42

L'accès à la gallerie que j'ai oublié d'indiquer : http://www.vivreavecundiabete.com/musee

vivreavecundiabete
2009-12-07 21:30:04

Merci pour votre réponse.

Le message apparait sur toutes les pages, en haut.
On voit un bout du message d'erreur qui reste toujours apparant sous le titre de mon album photo Piwigo. Il est en partie caché par ma bannière.


Les infos sur mon hébergement:
•System d'exploitation: Linux
•PHP: 5.2.11
•MySQL: 5.0.38-log
Server API  CGI

nicolas
2009-12-07 20:45:10

vivreavecundiabete a écrit:

Bonjour,


Je viens de mettre à jour ma gallerie piwigo en passant de la version 2.0.3 a la version 2.0.6.
Mais je rencontre un problème. Sur toutes les pages de ma gallerie j'ai le message d'erreur suivant:


Notice: Undefined index: QUERY_STRING in /www/sites/1/V/I/vivreavecundiabete.com/site/musee/include/functions.inc.php on line 774

Pourriez-vous s'il vous plait m'aider ?
Salutations

Il va falloir nous en dire un peu plus. Dans quel contexte peut-on essayer de reproduire le phénomène ? En cliquant où ? Eventuellement plusieurs clic.

Sinon quel OS ? Quel serveur ? Quelle version précise de php ?

vivreavecundiabete
2009-12-07 19:10:41

Bonjour,


Je viens de mettre à jour ma gallerie piwigo en passant de la version 2.0.3 a la version 2.0.6.
Mais je rencontre un problème. Sur toutes les pages de ma gallerie j'ai le message d'erreur suivant:


Notice: Undefined index: QUERY_STRING in /www/sites/1/V/I/vivreavecundiabete.com/site/musee/include/functions.inc.php on line 774

Pourriez-vous s'il vous plait m'aider ?
Salutations

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact