Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Gotcha
2010-01-02 17:35:05

Je viens de séparer mes plugins perso en autant de fichiers que de plugins. C'est donc à présent plus "propre" de ce coté là.

Gotcha
2009-12-21 10:47:26

Je vous crois sur parole. C'est juste sympa de découvrir certaines choses.


Bon, trêve de blablas, j'ai découvert la partie du bloc qui me faisait tout planté. C'est un code donné par VDigital post:123892
Vu que je n'ai pas encore synthétiser la discution en question, j'espère que ce n'est pas si grave que ça.

VDigital
2009-12-21 10:15:27

Gotcha a écrit:

... c'est pourtant des ligne de commentaires non ??? C'est vrai ça, comme Piwigo arrive à récupérer des infos qui sont passées en commentaire pour de php ?

Comment?
Imagine qu'il sache simplement lire certains commentaires ou notices (grillées).
(Cela évite d'avoir du cambouis plein les mains.)

LucMorizur
2009-12-21 10:13:27

Ce sont des lignes de commentaire lues et interprétées par Piwigo : comment crois-tu qu'il indique l'auteur du plugin, la version, etc, dans la page des plugins installés ? ;-)

Cela dit je n'ai aucune certitude que cela résolve ton problème. Mais c'est à essayer.

:-)

Gotcha
2009-12-21 10:10:11

[HS]
Il n'y a pas que moi qui se fait avoir au sprint xD
[/HS]

Je n'ai pas encore essayé mais c'est pourtant des ligne de commentaires non ??? C'est vrai ça, comme Piwigo arrive à récupérer des infos qui sont passées en commentaire pour de php ?

LucMorizur
2009-12-21 10:09:46

ddtddt a écrit:

J'avais pas vu je le rajoute ;-)

MDR :-D c'était indispensable !

ddtddt
2009-12-21 10:02:13

LucMorizur a écrit:

[HS]
Damien, tu as oublié le [Grillé] dans ton message :-D !
[/HS]

J'avais pas vu je le rajoute ;-)

LucMorizur
2009-12-21 09:52:53

[HS]
Damien, tu as oublié le [Grillé] dans ton message :-D !
[/HS]

ddtddt
2009-12-21 09:46:04

et si tu enlève la

/*
Plugin Name: Catégories Ping-Pong (menubar)
Version: 1.0
Description: Plugin Perso par VDigital
Plugin URI: http://piwigo.org
Author: VDigital
Author URI: http://fr.piwigo.org/forum/viewtopic.ph … 92#p123892
*/

2 déclarations de plugins dans le mm fichier cela ne pose pas de problème ?

[edit]
Grillé :D

LucMorizur
2009-12-21 09:45:43

Et si dans ton plugin perso tu retires l'un des deux blocs commentaire ?

/*
Plugin Name: Décocher la case "Simuler"
Version: 1.0
Description: Plugin Personnel
Plugin URI: http://piwigo.org
Author:
Author URI:
*/

Gotcha
2009-12-21 09:33:45

J'ai toujours ce problème.
Dès que je veux désactiver le plugin perso, ça me fait tout planter :-(

Gotcha
2009-12-12 23:03:22

flop25 a écrit:

on attend les captures ^^

Flute !
Elles sont trop grandes donc je les réduis tout de suite.
Pardon...

[EDIT]
C'est corrigé

flop25
2009-12-12 21:52:34

on attend les captures ^^

Gotcha
2009-12-12 18:19:23

En creusant je suis tombé sur un os... c'est normal docteur ?

*** Je suis sur mon site hébergé sur un serveur distant ***

Bon... j'ai persévéré j'ai observé un sale comportement. (CF capture 1)
D'après ce que je vois, c'est mon plugin personnel qui serait en cause.

Bon ban je le désactive de ce pas.
Sauf que... de retour sur la page d'accueil, ça mouline dans semoule et j'ai droit à une page totalement HS ! (CF capture 2)

Voici le contenu de mon plugin perso

Code:

<?php

/*
Plugin Name: Décocher la case "Simuler"
Version: 1.0
Description: Plugin Personnel
Plugin URI: http://piwigo.org
Author:
Author URI:
*/

add_event_handler('loc_begin_page_tail', 'personal_sync_not_simulate');
function personal_sync_not_simulate()
{
  global $page, $template;
  if ( isset($page['page']) and $page['page'] == 'site_update' )
  { $template->append('footer_elements', '<script type="text/javascript">
  document.getElementsByName("simulate")[0].checked = false;
</script>');
  }
}


/*
Plugin Name: Catégories Ping-Pong (menubar)
Version: 1.0
Description: Plugin Perso par VDigital
Plugin URI: http://piwigo.org
Author: VDigital
Author URI: http://fr.piwigo.org/forum/viewtopic.php?pid=123892#p123892
*/
add_event_handler('loc_end_index', 'clear_index_perso');

function clear_index_perso()
{
  global $template;
  $template->clear_assign(array(
    'U_MODE_FLAT', 'U_MODE_NORMAL', 'U_MODE_POSTED', 'U_MODE_CREATED',
  ));
}

function hide_counter_menu_cleaner($mbcat) {
  $check = true;
  while ($check) {
    $strt = strpos($mbcat, '<!--hide-counters-->');
    $end = ($strt !== false) ? strpos($mbcat, '</li>', $strt):false;
    if ($trt === false or $end === false) $check = false;
    else {
      $mbcat = substr($mbcat, 0, $strt) . '</a>' . substr($mbcat, $end);
    }
  }
  return $mbcat;
}




?>

Je parviens à retrouver la page d'administration et en réactivant le plugin perso, l'affichage rentre dans l'ordre...

Drôle d'histoire ! Mais ce n'est pas terminé pour autant :p

Eric
2009-12-12 18:07:09

Un pb avec multi view alors ? Possible en fonction de certains thèmes. J'avoue n'avoir jamais poussé l'utilisation de ce plugin. Je l'ai testé vite fait, comme çà, question de voir ce que cela donnait. Et puis chez moi, les thèmes des galeries sont très basiques.

A creuser dans cette direction, je pense.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact