Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Neutre
2010-01-02 16:05:15

SNF69 a écrit:

je laisse Neutre le faire car c'est lui qui a le problème ;o))

Voilà qui est fait !  http://fr.piwigo.org/forum/viewtopic.ph … 90#p127790

SNF69
2010-01-02 14:52:00

flop25 a écrit:

SNF69 a écrit:

De tête c'est le plugin "LinkRoot" qui doit gérer cette fonction d'après moi il faudrait rechercher de ce coté là ;o)) mais je ne suis pas assez compétent pour creuser dans le code :o(( désolé.


Seb

oui et ce serait un bug à poster dans un nouveau sujet s'il te plait

Tu as raison et je laisse Neutre le faire car c'est lui qui a le problème ;o))


Seb

flop25
2010-01-02 14:50:48

SNF69 a écrit:

De tête c'est le plugin "LinkRoot" qui doit gérer cette fonction d'après moi il faudrait rechercher de ce coté là ;o)) mais je ne suis pas assez compétent pour creuser dans le code :o(( désolé.


Seb

oui et ce serait un bug à poster dans un nouveau sujet s'il te plait

SNF69
2010-01-02 14:46:16

De tête c'est le plugin "LinkRoot" qui doit gérer cette fonction d'après moi il faudrait rechercher de ce coté là ;o)) mais je ne suis pas assez compétent pour creuser dans le code :o(( désolé.


Seb

Gotcha
2010-01-02 14:38:17

flop25 a écrit:

ha ben voilà c'est clair et net ! Donc pour résumer : Bonne année

Sauf que Neutre n'a toujours pas de réponse à son problème...

flop25
2010-01-02 14:16:35

ha ben voilà c'est clair et net ! Donc pour résumer : Bonne année

Neutre
2010-01-02 14:13:57

Bonjour Flop25 et bonne année !
La question d la redirection suite au login/delogin m'été réglée par Surhiliste :

En ce qui me concerne, j'ai remplacé, dans le fichier menubar_identification.tpl du template que j'utilise, Yoga en l'occurence, la ligne 17 en dessous de {if isset($U_LOGOUT)}:

    {if isset($U_LOGOUT)}
    <li><a href="./index.php?act=logout">{'logout'|@translate}</a></li>
    {/if}

Le problème reste entier (je reviens sur la page de pré-accueil (.../index/htlm) et non sur .../index.php quand je clique sur Accueil (voir capture).
Mais cela n'a rien à voir avec floPure ;-) car cela se produit quelque soit le thème !

flop25
2010-01-02 13:59:12

j'ai pas tout compris mais de ce que j'en ai compris c'est qu'il concerne floPure et la redirection suite au login/delogin ... peux-tu poster ici http://fr.piwigo.org/forum/viewtopic.php?id=11086 et expliquer le problème que tu as spécifiquement avec ce template merci ?

SNF69
2010-01-02 13:44:33

N'utilisant pas le même template que toi je ne vais pas pouvoir t'être d'un grand secours désolé :o((


Seb

Neutre
2010-01-02 13:32:54

surhiliste a écrit:

... voici le post en question : http://fr.piwigo.org/forum/viewtopic.php?id=16489

Euh, c'est celui où nous échangeons en ce moment..

Neutre
2010-01-02 12:40:04

Un grand merci Surhiliste !
Cela me règle la question de connexion-déconnexion mais, me semble-t-il , pas la question du retour au pré-accueil à partir du clic sur "Accueil" de mes pages Catégories.
Je cherche..

surhiliste
2010-01-02 12:30:56

... voici le post en question : http://fr.piwigo.org/forum/viewtopic.php?id=16489

Gotcha
2010-01-02 12:30:53

Je viens d'en notifier l'auteur du template :-)

surhiliste
2010-01-02 12:27:54

J'avais le même problème et la solution a été donné dans un autre post.

En ce qui me concerne, j'ai remplacé, dans le fichier menubar_identification.tpl du template que j'utilise, Yoga en l'occurence, la ligne 17 en dessous de {if isset($U_LOGOUT)}:

    {if isset($U_LOGOUT)}
    <li><a href="./index.php?act=logout">{'logout'|@translate}</a></li>
    {/if}

Neutre
2010-01-02 12:14:11

Bonjour,

Je réactive ce post car, totalement séduit par le travail de SNF69, je m'en suis inspiré (je veux dire que je l'ai honteusement pompé avec sa sympathique permission - merci SNF69) et je suis confronté à la difficulté que Sébastien signalait au début du post.

A savoir que lors que je veux revenir sur l'accueil, je suis redirigé vers la pré-page d'accueil et quand je me déconnecte, c'est la même chose avec, de plus la reconnection automatique sous mon login (conséquence du "se connecter automatiquement"...).

De même, sur la page d'une catégorie ou sous-catégorie, cliquer sur Accueil dans le chemin en tête du cadre Catégories me ramène automatiquement sur le pré accueil.

j'ai bien essayé l'astuce de contournement du problème de Sébastien en intégrant son code dans mon menubar_perso.tpl . Mais cela ne fonctionne pas correctement avec floPure. Cela me crée un bouton supplémentaire de connection ou déconnection qui n'est pas intégré à mon bloc "Identification".

J'ai bien essayé de l'intégrer dans un identification_perso.tpl mais je ne trouve pas de {$U_LOGOUT} auquel je pourrais substituer le chemin de ma galerie www.lesphotosdejean.fr/index.php?

A défaut de solution globale ;-) qui fasse que le retour puisse ce faire systématiquement sur l'index.php, auriez vous une idée pour me dépanner ?

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact