Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Korben
2009-04-27 23:06:17

OK Merci je vrais regarder ce que c'est que WAMPP
De ce que jai vu il a l'air intéressant.
En tout cas, merci bcp pour l'aide.

rub
2009-04-26 23:26:28

Korben a écrit:

PS : Tout ceci a été fait avec "//$conf['smtp_host'] = 'smtp.monFAI.fr';" dans le fichier "config_local.inc.php"


Par contre, il n'y a plus aucun pb lorsque je mets "$conf['smtp_host'] = 'smtp.monFAI.fr';" dans le fichier "config_local.inc.php"

Donc, c'est résolu? (à mettre dans le titre)

Je ne sais pas pourquoi ca ne fonctionne pas en natif, ca doit venir d'orange car moi sous XAMPP mais avec le smtp de free ca fonctionne quelque soit la configuration. (maintenant ;-) )

Tu as WampServer essaie vite XAMMPP, c'est peut-être un pb de config.

Korben
2009-04-26 21:20:11

J'ai remplacé le fichier par celui que tu viens de donner.
Voici les résultats :

Dans les Logs de WAMP :
"[26-Apr-2009 21:10:08] PHP Warning:  mail() [<a href='function.mail'>function.mail</a>]: SMTP server response: 501 5.1.3 Bad recipient address syntax in C:\wamp\www\piwigo\include\functions_mail.inc.php on line 780"


Dans la page de la photo :
"Warning: mail() [function.mail]: SMTP server response: 501 5.1.3 Bad recipient address syntax in C:\wamp\www\piwigo\include\functions_mail.inc.php on line 780"


Dans le fichier mail.visiteur.fr.yoga.dark.txt :

[Ma Gallerie Perso] Commentaire par TEST4
From: "Ma Gallerie Perso" <e-mail@administrateur.com>
Reply-To: "Ma Gallerie Perso" <e-mail@administrateur.com>
To: undisclosed-recipients: ;
Bcc: "Administrateur" <e-mail@administrateur.com>
Content-Type: multipart/alternative;
  boundary="---=Wa4G2ENhPC9767QkAGpw668ioyW73434";
  reply-type=original
MIME-Version: 1.0
X-Mailer: Piwigo Mailer
-----=Wa4G2ENhPC9767QkAGpw668ioyW73434
Content-Type: text/html; charset="utf-8";
Content-Transfer-Encoding: 8bit

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html lang="fr" dir="ltr">
<head>
<title>Piwigo Mail</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<style><!-- /* Mini style for mails */
/* Global mail css */

body { font-family: Univers, Helvetica, Optima; font-size:12px; margin:0px; padding:0px; }
#the_page { margin:0px; padding:0px; text-align:left;}
#content { margin:0px; padding:82px 0px 0px 62px; width:732px;}
hr { width:632px; margin-left:0;}
#copyright { font-size:10px; margin:0px; padding:48px 0px 32px 62px;}
.PWG { font-family:verdana, sans-serif !important; font-size:0.9em; font-weight:normal; letter-spacing:0px;}
h2 { padding:7px 15px; width:617px; font-weight:bold;}
img { margin:16px; border:16px solid #aaa; -moz-border-radius: 4px; border-radius: 4px 4px; }
img:hover { padding: 15px; border: 1px solid yellow; -moz-border-radius: 4px; border-radius: 4px 4px; }/* Theme dark mail css */

body { background-color:#444; color:#fff;}
#the_page { background: #444 url(http://localhost/piwigo/template/yoga/mail/text/html/images/mailbody-bg.png) repeat-y scroll left top;}
#content { background: transparent url(http://localhost/piwigo/template/yoga/mail/text/html/images/header-bg.png) no-repeat scroll left top;}
#copyright { background: transparent url(http://localhost/piwigo/template/yoga/mail/text/html/images/footer-bg.png) no-repeat scroll left bottom;
color: #69c;}
h2 { background-color: #333;color:#fff48e;background-image: url(http://localhost/piwigo/template/yoga/theme/dark/images/tableh1_bg.png);}
img { margin: 16px; border: 16px solid #111; -moz-border-radius: 4px; border-radius: 4px 4px; }
img:hover { padding: 15px; border: 1px solid yellow;background-color:#444;-moz-border-radius: 4px; border-radius: 4px 4px; }
a { color: #fff48e; background: transparent;border-bottom:1px dotted #005e89; }
a:hover { color: #fff48e;}--></style>
</head>
<body>
<div id="the_page">
<div id="content" class="content"><p>Auteur: TEST4<br />
Commentaire: kdfkldkf<br />
<br />
Suppression: <a href='http://localhost/piwigo/comments.php?delete=41' class='thumblnk'>http://localhost/piwigo/comments.php?delete=41</a><br />
<br />
Validation: <a href='http://localhost/piwigo/comments.php?validate=41' class='thumblnk'>http://localhost/piwigo/comments.php?validate=41</a><br />
<br />
Utilisateur connecté: visiteur<br />
IP: 127.0.0.1<br />
Navigateur: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; InfoPath.2; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; WWTClient2; OfficeLiveConnector.1.3; OfficeLivePatch.0.0)<br />
</p></div> <!-- content -->
<div id="copyright">
<hr/>

  Propulsé par
  <a href="http://piwigo.org" class="Piwigo">
  <span class="Piwigo">Piwigo</span></a>
 
  - Contacter
  <a href="mailto:e-mail@administrateur.com?subject=Un+commentaire+sur+le+site">Webmestre</a>

</div> <!-- copyright -->
</div> <!-- the_page -->

</body>
</html>
-----=Wa4G2ENhPC9767QkAGpw668ioyW73434--




PS : Tout ceci a été fait avec "//$conf['smtp_host'] = 'smtp.monFAI.fr';" dans le fichier "config_local.inc.php"


Par contre, il n'y a plus aucun pb lorsque je mets "$conf['smtp_host'] = 'smtp.monFAI.fr';" dans le fichier "config_local.inc.php"

rub
2009-04-26 20:41:12

Korben a écrit:

ok mais normalement que ce soit par smtp ou non l'envoi de mail en caché ne devrait pas poser pb.

Sauf en cas de bug, chez nous...
J'ai fait un correctif. Tu peux valider?


Korben a écrit:

D'aileurs, je si je veux faire un test, comment mettre en commentaire l'envoi du mail à l'adresse cachée ?

Ca le fait dans le cas d'une notification de commentaire. (pas pour la NBM)

Korben
2009-04-26 18:33:06

ok mais normalement que ce soit par smtp ou non l'envoi de mail en caché ne devrait pas poser pb.
D'aileurs, je si je veux faire un test, comment mettre en commentaire l'envoi du mail à l'adresse cachée ?
Merci

rub
2009-04-26 18:29:17

Korben a écrit:

Dc ca veut dire aussi que si il n'y a qu'un seul admin pour la gallerie, il recevra donc 2 mails à chaque notification de commentaire !!

Non, non...
Et même s'il y a l'option des mails en copie, vu que ca sera la même adresse, il recevra un mail...

Ce qui est important de retenir, c'est que c'est envoyé en copie cachée et que ca ne fonctionne pas bien avec l'envoi par smtp. (pour le moment ;-))

Korben
2009-04-26 18:08:20

ha ok ok Je comprend mieux now !!
Dc ca veut dire aussi que si il n'y a qu'un seul admin pour la gallerie, il recevra donc 2 mails à chaque notification de commentaire !!
Du coup, si là l'admin n'est pas au courant qu'il y a des commentaire, il y a un problème :) :) :) :) :)

rub
2009-04-26 18:04:07

Korben a écrit:

ha oui ?? mais comment c'est possible ??
Et d'ailleurs j'ai vu ça aussi dans le debug que je t'ai envoyé qu'il y avait des destinataires mais où c'est indiqué qu'il faut envoyé les notifications à plusieurs destinataires ???

C'est possible car pour les commentaires ca envoie en copie invisible à tous les admins de la galerie.

Korben
2009-04-26 17:38:45

ha oui ?? mais comment c'est possible ??
Et d'ailleurs j'ai vu ça aussi dans le debug que je t'ai envoyé qu'il y avait des destinataires mais où c'est indiqué qu'il faut envoyé les notifications à plusieurs destinataires ???

rub
2009-04-26 17:31:29

J'arrive à reproduire le problème chez moi.
Le problème survient quand il n'y a des destinataires (ils sont en cc ou bcc).
Je reviens avec un correctif.

Korben
2009-04-26 17:30:27

Peux-tu me dire ce que ça change en ayant juste le mail administrateur de modifié ???
J'ai juste remplacé dans le fichier simplement l'e-mail et fais un copier/coller de l'intégrale du fichier (Ctrl+A) ou alors je t'envoi le fichier avec l'adresse e-mail modifiée comme tu veux

Korben
2009-04-26 17:26:19

J'ai remplacé le fichier par celui que tu m'as donné et voici ce que ça donne :

Dans les logs PHP de WAMP :
[26-Apr-2009 17:24:01] PHP Warning:  Unable to send e-mail. Error message reported by the SMTP server: "501 5.1.3 Bad recipient address syntax
" in C:\wamp\www\piwigo\include\class_smtp_mail.inc.php on line 63

Précision : J'ai dans le fichier "config_local.inc.php"
$conf['smtp_host'] = 'smtp.monFAI.fr';


Et maintenant avec dans le fichier "confg_local.inc.php"
//$conf['smtp_host'] = 'smtp.orange.fr';


Dans les logs PHP de WAMP :

[26-Apr-2009 17:28:40] PHP Warning:  mail() [<a href='function.mail'>function.mail</a>]: SMTP server response: 501 5.1.3 Bad recipient address syntax in C:\wamp\www\piwigo\include\functions_mail.inc.php on line 780

rub
2009-04-26 17:16:09

Korben a écrit:

En fait j'ai moi-même remplacé l'adresse e-mail dans ce que j'ai mis pour ne pas donner mon e-mail (c'est volontaire)
Mais "e-mail@administrateur.com" correspond dans la réalité à l'adresse e-mail du compte "Administrateur" de Piwigo
Si tu vois ce que je veux dire.

Oui, je vois.

Mais, ca te pose pas de problème de me le transférer en MP...
Juste pour vérifier le fichier brut...

rub
2009-04-26 17:14:54

Korben a écrit:

Tu veux que je supprime et remplace complètement le fichier "class_smtp_mail.inc.php" par celui que tu m'as donné ???

Oui

Korben
2009-04-26 17:13:16

En fait j'ai moi-même remplacé l'adresse e-mail dans ce que j'ai mis pour ne pas donner mon e-mail (c'est volontaire)
Mais "e-mail@administrateur.com" correspond dans la réalité à l'adresse e-mail du compte "Administrateur" de Piwigo
Si tu vois ce que je veux dire.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact