Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Adales
2013-04-20 10:34:43

Ce qui a été donné ici concerne les miniatures si j'ai bien lu.

Pour ceux qui veulent changer le alt et le title dans l'image principale afin que cela donne le titre et la légende de l'image, j'ai modifié le template (on peut aussi modifier juste un thème) personnalisé pour le fichier picture_content.tpl :

Dans la balise alt de <img ... :

Code:

alt="{$current.TITLE|@replace:'"':' '} - {if isset($COMMENT_IMG)}$COMMENT_IMG|@strip_tags:false|@replace:'"':' '} {/if}"

Dans la balise title de <img ... :

Code:

title="{$current.TITLE|@replace:'"':' '} - {if isset($COMMENT_IMG)}{$COMMENT_IMG|@strip_tags:false|@replace:'"':' '}{/if}"

Je ne sais pas si c'est plus efficace pour le SEO, mais en tout cas cela me parait plus logique que de mettre le nom de fichier dans le alt, qui pour moi ne signifie rien, et de mettre seulement le commentaire dans le titre. Ca ne mange pas de pain ...

Gotcha
2010-08-15 12:57:32

Bien vu ;-)

Zaphod
2010-08-15 09:57:58

Justement tu ne mets pas forcément le titre en dessous des miniatures.
Moi je ne le mets pas.

Dans tous les cas, je ne vois pas quel intérêt pourrait avoir le visiteur pour le nom et le poids du fichier (surtout lors d'un transfert via ploader où le nom est juste une suite de caractères quelconque).

Gotcha
2010-08-15 00:48:30

Je ne sais pas si la balise ALT est plus pertinente avec le titre (s'il y en a) de l'objet ou bien avec le nom + poids de ce dernier.
Sachant que le titre de la photo se trouve (sur la page thumbnail) sous la miniature. Pour les autres pages, oui là ce serait sans doute plus utile.

[Bugtracker] ticket 1797

amande
2010-08-14 23:49:41

merci Zaphod.

pourquoi ne pas intégrer cette modification directement dans Piwigo ?

orbitweb
2010-08-14 18:36:46

Ah !! ça y est j'ai trouvé !

Dans le fichier "themeconf.inc.php" du répertoire /theme/luciano/ il y a une ligne : "$conf['show_thumbnail_caption']  = false;" !!
je l'ai remplacée par "$conf['show_thumbnail_caption']  = true;" et tout fonctionne très bien maintenant !
Que de temps perdu pour une petite ligne de code que je ne trouvais pas... En tout cas merci pour votre aide !

orbitweb
2010-08-14 18:32:34

Merci pour tes conseils Zaphod.
J'ai changé mon thème, et en effet là les titres s'affichent bien au bas de mes vignettes.

Donc j'en déduis que le problème vient du thème que j'utilise, c'est à dire Luciano... mais je ne vois pas ce qui coince...

Sinon je ne sais pas ce que fait "purger les templates compilés".

On m'avait conseillé d'utiliser cette fonction lorsque je fais des modifications sur des fichiers templates de mes plugins (par exemple RV Maps). Il est nécessaire de cliquer dessus pour que la mise à jour des fichiers .tpl modifiés soit prise en compte.

Zaphod
2010-08-14 16:29:45

Tu as bien des titres pour tes images ?

Sinon je ne sais pas ce que fait "purger les templates compilés".
Pense aussi à vider le cache de ton navigateur.

Commençons par un test simple : remets le template de base, et avec show_thumbnails_caption à TRUE, tu devrais voir le titre des images en dessous des miniatures.
Si ça n'est pas le cas... alors il y a un truc qui couille quelque part...

orbitweb
2010-08-14 16:22:51

Merci Zaphod pour cette explication détaillée !
Hélas, je viens de suivre à la lettre ces indications mais ça ne fonctionne pas pour moi !
- j'ai bien remplacé mes balises par {$thumbnail.NAME} dans un fichier template extension "my-thumbnails.tpl" qui est bien activé dans l'admin,
- j'ai bien rajouté la ligne "$conf['show_thumbnail_caption'] = true;" à mon fichier "local/config/config.inc.php"
- une fois ces modifications faites je suis allé dans l'admin > outils > maintenance et j'ai cliqué sur "Purger les templates compilés"

au final, les champs "title" et "alt" de mes images sont vides... auriez vous une idée de ce qui coince ? Merci !

Zaphod
2010-08-14 14:55:20

Bon voila c'est fait.

Il faut se créer (avec local files editor) un template personnalisé thumbnail_mod.tpl.

On copie juste le thumbnail.tpl de base, et à cette ligne :

<a href="{$thumbnail.URL}">
            <img class="thumbnail" src="{$thumbnail.TN_SRC}" alt="{$thumbnail.TN_ALT}" title="{$thumbnail.TN_TITLE}">
</a>

il faut changer le thumbnail.TN.ALT et le thumbnail.TN.TITLE par thumbnail.NAME.

Ca donne ça :

<a href="{$thumbnail.URL}">
            <img class="thumbnail" src="{$thumbnail.TN_SRC}" alt="{$thumbnail.NAME}" title="{$thumbnail.NAME}">
</a>

Ensuite, on choisi dans les options de remplacer le thumbnail.tpl par notre nouveau fichier thumbnail_mod.tpl
(c'est le menu Templates (modèles) en v2.1)

Pour que ça fonctionne, il faut avoir choisi d'afficher les légendes des miniatures dans le fichier local/config/config.inc.php.
Sinon, la variable thumbnail.NAME est vide.
La valeur par défaut est à TRUE, mais il faut vérifier qu'on n'impose pas la valeur false (c'était mon cas).
Je préfère le mettre de toutes façons dans le fichier "Configuration Locale" avec LocalFilesEditor, :

$conf['show_thumbnail_caption'] = true;

Le souci, c'est que perso je ne veux pas afficher la légende.
Dans le fichier thumbnail.tpl précédemment crée, je mets donc cette ligne en commentaire :

<!--        {if isset($thumbnail.NAME)}{$thumbnail.NAME}{/if}-->

J'en profite aussi pour virer l'icone de nouveauté :

<!--        {if !empty($thumbnail.icon_ts)}
        <img title="{$thumbnail.icon_ts.TITLE}" src="{$ROOT_URL}{$themeconf.icon_dir}/recent.png" class="icon" alt="(!)">
        {/if}-->

Au final mon template perso thumbnail_mod.tpl est ceci :

{if !empty($thumbnails)}
<ul class="thumbnails">
{foreach from=$thumbnails item=thumbnail}
    <li>
    <span class="wrap1">
        <span class="wrap2">
        <a href="{$thumbnail.URL}">
<!--            <img class="thumbnail" src="{$thumbnail.TN_SRC}" alt="{$thumbnail.TN_ALT}" title="{$thumbnail.TN_TITLE}">-->
            <img class="thumbnail" src="{$thumbnail.TN_SRC}" alt="{$thumbnail.NAME}" title="{$thumbnail.NAME}">
        </a>
        </span>
        <span class="thumbLegend">
<!--        {if isset($thumbnail.NAME)}{$thumbnail.NAME}{/if}-->
<!--        {if !empty($thumbnail.icon_ts)}
        <img title="{$thumbnail.icon_ts.TITLE}" src="{$ROOT_URL}{$themeconf.icon_dir}/recent.png" class="icon" alt="(!)">
        {/if}-->
        {if isset($thumbnail.NB_COMMENTS)}
        <span class="{if 0==$thumbnail.NB_COMMENTS}zero {/if}nb-comments">
        <br>
        {$pwg->l10n_dec('%d comment', '%d comments',$thumbnail.NB_COMMENTS)}
        </span>
        {/if}

        {if isset($thumbnail.NB_HITS)}
        <span class="{if 0==$thumbnail.NB_HITS}zero {/if}nb-hits">
        <br>
        {$pwg->l10n_dec('%d hit', '%d hits',$thumbnail.NB_HITS)}
        </span>
        {/if}
        </span>
    </span>
    </li>
{/foreach}
</ul>
{/if}

Zaphod
2010-08-14 14:39:22

C'est une bonne question... à laquelle je ne sais pas répondre ;)
J'ai refait les modifs depuis 0 en passant à Piwigo 2.1, et celle là je l'ai oubliée.

Donc faut que je le refasse... je vais me relire le topic car je ne me souviens plus de ce que j'avais fait.

Gotcha
2010-08-14 10:51:08

[HS]

N'hésitez pas à "notifier" un utilisateur pour lui envoyer un courriel en plus de votre message sur le forum :-)
Pour Notifier quelqu'un d'un message, regardez dans le coin inférieur droit du message et vous trouverez le lien.

[/HS]

amande
2010-08-13 14:35:08

Désolée de déterrer ce vieux topic mais c'est exactement ce que je souhaiterai faire...

J'utilise Piwigo 2.1.2 et je voudrais que les balises alt et title contiennent la même chose. Peux tu m'expliquer ce que tu as fait Zaphod pour arriver à ce résultat ?

Merci

VDigital
2009-04-02 11:01:33

Pensez à partager vos template extensions...

Zaphod
2009-04-02 10:15:51

En tous cas, avec Piwigo 2.0.x, la gestion des templates est extrêmement facilitée.

Moi j'ai fait la modif pour avoir ce que je veux (dans mon cas j'ai mis : alt="{$thumbnail.NAME}" title="{$thumbnail.NAME})
Par contre ça m'oblige à mettre true à $conf['show_thumbnail_caption']

Ceci dit, la modif est faisable en 1.7 aussi, avec LocalFilesEditor on peut éditer le thumbnails.tpl
Pour le commentaire de l'image, ça risque d'être plus compliqué.

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact