Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

graphonie
2009-06-09 16:55:11

Fin des soucis

j'ai bien relancé upgrade.php, en remettant manuellement mes identifiants, car en mode de saisie assistée (opera) l'excution automatique court circtuitait  le lancement de la mise à jour

All is perfect !
Merci de tout

VDigital
2009-06-09 16:24:13

Tu as l'air d'avoir une galerie bien en vrac avec des messages venant de Piwigo 2.0.x

( Pour éviter de se retrouver dans la galère ou graphonie se trouve, une solution sage consiste à suivre à la lettre la procédure de mise à jour. Et dans le cas où l'on ne pige pas, relire bien attentivement, et venir au besoin poser une question sur le forum pour se faire éclaicir le point. Après les réparations surtout en aveugle, cela devient très aléatoire. )

Dans le cas présent la base n'est visiblement pas à jour (upgrade.php n'a pas été exécuté, ou ne s'est pas éxécuté correctement).

graphonie
2009-06-09 15:55:55

Et voic le deuxième test, en visiteur simple :

"
Notice: Undefined index: image_access_type in /homepages/12/d203335877/htdocs/arts/galleries/include/functions_user.inc.php on line 1277

Notice: Undefined index: level in /homepages/12/d203335877/htdocs/arts/galleries/include/functions_user.inc.php on line 1291

Notice: Undefined index: upload_user_access in /homepages/12/d203335877/htdocs/arts/galleries/include/functions_category.inc.php on line 484

Notice: Undefined index: upload_link_everytime in /homepages/12/d203335877/htdocs/arts/galleries/include/functions_category.inc.php on line 493

Warning: Cannot modify header information - headers already sent by (output started at /homepages/12/d203335877/htdocs/arts/galleries/include/functions_user.inc.php:1277) in /homepages/12/d203335877/htdocs/arts/galleries/include/page_header.php on line 98"

Il me semble que je dois tenter d'installer un template nouveau pour tout remettre en ordre. Serait ce la bonne solution ?

graphonie
2009-06-09 15:53:20

Re bonjour,
les répertoires /_data et son sous-répertoire /templates-c sont toujours bien en chmod 0777, réverification faite.

J'ai trouvé la réponse :
En fait, le fichier, c'est la conservation du fichier config_default.inc.php de la version 1.70 qui posait problème.
Il s'agissait d'un renommage de mon fichier config_local.inc.php, du fait (on doit toujours se méfier de sa p^ropre bonne volonté) que  je voumlais créer une version dem1.70 de ce fichier, qui était indiquée comme à ceonserver.

En remettant celui de la version Piwigo 2.02c, cela commence à  fonctionner.

1er test ; connection en admin . La page s'affiche, cependant, voici le message d'erreur qui apparait tout en haut :

"

Notice: Undefined index: c13y_ignore in /homepages/12/d203335877/htdocs/arts/galleries/admin/include/check_integrity.class.php on line 48

Warning: Cannot modify header information - headers already sent by (output started at /homepages/12/d203335877/htdocs/arts/galleries/admin/include/check_integrity.class.php:48) in /homepages/12/d203335877/htdocs/arts/galleries/include/page_header.php on line 98
"

VDigital
2009-06-09 14:53:28

graphonie a écrit:

...
Dois-je donc placer dans les 3 dossiers /templates , /template-extension, et /template-common uniquement le template yogoa de la nouvelle version, sans aucune référence à l'ancienne  (javais lu que ces dosseirs tempaltes etaient à sauvegarde, de façon optionnelle) ?

C'est surtout le template-extension qui va pouvoir être réutilisé dans le futur.
Dans le futur, c'est à dire tant qu'on ne changera pas à nouveau de moteur de template.
On vient de le changer... Donc à priori, pas de problème pendant quelques temps.
(Mais les anciens templates de PhpWebGallery sont incompatibles avec ceux de Piwigo.)

Donc, actuellement: "sans aucune référence à l'ancienne" la réponse est oui, malheureusement.

rio
2009-06-09 13:10:01

graphonie a écrit:

Dois-je donc placer dans les 3 dossiers /templates , /template-extension, et /template-common uniquement le template yogoa de la nouvelle version, sans aucune référence à l'ancienne  (javais lu que ces dosseirs tempaltes etaient à sauvegarde, de façon optionnelle) ?

Oui, c'est une bonne chose. Regarde déjà si tu as toujours le message d'erreur avec les fichier d'origine. En suite on regardera avec les modifs que tu as pu faire dans le passé.

:-))

rio
2009-06-09 13:03:02

Correction.
Ton problème vient probablement d'ailleurs … avant d’avancer, peux-tu revérifier le chmod de ../_data et ../_data/template_c ?
Tu peux supprimer le ../template_c
Merci

:-))

graphonie
2009-06-09 13:01:26

Précision ultime :
Ma version d eMysql est la 5.0.

Merci de ta réponse, Rio,
Je n'utilisai pas d'autre template que le yoga par defaut, sans amenagements, de memoire.
Dois-je donc placer dans les 3 dossiers /templates , /template-extension, et /template-common uniquement le template yogoa de la nouvelle version, sans aucune référence à l'ancienne  (javais lu que ces dosseirs tempaltes etaient à sauvegarde, de façon optionnelle) ?
Je vais tester avec ce changement là.

rio
2009-06-09 12:48:48

Non je dirais plutôt un problème de template. Il est possible qu'un template utilisé n'existe plus dans la nouvelle version.
Fais une recherche sur le forum, le problème doit être réglé directement sur la base de données.

:-))

graphonie
2009-06-09 12:32:07

Bonjour à tous,

Bonjour.

Je rencontre le même message d'erreur, adapté bien sur au chemin de mon site.

Ce site est un site distant, hébergé sous Linux, chez 1and1.fr.


Voici le message d'erreur, dès que j'appelle la page upgrade.php :

"Piwigo encountered a non recoverable error
/templates_c no_write_access

#1    mkgetdir /homepages/12/d203335877/htdocs/arts/galleries/include/template.class.php(61)
#2    Template::Template /homepages/12/d203335877/htdocs/arts/galleries/include/common.inc.php(169)
#3    include_once /homepages/12/d203335877/htdocs/arts/galleries/index.php(26)
"
PHP5
J'ai passé la version php en php 5.29, en me conformant aux préconisations de mon hébergeur, (création d'un fichier .htaccess recopié tant à la base de l'bebergement que dans chacun des réperoires correspondant au site en question) dont le contenu est :
.AddType x-mapp-php5 .php .php3 .php4 .htm .html

J'y ai meme ajouté la commande (lue sur le forum)
SetEnv PHP_VER 5
sans succès dans et l'autre cas.

Mes autres sites en php fonctionnent après cela. J'ai vérifié la bonne prise en compte de cette version nouvelle de php par un phpinfo dont voiic la copie .pdf :
http://arts.musarder.com/arts-musarder- … erveur.pdf


MYSQL
J'ai édité le fichier /include/mysql.inc.php  pour lui ajouter les deux dernieres  lignes 'spéciales Piwigo', et vérifier que le préfixe des tables restait bien celui déjà présent dans ma base de données, de la version 1.70. Voici le contenu de ce fichier, les infos personnelles étant bien sur remplacées par des acronymes :
"<?php
$cfgBase = 'ma_base_chez_1and1';
$cfgUser = 'mon_nom_d_utilisateur';
$cfgPassword = 'mon_pot_de_passe';
$cfgHote = 'l_adresse_de_ma_base_chez_1and1';

$prefixeTable = 'phpwebgallery_';

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

?>
"

DOSSIERS de MIGRATION
Conformément aux réponses dlues sur le forum, j'ai crée de mes blanches mimines
tant un répertoire /homepages/12/d203335877/htdocs/arts/galleries/_data et son sous répertoire /homepages/12/d203335877/htdocs/arts/galleries/_data/templates_c
qu'un réprtoire /homepages/12/d203335877/htdocs/arts/galleries/templates_c
qui sont donc tous deux au même niveau hierarchique que les autres répertoires de Piwigo (galleries, admin, include, doc,...)
J'ai chmodé avec succès chacun des répertoires en 0777.


Pourtant , je reste toujours bloqué sur la même erreur.

La configuration php5 de mon hébegeur serait elle en cause ? Merci de m'éclairer, et de m'aider à résoudre ce problème

Meric d'avance

Jean-François

TokKy
2009-03-29 19:40:49

merci

mais je parlais pas de ça, mais plutot au niveau du code, quels fichiers sont appeler par tel ou tel fonctions, quels actions sont déclanché.....

la parti séquences du code !

merci d'avance

VDigital
2009-03-27 20:55:49
TokKy
2009-03-27 20:19:42

si qq'un pouvait me donner le sequencement de l'upgrade ça me permettrai d'analyser où se trouve le soucis

merci d'avance

VDigital
2009-03-24 22:36:19

Chez moi, ils sont en 755 et cela marche très bien.
Pas d'idée pour l'instant.

TokKy
2009-03-24 22:31:46

et pourtant :

tokky@sd-xxxxx:/home/http/tok.fr/photos$ ls -l
total 272
-rwxrwxrwx  1 www-data www-data  3106 2009-03-23 16:48 about.php
-rwxrwxrwx  1 www-data www-data  5670 2009-03-23 16:48 action.php
drwxrwsrwx  5 www-data www-data  4096 2009-03-23 16:49 admin
-rwxrwxrwx  1 www-data www-data  6777 2009-03-23 16:49 admin.php
-rwxrwxrwx  1 www-data www-data  2446 2009-03-23 16:49 category.php
-rwxrwxrwx  1 www-data www-data 12379 2009-03-23 16:49 comments.php
drwxrwsrwx  3 www-data www-data  4096 2009-03-24 10:15 _data
drwxrwsrwx  2 www-data www-data  4096 2009-03-23 16:49 doc
-rwxrwxrwx  1 www-data www-data  6703 2009-03-23 16:49 feed.php
drwxrwsrwx  5 www-data www-data  4096 2008-08-18 16:21 galleries
-rwxrwxrwx  1 www-data www-data  3736 2009-03-23 16:49 identification.php
drwxrwsrwx  5 www-data www-data  4096 2009-03-24 10:52 include
-rwxrwxrwx  1 www-data www-data  8651 2009-03-23 16:50 index.php
drwxrwsrwx  3 www-data www-data  4096 2009-03-23 16:50 install
-rwxrwxrwx  1 www-data www-data 12975 2009-03-23 16:50 install.php
drwxrwsrwx 11 www-data www-data  4096 2009-03-23 16:52 language
-rwxrwxrwx  1 www-data www-data  4059 2009-03-23 16:52 nbm.php
-rwxrwxrwx  1 www-data www-data  3791 2009-03-23 16:52 notification.php
-rwxrwxrwx  1 www-data www-data  6351 2009-03-23 16:52 password.php
-rwxrwxrwx  1 www-data www-data 25884 2009-03-23 16:52 picture.php
drwxrwsrwx 19 www-data www-data  4096 2009-03-23 17:54 plugins
-rwxrwxrwx  1 www-data www-data  3259 2009-03-23 16:53 popuphelp.php
-rwxrwxrwx  1 www-data www-data  9356 2009-03-23 16:53 profile.php
-rwxrwxrwx  1 www-data www-data  2704 2009-03-23 16:53 qsearch.php
-rwxrwxrwx  1 www-data www-data  3168 2009-03-23 16:53 random.php
-rwxrwxrwx  1 www-data www-data  3499 2009-03-23 16:53 register.php
-rwxrwxrwx  1 www-data www-data  6820 2009-03-23 16:53 search.php
-rwxrwxrwx  1 www-data www-data  7549 2009-03-23 16:53 search_rules.php
-rwxrwxrwx  1 www-data www-data  6149 2009-03-23 16:53 tags.php
drwxrwsrwx  3 www-data www-data  4096 2008-08-18 16:21 template
drwxrwsrwx  3 www-data www-data  4096 2009-03-23 17:42 template-common
drwxrwsrwx  4 www-data www-data  4096 2009-03-23 17:42 template-extension
drwxrwsrwx  2 www-data www-data  4096 2009-03-23 16:55 tools
-rwxrwxrwx  1 www-data www-data  4260 2009-03-23 16:55 upgrade_feed.php
-rwxrwxrwx  1 www-data www-data 11650 2009-03-23 16:55 upgrade.php
-rwxrwxrwx  1 www-data www-data 14418 2009-03-23 16:55 upload.php
-rwxrwxrwx  1 www-data www-data 12009 2009-03-23 16:55 ws.php


et


tokky@sd-xxxxx:/home/http/tok.fr/photos/_data$ ls -l
total 4
drwxrwsrwx 2 www-data www-data 4096 2009-03-23 22:13 templates_c


Je ne peux pas faire mieux.

Il faut peut être que je place ce dossier ailleurs ?

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact