Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Gotcha
2011-04-06 15:45:41

Gotcha a écrit:

Par contre j'ai une question portant sur la classe : "markItUpButton markItUpButton15 markItUpSize markItUpDropMenu" qui affiche le sous-menu déployé par défaut lors de l'affichage de chaque page :-(

Est-ce que l'on peut désactiver ce fonctionnement ?

C'était à cause d'une ligne CSS dans mon thème.
=> Résolu.

Gotcha
2011-04-06 14:17:19

ddtddt a écrit:

Gotcha a écrit:

C'est bon pour moi avec l'affichage de mon thème. C'était un petit truc à la noix qui faisait un blocage.

et tu ne partages ton petit truc à la noix ?

Message éditer juste au dessus.

**********************

Par contre j'ai une question portant sur la classe : "markItUpButton markItUpButton15 markItUpSize markItUpDropMenu" qui affiche le sous-menu déployé par défaut lors de l'affichage de chaque page :-(

Est-ce que l'on peut désactiver ce fonctionnement ?

ddtddt
2011-04-06 14:14:46

Gotcha a écrit:

C'est bon pour moi avec l'affichage de mon thème. C'était un petit truc à la noix qui faisait un blocage.

et tu ne partages ton petit truc à la noix ?

Gotcha
2011-04-06 14:12:34

C'est bon pour moi avec l'affichage de mon thème. C'était un petit truc à la noix qui faisait un blocage.

Ancien code :

Code:

{footer_script require="jquery"}
{literal}
jQuery(document).ready(function(jQuery){
  stt = jQuery('#scrolltotop');
  jQuery(window).scroll(function(){
    scrollTop = jQuery(window).scrollTop();
    jQuery('#scrolltotop a').click(function(){
        jQuery('html,body').stop().scrollTop(0);
    });
    if(scrollTop >= 300){
      if(stt.css('opacity') == 0){
        stt.stop().fadeTo(2000,1);
      }
    }else{
      if(stt.css('opacity') > 0){
        stt.stop().fadeTo(500,0);  
      } 
    }
  });
  jQuery(window).scroll();
});
{/literal}
{/footer_script}

Nouveau code :

Code:

{footer_script}
{literal}
jQuery(document).ready(function(jQuery){
  stt = jQuery('#scrolltotop');
  jQuery(window).scroll(function(){
    scrollTop = jQuery(window).scrollTop();
    jQuery('#scrolltotop a').click(function(){
        jQuery('html,body').stop().scrollTop(0);
    });
    if(scrollTop >= 300){
      if(stt.css('opacity') == 0){
        stt.stop().fadeTo(2000,1);
      }
    }else{
      if(stt.css('opacity') > 0){
        stt.stop().fadeTo(500,0);  
      } 
    }
  });
  jQuery(window).scroll();
});
{/literal}
{/footer_script}

Ca se passe sur la première ligne.

Gotcha
2011-04-06 01:04:53

Je viens de trouver où ça cloche, dans mon fichier local_heade.tpl j'ai codé ce morceau :

Code:

{* Bannière des pages *}
{if (!$display_urbx_banner)}
<style type="text/css">
#{$BODY_ID} #theHeader {ldelim} display: none; {rdelim}
</style>
{/if}

{* Ajout du favicon qui tourne *}
<link rel="shortcut icon" type="image/x-icon" href="{$ROOT_URL}{$themeconf.icon_dir}/favicon.gif">

{* Ajout du flux RSS dans la barre de titre (FF) *}
<link rel="alternate" type="application/rss+xml" title="{'Galerie RSS feed'|@translate}" href="./notification.php">

{* Ajout de la fonction de détéction du navigateur *}
{combine_script id='browsers.script' load='header' path='themes/urbex/js/css.js}

{footer_script require='browsers.script'}
<!--
Name_motor = navigator.product;
Version_Motor = navigator.productSub;

if ((Name_motor=="Gecko" && Version_Motor>="20100115") 
  || (BrowserDetect.browser=="Firefox" && BrowserDetect.version>=3.5) 
  || (BrowserDetect.browser=="Safari" && BrowserDetect.version>=3.1) 
  || (BrowserDetect.browser=="Opera" && BrowserDetect.version>=10) 
  || (BrowserDetect.browser=="Chrome" && BrowserDetect.version>=4))
  document.write('<link rel="stylesheet" type="text/css" href="themes/{$themeconf.name}/CSS3.css">');
// -->
{/footer_script}

{* Redirect auto from google images. See : http://technet.ameriquebec.net/2009/03/23-241-ne-perdez-pas-votre-trafic-en-provenance-de-google-images.qc *}
<script language="JavaScript" type="text/javascript">
  if (top.location != self.location) top.location.replace(self.location);
</script>

{footer_script require="jquery"}
{literal}
jQuery(document).ready(function(jQuery){
  stt = jQuery('#scrolltotop');
  jQuery(window).scroll(function(){
    scrollTop = jQuery(window).scrollTop();
    jQuery('#scrolltotop a').click(function(){
        jQuery('html,body').stop().scrollTop(0);
    });
    if(scrollTop >= 300){
      if(stt.css('opacity') == 0){
        stt.stop().fadeTo(2000,1);
      }
    }else{
      if(stt.css('opacity') > 0){
        stt.stop().fadeTo(500,0);  
      } 
    }
  });
  jQuery(window).scroll();
});
{/literal}
{/footer_script}

C'est ça qui me fait planter bbcode_bar sans que je sache corriger :'(

Gotcha
2011-04-06 00:33:59

A toute fins utiles, voici le code original de picture.tpl

Code:

{if isset($comment_add)}
  <form method="post" action="{$comment_add.F_ACTION}" class="filter" id="addComment">
  <fieldset>
    <legend>{'Add a comment'|@translate}</legend>
    {if $comment_add.SHOW_AUTHOR}
    <label>{'Author'|@translate}<input type="text" name="author"></label>
    {/if}
    <label>{'Comment'|@translate}<textarea name="content" id="contentid" rows="5" cols="80">{$comment_add.CONTENT}</textarea></label>
    <input type="hidden" name="key" value="{$comment_add.KEY}">
    <input type="submit" value="{'Submit'|@translate}">
  </fieldset>
  </form>
  {/if}

Que je remplace par :

Code:

  {if isset($comment_add)}
  <form method="post" action="{$comment_add.F_ACTION}" class="filter" id="addComment">
  <fieldset>
        <table class="commentr">
        <tr>
          <td>
          <p>
              {if $comment_add.SHOW_AUTHOR}
            <label>{\'upload author\'|@translate}
                  <input type="text" name="author">
                </label>
              {/if}
              <br />
              </p>
              <input type="hidden" name="key" value="{$comment_add.KEY}">
              <input type="submit" value="{\'Submit comment\'|@translate}">
          </td>
            <td class="center" align="center">
              <textarea name="content" id="contentid" rows="5" cols="62" onFocus="if(this.value==\'Votre commentaire ici. Merci\')this.value=\'\'">Votre commentaire ici. Merci{$comment_add.CONTENT}</textarea>
            </td>
            <td>
             {\'Comment\'|@translate}<br />
            </td>
        </tr>
      </table>
    </fieldset>
  </form>
    {/if}

(le caractère simple quote est échapé, c'est normal)

Le problème ne semble pas provenir de ce fichier car dès que j'enlève cette personnalisation, le problème est toujours présent.

C'est peux-être le footer comme tu dis Zaphob. Je vais voir ça, merci.

Zaphod
2011-04-06 00:09:58

De ce que j'ai compris.

- il faut un form id="commentAdd"
- il faut le combine script dans le footer

Gotcha
2011-04-06 00:03:23

Chez moi (thème un peu spécial en plein développement) l'affichage ne se fait pas du tout.

Le plugin se base sur quoi pour l'affichage ??

Zaphod
2011-04-05 23:29:01

J'ai un problème de compatiblité avec mon thème.

L'affichage ne se fait pas bien :
http://www.audreyetjulien.fr/test/pictu … ategory/20
(cf. image ci-dessous)
Je pense que c'est parce que le champ commentaire est caché par défaut... la barre s'initialise donc mal.

Accessoirement l'affichage des smilies plante une fois le commentaire écrit.

mistic100
2011-04-03 21:37:50

nouvelle version disponible : 2.2.a
officiellement compatible avec Piwigo 2.2.0

Veillez à bien passer par la mise à jour automatique, ou au moins passer par la page d'administration, pour mettre à jour la configuration

Si la barre ne s'affiche pas vérifiez que vous n'utilisez pas de template-extension pour footer.tpl
Si c'est le cas vous devez modifier votre TE en ajoutant avant </body> le code suivant (nouveauté dans Piwigo 2.2)
{get_combined_scripts load='footer'}

sakkhho
2011-04-03 12:10:02

je confirme le bug.

a+

Alain Gb
2011-04-03 07:29:50

Bonjour

Un petit mot pour signaler un petit bug ci dessous :
http://pix.am/Ad30.png

avec la liste des plugins installés:
http://pix.am/u0U5.png

Je suis sur Mac.

Merci pour votre dévouement
Alain

Dazou
2010-12-13 19:13:07

Je n'ai pas fais le test, car je me suis aperçu que plusieurs personne utilisait "Google Chrome" (je pensais que se navigateur n'étais pas dans les principaux) et vu qu'avec google chrome il est impossible d'écrire un commentaire j'ai préféré le désinstaller malheureusement.

ddtddt
2010-12-10 10:34:33

je n'utilise pas ce thème
mais la manip que tu présentes prends pas longtemps et tu peux revenir facilement en arrière

Ce que je te conseil c'est de faire le test et de venir nous donner le résultat ;-)

Dazou
2010-12-10 10:02:26

Bonjour,

Je me suis mis a Piwigo il y a quelque semaine, car faisant de la photo sport mécanique en tant qu'amateur je voulais un site sans me cassé la tête car je connais pas grand chose au HTML.

On ma conseillé (SNF) Piwigo qui est vraiment simple d'utilisation (bravo au développeur).


Mais pour en revenir au sujet de BBCode_Bar, j'ai un petit souci avec Firefox. J'ai ma barre d'icône qui est totalement a droite, quand je clique dessus ils disparaissent et réapparaissent immédiatement mais impossible de les utiliser. Alors que sous IE tout marche niquel.

J'ai fais une petite recherche sur le forum et j'ai trouvé ceci :

VDigital a écrit:

[extension by Piwigo Team] LocalFiles Editor
onglet css

rules de ton thème, ajoute:

#outils {
  left:-600px;
  position:relative;
}

Mais ma question est si je fais cette manip. les utilisateurs d'IE n'auront plus la barre correctement mise en place mais complétement décalé a gauche ?

Si oui y a t-il une manip. pour que la barre d'icone soit en bonne place pour les 2 navigteurs (Firefox et IE) ?

PS : j'utilise le theme montblancxl (je sais pas si sa peut vous servir)

Merci de votre réponse.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact