Annonce

#1 2020-03-17 11:22:48

Cauneille
Membre
2014-11-30
16

Erreur 404 à l'installation

Bonjour,

Contexte :

J'ai un abonnement 1&1 Starter. Sur celui-ci, j'ai installé un serveur Web Joomla dans le répertoire « /WebAsa ». Mon nom de domaine en .fr est redirigé vers ce répertoire et est accessible en http et en https.
Ce site "brehal-cauneille.fr" fonctionne depuis plus d'un an.
Récemment, j'ai créé un sous-domaine "philatelie.brehal-cauneille.fr". Il pointe vers le répertoire « /Philatelie » dans lequel j'ai installé un serveur Web Joomla. Ce nouveau site fonctionne depuis plusieurs jours sans problème.

Problème :

Il y a plusieurs années, j'ai installé une galerie de photos sur mon espace personnel Free avec Piwigo. Cette galerie a fonctionné sans problème hormis ceux connus dus à Free. Depuis quelques temps, mon espace personnel est devenu inaccessible et donc la galerie inopérante.
Plutôt que de tenter de démêler les messages d'erreur nombreux devant lesquels je me trouvais, et puisque j'avais de l'espace disponible chez 1&1 j'ai décidé d’y installer une nouvelle version de ma galerie.
J’ai donc déclaré un nouveau sous-domaine de la même façon que le précédent. J’ai créé le sous-domaine « galerie-photos.brehal-cauneille.fr » et l’ai attaché au répertoire « /Galerie-photos ».
J’ai transféré le fichier « piwigo-netinstall.php » avec FileZilla et ai lancé la commande suivante :
http://galerie-photos.brehal-cauneille. … nstall.php
et j’ai obtenu la fameuse erreur « 404 Not Found ».

J’ai tenté l’installation manuelle décrite dans le site Piwigo mais toujours la même erreur. Dans les deux cas, j’ai essayé avec http et https avec le même résultat.

Je suis preneur de toute solution qui m’aidera à débrouiller le problème.
Merci d’avance


Version de Piwigo: 2.10.1
Version de PHP: 7.3
Version de MySQL: 5.5

Hors ligne

#2 2020-03-17 12:14:22

k5
Équipe Piwigo
lieu
2014-01-26
480

Re: Erreur 404 à l'installation

Bonjour,
Y a-t-il un ou plusieurs fichier .htaccess ?
Quelle est la version de piwigo ?
Vous voulez déplacer piwigo de free à un hébergeur 1&1 ?
je crois qu'avec le netinstall, on ne peut pas.
Si vous voulez reprendre une ancienne galerie mis sur free, il faut copier/coller toute la base et ses fichiers ensuite modifier le fichier database.inc.php et mettre les droits chmod sur les dossiers concernés. Aprés faire la mise à jour.
Ou alors, installer une nouvelle galerie, remettre les photos, les données importantes. En téléchargeant la derniere version piwigo.
Cordialement
k5


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#3 2020-03-17 13:18:54

Cauneille
Membre
2014-11-30
16

Re: Erreur 404 à l'installation

Merci pour votre réponse.

Comme je ne peux accéder à mon ancienne galerie, je repars sur une installation neuve et j'essaye d'installer la version 2.10.1

Il y a un .htaccess dans le répertoire /WebAsa sur lequel pointe brehal-cauneille.fr
Il n'y a pas de .htaccess dans le répertoire /Philatelie sur lequel pointe philatelie.brehal-cauneille.fr

Ces deux serveurs sont fonctionnels.

Cldt

Hors ligne

#4 2020-03-17 14:12:53

Cauneille
Membre
2014-11-30
16

Re: Erreur 404 à l'installation

Et bien il m'a suffit de copier le .htaccess de /WebAsa dans / et le message de début d'installation est apparu. Donc c'était tout bête je n'avais pas fait attention au fait que 1&1 n'était pas dans la liste des hébergeur pour lesquels l'installation de piwigo ne gérait pas elle-même le .htaccess

Donc problème résolu et merci à l'équipe d'avoir attiré mon attention sur ce fichier.

Cordialement

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact