Annonce

#1 2020-01-09 12:22:21

pconde
Membre
2020-01-08
3

erreur avec php 7.4

Bonjour

J'ai un système avec openSUSE tumbleweed, la dernière version de piwigo et php 7.4.1. Avec cette version de PHP j'ai  2 types de messages d'erreur:

1. Les deux fichiers piwigo/include/functions_cookie.inc.php et piwigo/admin/site_update.php contiennent des "{" au lieu de "[ "  pour des tableaux associatif (array). Facile a corriger.

2.  Une autre erreur provient de l'utilisation d'un tableau associatif avec un index inconnu aux lignes 125 et 126 dans le fichier  piwigo/include/functions_category.inc.php. Comme c'est compris dans une boucle d'exploitation d'un appel SQL, le message est répété un grand nombre de fois. Ensuite mon site fonctionne correctement sauf quand je retourne sur la page des galleries ou les erreurs s'affichent.
Les lignes concernées sont
        'SELECTED' => $selected_category['id'] == $row['id'] ? true : false,
        'IS_UPPERCAT' => $selected_category['id_uppercat'] == $row['id'] ? true : false,
En simulant l'appel SQL il me semble que $row['id'] est rempli. Reste donc $selected_category[...] comme suspect potentiel

    Piwigo 2.10.1
    Système d'exploitation: Linux
    PHP: 7.4.1 (Montrer les informations) [2020-01-09 10:58:44]
    MySQL: 10.3.20-mariadb [2020-01-09 11:58:44]
    Bibliothèque graphique: External ImageMagick 7.0.9-13

URL Piwigo: http://

J'ai vu sur le forum que ces erreurs ne se produisaient pas avec une version antérieure de PHP mais avec tumbleweed je ne peux pas redescendre à une ancienne version.

Salutations
Philippe

Hors ligne

#2 2020-01-21 12:25:26

r1299
Membre
2019-03-05
16

Re: erreur avec php 7.4

bonjour, j"avais également essayé en php 7.4.
Mais j'avais des erreurs. Du coup je suis sur php 7.0.33.
J'utilise ispconfig sur mon serveur, ce qui me permet d'avoir plusieurs versions de php.
ne connaissant pas opensuse, je ne sais pas si on peut changer la version de php.

Hors ligne

#3 2020-01-22 14:41:21

pconde
Membre
2020-01-08
3

Re: erreur avec php 7.4

Merci,

J'ai trouvé hier sur le site de piwigo (anglais)  une correction qui permet l'exécution sans erreur avec PHP 7.4.

Salutations
Philippe

Hors ligne

#4 2020-01-22 18:52:38

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14895

Re: erreur avec php 7.4

pconde a écrit:

Merci,

J'ai trouvé hier sur le site de piwigo (anglais)  une correction qui permet l'exécution sans erreur avec PHP 7.4.

Salutations
Philippe

Bonjour

Et tu la partage ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2020-01-23 08:32:46

pconde
Membre
2020-01-08
3

Re: erreur avec php 7.4

Bonjour,

voici la référence

https://github.com/Piwigo/Piwigo/pull/1 … 1f44370ce0

Il faut éditer le fichier piwigo/include/functions_category.inc.php et reporter les corrections de ce fix.
+2 nouvelles lignes et 2 lignes modifiées
Salutations
Philippe

Hors ligne

#6 2020-01-30 11:00:06

JeanKst
Membre
2020-01-17
2

Re: erreur avec php 7.4

merci Philippe, j'ai également cherché sur le site en anglais pour résoudre le problème, bon vent à vous

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact