•  » Installation
  •  » [Résolu] Probleme installation "Impossible de se connecter au serveur"

#1 2019-11-07 23:08:40

Aled
Invité

[Résolu] Probleme installation "Impossible de se connecter au serveur"

Bonsoir,

Je rencontre un problème lors de l'installationde piwigo, une fois rentré les login/mdp, je reçois l'erreur
"Impossible de se connecter au serveur".
Je ne trouve pas de fichier de log d'install,y en a t'il un ?
Le service mysql est bien actif, et fonctionne avec le login/mdp via la command mysql -u
J'ai essayé plusieurs valeurs pour l'hôte (localhost,127.0.0.1,localhost:3306,,127.0.0.1:3306), mais pas mieux.
J'ai supprimé/recréé la db (avec un nom différent), pas mieux.
changement de mdp du compte mysql,pas mieux.

Bref, je sèche...
Une idée ?

Merci

Version de Piwigo: 2.10.1
Version de PHP: PHP 7.2.24
Version de MySQL: Ver 14.14
URL Piwigo: http://

#2 2019-11-07 23:46:14

k5
Équipe Piwigo
lieu
2014-01-26
444

Re: [Résolu] Probleme installation "Impossible de se connecter au serveur"

Bonjour,
php 5.6 est il installé ?
je dirai de voir les privilèges exactes de la base de données.
ou alors
petit script test en php pour tester les droits mysqli :

Code:

<?php
$link = mysqli_connect("127.0.0.1", "my_user", "my_password", "my_db");
if (!$link) {
    echo "Erreur : Impossible de se connecter à MySQL." . PHP_EOL;
    echo "Errno de débogage : " . mysqli_connect_errno() . PHP_EOL;
    echo "Erreur de débogage : " . mysqli_connect_error() . PHP_EOL;
    exit;
}
echo "Succès : Une connexion correcte à MySQL a été faite! La base de donnée est génial." . PHP_EOL;
echo "Information d'hôte : " . mysqli_get_host_info($link) . PHP_EOL;
mysqli_close($link);
?>

Cordialement
k5


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#3 2019-11-08 13:08:58

Aled
Invité

Re: [Résolu] Probleme installation "Impossible de se connecter au serveur"

Bonjour K5,

Finalement, c'est bon, j'ai trouvé, une histoire de caractère special dans le Mdp qui n'etait pas bien apprecié !
A voir pour "escaper" les caractères spéciaux dans le champ pour solutionner le problème !

Merci

Al

  •  » Installation
  •  » [Résolu] Probleme installation "Impossible de se connecter au serveur"

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact