•  » Installation
  •  » Pas de connexion à la base de données après une migration

#1 2018-10-10 18:34:26

achrome
Membre
2017-03-11
11

Pas de connexion à la base de données après une migration

Bonjour/Bonsoir,

Je suis en train de migrer mon site piwigo depuis free vers un autre hébergeur.
J'ai transféré avec succès la base.
J'ai uploadé les fichier, mais lorsque je veux me connecter à la page d'accueil, j'ai le message suivant :

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /var/www/monsite.com/users/monlogin/www/piwigo/include/dblayer/functions_mysql.inc.php:38 Stack trace: #0 /var/www/monsite.com/users/monlogin/www/piwigo/include/common.inc.php(124): pwg_db_connect('localhost', 'monlogin', 'motdepasse', 'monlogin') #1 /var/www/monsite.com/users/monlogin/www/piwigo/index.php(26): include_once('/var/www/monsite...') #2 {main} thrown in /var/www/monsite.com/users/monlogin/www/piwigo/include/dblayer/functions_mysql.inc.php on line 38

J'ai renseigné le bon login, la bonne base et le bon mot de passe, bien sûr.

Je suspecte que le problème vient de mon mot de passe qui contient des caractères exotiques, comme î ou ñ par exemple.

Version de Piwigo: 2.9.4
Version de PHP: 7.2
Version de MySQL: 5.7

Hors ligne

#2 2018-10-11 06:53:14

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14236

Re: Pas de connexion à la base de données après une migration

Bonjour,

tu as modifié le fichier config avec quel logiciel ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2018-10-11 21:08:59

achrome
Membre
2017-03-11
11

Re: Pas de connexion à la base de données après une migration

Bonjour,

J'ai utilisé un éditeur de textes (gedit)

Voila le fichier complet (moins les infos perso)

Code:

$ cat database.inc.php
<?php
$conf['dblayer'] = 'mysql';
$conf['db_base'] = 'nomdemabase';
$conf['db_user'] = 'nomdutilisateur';
$conf['db_password'] = 'lemotdepasse';
$conf['db_host'] = 'localhost';

$prefixeTable = 'piwigo_';

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

?>

Hors ligne

#4 2018-10-11 21:11:56

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14236

Re: Pas de connexion à la base de données après une migration

tu peux essayer de remplacer

$conf['dblayer'] = 'mysql';

par

$conf['dblayer'] = 'mysqli';


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2018-10-11 21:21:44

achrome
Membre
2017-03-11
11

Re: Pas de connexion à la base de données après une migration

Oui, ça fonctionne !

Merci.

D'où vient l'erreur ? 

Hors ligne

#6 2018-10-11 21:46:38

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14236

Re: Pas de connexion à la base de données après une migration

version de php différente je dirais que chez free ce n'était pas php > 7


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#7 2018-10-11 21:52:17

achrome
Membre
2017-03-11
11

Re: Pas de connexion à la base de données après une migration

D'accord, ça me rassure, je n'ai pas fait le boulet :)

Peut-être faut-il rajouter une ligne là dessus dans la doc sur la migration ? (à moins qu'elle y soit et que je  l'ai loupée ?)

Hors ligne

  •  » Installation
  •  » Pas de connexion à la base de données après une migration

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2018 · Contact