•  » Plugins
  •  » Plugin OpenStreetmaps - incompatibilités avec Piwigo 2.9

#1 2018-03-25 12:19:10

Guillaume C
Membre
2014-04-08
133

Plugin OpenStreetmaps - incompatibilités avec Piwigo 2.9

Bonjour,

Je fais suite à la discussion [Forum, topic 223532] dans laquelle j'abordais un problème d'affichage de [extension by xbgmsharp] piwigo-openstreetmap

J'ai trouvé les causes mais pas la solution idéale:
Depuis la sortie de Piwigo 2.9.0, je OpenStreetmaps fonctionnait +/- mais ne s'affichait plus.

Les causes :
1. Incompatibilité (de mon installation ?) avec la redirection de la page d'accueil quand on a une page additionnelle en homepage

Code:

$conf['gallery_url'] = 'index.php/categories';

Résultat : Piwigo cherche le plugin dans les catégories et, évidemment, ne le trouve pas.

2. Incompatibilité (de mon installation ?) avec l'url rewriting

Code:

$conf['question_mark_in_urls'] = false;

Si on supprime la redirection de la page d'accueil, le plugin refonctionne correctement, sauf la "puce" qui ne s'affiche pas.

J'ai donc commenté les lignes provisoirement mais c'est pas top... si je les avais ajoutées, c'est que j'en avais besoin ;-)

Piwigo 2.9.3
Système d'exploitation: Linux
PHP: 5.4.45-0+deb7u11
MySQL: 5.5.59-0+deb7u1-log
Bibliothèque graphique: ImageMagick 6.7.7-10
URL Piwigo: http://guillaumecyriaque.be

Hors ligne

  •  » Plugins
  •  » Plugin OpenStreetmaps - incompatibilités avec Piwigo 2.9

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact