#1 2017-11-11 17:57:43

Bleuvague02
Invité

Migration 2.9.1 plus d'accès à mes utilisateurs???

Bonjour/Bonsoir,

Bonjour à tous,

J'utilise piwigo depuis plus de 5 ans avec une immense satisfaction, au passage un grand merci à l'équipe.

Je viens de migrer 2 sites de la 2.8.5 à la 2.9

Je rencontre un problème vraiment bizarre avec les deux migrations, à savoir, je ne peux plus rien faire au niveau des utilisateurs!!!!

Dans la forme dédiée, il n'y a plus d'affichage, les utilisateurs existent bien, je les vois via admin tools, je peux changer d'utilisateur sans problème. Mais je ne peux ni voir, ni créer d'utilisateur.

La forms groupe est ok

Sur un des deux site j'en ai 131... Je dois solutionner ce problème d'ici demain, sinon je dois repasser à la 2.8.5 sachant que tout est sous backup.

C'est la première fois que je rencontre des soucis lors d'une migration avec piwigo.

Si vous avez des pistes... 

Pour infos :
Les deux sites sont héberger sur des serveurs différents.


Version de Piwigo: 2.9.1
Version de PHP: 7
Version de MySQL: 5.5
URL Piwigo: http://

#2 2017-11-11 18:27:48

k5
Membre
Lieu: lieu
Date d'inscription: 2014-01-26
Messages: 200

Re: Migration 2.9.1 plus d'accès à mes utilisateurs???

Bonjour Bleuvague02, est ce que vous pouvez essayer un check files integrity ?

http://fr.piwigo.org/ext/extension_view.php?eid=844

k5
cordialement

Dernière modification par k5 (2017-11-11 18:29:06)


Beta testeur disponible - développeur - hébergement multiple... (free, webhost,hosting,ex2,ovh,hostinger,kalanda,local,serveur,git,BSD...)
Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#3 2017-11-11 18:29:46

Bleuvague02
Invité

Re: Migration 2.9.1 plus d'accès à mes utilisateurs???

Pour infos, je viens d'essayer quelque chose de pas vraiment conseillé...
J'ai viré le dossier admin et mis le dossier admin de la version 2.8.5 et là la forme des utilisateur fonctionne !!!

Donc hormis un bug où problème de plug-in je ne vois pas...
Sachant que les plugin que j'utilise sont ok pour la 2.9

#4 2017-11-11 18:37:13

Bleuvague02
Invité

Re: Migration 2.9.1 plus d'accès à mes utilisateurs???

Je viens d'essayé et j'ai bien une liste de fichier modifié :

admin/include/mysqldump.php has been modified
admin/include/updates.class.php has been modified
admin/site_reader_local.php has been modified
admin/themes/clear/icon/index.php has been modified
admin/themes/clear/index.php has been modified
admin/themes/clear/themeconf.inc.php has been modified
admin/updates.php has been modified
admin/updates_ext.php has been modified
admin/updates_pwg.php has been modified
galleries/index.php has been modified
include/Logger.class.php has been modified
include/mdetect.php has been modified
local/config/index.php has been modified
local/css/index.php has been modified
local/index.php has been modified
plugins/index.php has been modified
template-extension/index.php has been modified
template-extension/yoga/index.php has been modified
template-extension/yoga/local/index.php has been modified
themes/default/icon/index.php has been modified
themes/default/icon/mimetypes/index.php has been modified
themes/default/images/index.php has been modified
themes/default/index.php has been modified
themes/default/template/mail/index.php has been modified
themes/default/template/mail/text/html/index.php has been modified
themes/default/template/mail/text/index.php has been modified
themes/default/template/mail/text/plain/index.php has been modified
themes/index.php has been modified

Du coup que dois-je faire ?

#5 2017-11-11 19:49:58

Bleuvague02
Invité

Re: Migration 2.9.1 plus d'accès à mes utilisateurs???

Pour informations j'ai fait pas mal de test....

Pour le moment :
Je au refait une clean install en supprimant tous les thèmes et plugin ajouté, le problème persiste!

Il semblerait que le problème se situe au niveau du fichier user_list.tpl du thème actif pour l'admin.
Si je le remplace par celui de la version 2.8.5 cela "fonctionne" au niveau visuel.
Comme je ne sais pas si il y a eu des modifications dans la base user depuis la 2.8.5 jeune vais pas essayer un insert de record....

Là, il me reste 2 solutions
1: repasser totalement à la version 8.2.5
2: voir si je trouve à vue de nez un soucis dans le fichier user_list.tpl....

#6 2017-11-11 22:41:00

Bleuvague02
Invité

Re: Migration 2.9.1 plus d'accès à mes utilisateurs???

Bon...

Si cela intéresse un administrateur, j'ai donc réalisé des testes sur user_list.tp.
C'est bien là que cela coince !!!! En effet certain appel au jQuery semble revenir vide ???
Si jamais voir bloc de code ligne 579 à à 643.
Si on supprime cette partie et on place celle d'une version 2.8.5 ou 2.8.6 on arrive à voir la liste des utilisateur. Certes cela ne revoit rien aux forms d'édition, mais cela semble démontrer qu'il y a un problème avec le jQuery.
Je suis reparti d'une version neuve, mais rien y fait.
J'ai tetsé avec plusieurs browser rien y fait non plus.

Du coup, sur mes gros sites j'ai du repasser en 2.8.5, mais sur un de mes sites j'ai laissé la 2.9.2 si jamais un administrer veut tester c'est sans problème.

#7 2017-11-12 01:37:38

Bleuvague02
Invité

Re: Migration 2.9.1 plus d'accès à mes utilisateurs???

J'ai tout repris depuis le début !

La conclusion est la suivante :

Quand je fais une mise à jour vers 2.9.x, j'ai systématiquement le problème avec cette disparition de la liste des utilisateurs dans l'admin.

Quand je repas depuis une installation totalement vierge cela fonctionne parfaitement.

J'ai réalisé pas mal de test, j'ai pensé à un problème de code dans user_list.tpl, mais non.
A un problème avec la bae de donnée, non plus.

Au final, j'y ai été dossier par dossier et je remarque que si je supprime physiquement le dossier themes, puis si je reprend le dossier themes téléchargé avec la 2.9.x cela fonctionne parfaitement !!!!

Je ne m'explique pas pourquoi, mais ça passe et c'est l'essentiel pour moi.

A votre disposition pour en parler ou faire des testes.

#8 2017-11-12 06:10:28

ddtddt
Équipe Piwigo
Lieu: Quetigny (21) - France
Date d'inscription: 2007-07-27
Messages: 13868
Site web

Re: Migration 2.9.1 plus d'accès à mes utilisateurs???

Bonjour,

Sans doute un plugin ou un thème qui ont un bout de code incompatible entre eux


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

Pied de page des forums

Propulsé par FluxBB