#1 2017-09-14 14:15:04

nenesite
Membre
Date d'inscription: 2009-07-23
Messages: 5

Problème Exif

Bonjour/Bonsoir,



j'ai des soucis avec les données exif
comme dit dans un message précedent, j'ai fait une mise à jour en pensant résoudre le pb.
ça n'a pas résolu le pb.

Les données qui m’intéressent sont surtout la date de prise de vue.
Certaines images sont bien synchronisées, d'autres non. Lorsque je regarde les données Exif du fichier que je rapatrie en FTP, elles semblent correctes.

par exemple :
sur cette photo :
http://jumpifnotzero.free.fr/galerie/picture.php?/1380
la date n'est pas reconnue, alors que mon logiciel (en local) me trouve les infos suivantes :
-- IFD0 --
Fabricant: Canon
Modèle: Canon PowerShot G9
Orientation de l’image: 1
Résolution en X: 180.0 ppi (pixel par pouce)
Résolution en Y: 180.0 ppi (pixel par pouce)
Unité de résolution: pouce
Date et heure du fichier: 2010:03:06 19:45:16
Positionnement Y et C: Centré
-- Données EXIF IFD --
Temps d’exposition: 1/2 s
Diaphragme ƒ: 2.8
Sensibilité ISO estimée: 400
Version Exif: 0220
Date/heure création des données originales: 2010:03:06 19:45:16
Date et heure de la génération des données numériques: 2010:03:06 19:45:16
Signification de chaque composant: Réservé
Mode de compression de l’image: 3.0
Vitesse d’obturation: 1.0 APEX = 1/2 s
Ouverture: 3.0 APEX = F2.8
Biais d’exposition: 0.0
Ouverture maximale objectif: 3.0 APEX = F2.8
Mesure de lumière: Moyenne centrée sur la largeur
Flash: Flash non déclenché, mode flash forcé.
Focale lentille: 7.4 mm
(et encore plein d'autres info après)

sur cette photo :
http://jumpifnotzero.free.fr/galerie/picture.php?/141
la date est correctement lue, mais si on affiche les meta données avec le petit appareil photo haut, il sort une erreur

j'ai fait les manip suivantes :
- essais de resynchroniser les images
- j'ai modifié le fichier local/config/config.inc.php selon un tuto trouvé : http://fr.piwigo.org/doc/doku.php?id=pw … lites:meta
"
$conf['show_exif'] = true;
$conf['use_exif_mapping'] = array(
'date_creation' => 'DateTimeOriginal'
"

j'ai mis cette photo en"sample.jpg" dans mon dossier /tool/ pour lire les infos :
http://jumpifnotzero.free.fr/galerie/tools/metadata.php
je vois que ça ne marche pas, mais je ne sais pas aller plus loin ?!

Version de Piwigo: 2.9.1
Version de PHP: 5.6.8 (serveur free.fr)
Version de MySQL: 5.0.83
URL Piwigo: http://jumpifnotzero.free.fr/galerie/

Dernière modification par nenesite (2017-09-14 14:20:59)

Hors ligne

#2 2017-09-14 14:32:19

nenesite
Membre
Date d'inscription: 2009-07-23
Messages: 5

Re: Problème Exif

Je me répond à moi même…
sur Mac, j'utilise le logiciel "Graphic Converter" pour faire tout le traitement des mes photos.
Sur certaines photos, les données exif semblent corrompues mais Graphic Converter sait les interpréter quand même.

Après faire "Reconstruire les MetaDonnées" ça semble marcher…
le problème vient donc bien des fichiers images

Hors ligne

#3 2017-09-14 21:13:03

ddtddt
Équipe Piwigo
Lieu: Quetigny (21) - France
Date d'inscription: 2007-07-27
Messages: 13833
Site web

Re: Problème Exif

Merci pour le retour


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

Pied de page des forums

Propulsé par FluxBB