#1 2017-09-14 11:33:51

Katryne
Membre
Lieu: Provence
Date d'inscription: 2016-12-03
Messages: 168
Site web

[Résolu] Open Street Map : pas partout ?

Bonjour !
Ça fait longtemps que je n'ai pas spécifié de géolocalisation et je m'aperçois que pour certaines photos la mini-carte est présente au bas de la page photo et dans d'autres non, alors que toutes les épingles sont bien présentes sur la carte de la catégorie. J'ai loupé une config  quelque part ?

Voilà un exemple : http://photos.revestou.fr/index?/category/Eau

Sur la page de catégorie, il y a bien 7 photos (dont 4 dans un sous-album) et donc 7 épingles sur la carte.
Quand on ouvre la page individuelle de chaque photo, on voit bien le petit bout de carte en bas de page. Sauf pour l'impluvium d'Orves où il n'y a pas de carte individuelle, même si on voit toujours son épingle sur la carte en page de catégorie.

Comment cela se fait ?

Là, je commence à géolocaliser des images d'une autre catégorie http://photos.revestou.fr/index?/category/30sites et ça me fait le même coup : c'est correctement configuré en admin, c'est visible sur la page de catégorie, mais rien sur la page individuelle.

Il est possible que les cartes individuelles qui s'affichent aient été configurées dans la version précédente de Piwigo ou du plugin ?

Merci d'avance de votre expertise.


Piwigo 2.9.2 -  Système d'exploitation: Linux
PHP: 7.0.24
MySQL: 5.5.57-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#2 2017-09-14 17:55:28

JPD
Membre
Lieu: Sud Bourgogne
Date d'inscription: 2012-06-29
Messages: 37

Re: [Résolu] Open Street Map : pas partout ?

Bonsoir,
J'ai eu un problème qui me semble similaire. Lors des réglages du plugin, dans l'item "Configuration panneau de droite", il faut choisir une propriété avant laquelle ajouter la localisation. Il faut que la propriété choisie soit bien sélectionnée dans configuration Piwigo > onglet "Affichage" > propriétés de la photo. Malheureusement le plugin propose la liste complète des propriétés et pas seulement celles sélectionnées.
Je n'ai rien observé de désagréable au cours des migrations de Piwigo et du plugin  que j'ai suivi avec mes galeries.


Piwigo : 2.9.1
PHP : 5.6.31
MySQL : 10.0.32-Maria DB
ImageMagick 6.7.2-7

Hors ligne

#3 2017-09-14 19:40:53

Katryne
Membre
Lieu: Provence
Date d'inscription: 2016-12-03
Messages: 168
Site web

Re: [Résolu] Open Street Map : pas partout ?

Merci merci merci ! C'est cela, oui, j'avais zoublié !

Dans la config d'OSM, j'avais demandé l'affichage de la carte avant l'info Mots-clés.
Sauf que je n'ai pas renseigné systématiquement les mots-clés et quand yen a pas, ben la carte s'affiche pas.

Alors là, j'ai configuré l'affichage des visites, et demandé de positionner la carte avant les visites. Comme c'est une info automatique qui n'a pas besoin de saisie humaine, l'affichage est certain et celui de la carte itou.


Piwigo 2.9.2 -  Système d'exploitation: Linux
PHP: 7.0.24
MySQL: 5.5.57-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

Pied de page des forums

Propulsé par FluxBB