#1 2017-08-25 21:56:02

swirti
Membre
Date d'inscription: 2015-06-25
Messages: 6

problème d'identification

Bonjour,

Suite à la mise à jour vers la dernière version 2.9.1, impossible de me connecter à l'admin, le message suivant s'affiche sur une page blanche :
Piwigo a rencontré une erreur non récupérable
[Hacking attempt] the input parameter "redirect_decoded" is not valid
#1    check_input_parameter /home/montagne/www/gallery/identification.php(50)


J'ai modifié le fichier identification.php comme indiqué ici
[Github] Piwigo commit eff13709 mais ça ne marche toujours pas.

J'ai le paramètre $conf['gallery_url'] = null;

Que dois-je faire pour réparer ce problème ?

Merci pour votre aide

Version de Piwigo: 2.9.1
Version de PHP: 5.6.30
Version de MySQL: 5.5.51-38.2

Hors ligne

#2 2017-08-27 07:00:35

ddtddt
Équipe Piwigo
Lieu: Quetigny (21) - France
Date d'inscription: 2007-07-27
Messages: 13777
Site web

Re: problème d'identification

Bonjour,

swirti a écrit:

J'ai le paramètre $conf['gallery_url'] = null;

Tu as la ligne en config local ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2017-08-27 15:08:13

swirti
Membre
Date d'inscription: 2015-06-25
Messages: 6

Re: problème d'identification

bonjour,

non la ligne est seulement dans config_default.inc.php

Hors ligne

#4 2017-08-27 16:10:13

ddtddt
Équipe Piwigo
Lieu: Quetigny (21) - France
Date d'inscription: 2007-07-27
Messages: 13777
Site web

Re: problème d'identification

Bonjour,

Si tu va sur l'accueil de ta galerie puis sur la page identification, cela ne fonctionne pas ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2017-08-27 21:03:19

flop25
Équipe Piwigo
Date d'inscription: 2006-07-06
Messages: 6233
Site web

Re: problème d'identification

Bonjour
en effet via quel lien et url y accédez vous ? Sous quel thème ?

Hors ligne

#6 2017-08-27 21:30:38

swirti
Membre
Date d'inscription: 2015-06-25
Messages: 6

Re: problème d'identification

Bonsoir,

Si je veux m'identifier via cette URL, j'ai l'erreur alors qu'avant la 2.9.1, ca marchait.
   identification.php?redirect=index.php?/categories


Si je m'identifie via cette URL, c'est-à-dire sans la redirection, c'est ok
   identification.php

Dernière modification par swirti (2017-08-27 21:33:38)

Hors ligne

#7 2017-09-11 22:14:55

swirti
Membre
Date d'inscription: 2015-06-25
Messages: 6

Re: problème d'identification

Bonjour,

personne ne peut résoudre mon problème ?

Hors ligne

#8 2017-09-11 23:26:41

Guillaume C
Membre
Date d'inscription: 2014-04-08
Messages: 115
Site web

Re: problème d'identification

Bonsoir,
Même problème chez moi depuis 2.9.1, avec Bootstrap Darkroom et uniquement via le menu connexion. J''avais mis ca sur le compte du thème mais pas cherché plus loin puisqu'on sait se connecter via la page identification ... J'y regarderai de plus près ce WE.

Hors ligne

Pied de page des forums

Propulsé par FluxBB