#1 2017-08-30 09:17:28

PascalH
Invité

problème de configuration de la base SQL

Bonjour,

Ayant un hébergement sur Ouvaton.coop, j'ai  installé  Piwigo sur celui-ci, mais j'ai un problème lorsque j'essaie de configurer ma Base SQL à partie de la boite de dialogue de Piwigo

Pour la Database configuration

    Dans le champ Host je mets le Serveur fourni par Ouvaton (j'ai aussi essayé en laissant localhost mais là j'obtiens Can't connect to server)
    Dans User je mets le login fourni par Ouvaton
    Dans Password je mets le PW que j’ai défini en créant la base Sql

Pour L’Admin Config :

    Dans le champs Username je mets mon prénom
    Pour le Password j’utilise le même PW que pour la database
    Enfin je mets une adresse mail qui m’appartient.


Quand je clique sur <start install> j’obtiens le message d'erreur suivant :
Fatal error: Call to a member function fetch_assoc() on boolean in /var/www/vhosts/MonNom.fr/httpdocs/Photos/include/dblayer/functions_mysqli.inc.php on line 226

Et Paf le chien cela stoppe,normal Fatal Error, et je ne sais comment m’en sortir.

Je voulais mettre en PJ une capture des données de ma base SQL mais je n'ai su le faire.

Merci des conseils et meilleures salutations.

Pascal H


Version de Piwigo: 2.9.1
Version de PHP: 5.6.20.
Version de MySQL: MariaDB en version 5.5.34, avec LibMySQL en version 5.5.31.

#2 2017-08-30 09:35:39

flop25
Équipe Piwigo
Date d'inscription: 2006-07-06
Messages: 6267
Site web

Re: problème de configuration de la base SQL

Bonjour
déjà

PascalH a écrit:

Pour le Password j’utilise le même PW que pour la database

non
On n'utilise jamais le même mot de passe deux fois surtout pour un serveur

D'abord allez supprimer les tables de Piwigo dans la base de données. Supprimez également le fichier local/config/database.inc.php . Là on repart à zéro
Puis re téléchargez Piwigo sur votre ordi et ré envoyez les fichiers par FTP en écrasant ceux existant

Dernière modification par flop25 (2017-08-30 09:44:39)

Hors ligne

#3 2017-08-31 16:11:22

PascalH
Invité

Re: problème de configuration de la base SQL

Bonjour Flop 25,

Je ne sais pas accéder aux tables piwigo dans ma base Sql (il ne doit pas y en avoir des masses car je n'ai pas encore réussi à initialiser ma base)
Idem je ne sais pas où est le fichier local/config/database.inc.php
J'ai supprimé tout le contenu du dossier Photos où j'avais téléchargé les données Piwigo comme dit de la faire l'installateur manuel et chargé à nouveau les données PwGo sur mon site cela foire tout pareil avec le même message d'erreur.

Je vais essayer avec NetInstall et vous tient au courant

Bonne fin de journée.

pascal

#4 2017-09-01 08:58:58

PascalH
Invité

Re: problème de configuration de la base SQL

Bonjour,

J'ai donc essayé avec NetInstall.
Je l'ai chargé sur mon site dans httpdocs, y ait accédé ai obtenu l'écran Piwigo mais lorsque j'ai cliqué pour lancer le processus j'ai récolté une erreur 403.
Tant pis...

Bonne journée.

pascal

Pied de page des forums

Propulsé par FluxBB