Annonce

  •  » Utilisation
  •  » [Résolu] Icones administration (Fontello et images)

#1 2016-08-02 19:10:22

Guillaume C
Membre
Belgium
2014-04-08
184

[Résolu] Icones administration (Fontello et images)

Bonjour/Bonsoir,

Ca fait un moment que je laisse ça de côté et, vacances obligent, j'ai tenté d'y regarder... Depuis quelques mois, les icônes et images de l’administration ne s'affichent plus correctement (voir capture). Les fichiers images et fontello sont pourtant bien présents. Quelqu'un aurait rencontré le même problème et/ou aurait une piste pour solutioner ceci ?

D'avance, merci :-)

Version de Piwigo: 2.8.2
Version de PHP: 5.4.45
Version de MySQL: 5.5.49
URL Piwigo: http://guillaumecyriaque.be/


Images attachées

Hors ligne

#2 2016-08-03 08:01:49

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14862

Re: [Résolu] Icones administration (Fontello et images)

Bonjour,

est ce que repertoire admin/themes/default/fontello
et bien présent sur ton site et identique à celui de l'archive ?

permission sur ces fichier ?

erreur dans la console du navigateur ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2016-08-03 11:22:26

Guillaume C
Membre
Belgium
2014-04-08
184

Re: [Résolu] Icones administration (Fontello et images)

Bonjour ddtddt,
Oui, tout y est.
Pour être sûr, j'ai renvoyé tout le répertoire thème sur le serveur mais rien n'y a fait. Cache navigateur purgé et templates compilés purgés aussi au cas où (je ne sais pas si ça agit sur les thèmes de l'administration).
CHMOD 755 pour tout le répertoire et son contenu (je pense, je ne les ai pas tous vérifiés).
Ce qui est étrange, c'est que certaines icônes fontello et certaines images s'affichent correctement. Au départ, j'ai pensé que ça pouvait provenir d'une modif de ma part (javascript). J'ai donc désactivé tous les plugins mais rien n'y a fait.
J'ai effectivement quelques erreurs et des avertissements dans la console sur la page d'accueil de l'admin pour fontello et les images. Le fichier qui poserait problème serait http://guillaumecyriaque.be/_data/combined/egcg13.css => Est-ce que je peux vider ce répertoire sans planter l'affichage et est-ce que les fichiers se recréeront automatiquement ?

Hors ligne

#4 2016-08-03 13:30:54

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14862

Re: [Résolu] Icones administration (Fontello et images)

Guillaume C a écrit:

J'ai effectivement quelques erreurs et des avertissements dans la console sur la page d'accueil de l'admin pour fontello et les images. Le fichier qui poserait problème serait http://guillaumecyriaque.be/_data/combined/egcg13.css => Est-ce que je peux vider ce répertoire sans planter l'affichage et est-ce que les fichiers se recréeront automatiquement ?

Bonjour,

Oui tu peux aller dans Administration > Outils > maintenances

Purger le cache utilisateur / Purger les templates compilés


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2016-08-03 14:06:40

Guillaume C
Membre
Belgium
2014-04-08
184

Re: [Résolu] Icones administration (Fontello et images)

ddtddt a écrit:

Oui tu peux aller dans Administration > Outils > maintenances

Purger le cache utilisateur / Purger les templates compilés

Déjà fait et ça n'avait strictement rien changé. Je pensais plutôt à une suppression manuelle via ftp de tout le contenu du répertoire /_data/combined, à l'exception du fichier index.

Hors ligne

#6 2016-08-03 14:20:52

Guillaume C
Membre
Belgium
2014-04-08
184

Re: [Résolu] Icones administration (Fontello et images)

J'ai tenté le tout pour le tout:
1. J'ai réuploadé tous les fichiers piwigo via ftp
2. J'ai vidé les répertoires /_data/combined/ et /_data/templates-c/ via ftp
3. J'ai purgé le cache utilisateur et les templates compilés via l'admin (une nouvelle fois)
=> aucun changement.

Dernière modification par Guillaume C (2016-08-03 14:24:09)

Hors ligne

#7 2016-08-03 17:59:25

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12364

Re: [Résolu] Icones administration (Fontello et images)

Bonjour,

Désactive les plugins un par un et trouve celui qui provoque ça (c'est souvent lié à un plugin).


Dernier billet du blog Piwigo.com (18 mars 2020) Covid19 : allongement de la période d’essai pour les entreprises

Hors ligne

#8 2016-08-03 18:10:20

Guillaume C
Membre
Belgium
2014-04-08
184

Re: [Résolu] Icones administration (Fontello et images)

Salut Pierrick,
Déjà essayé aussi, c'est d'ailleurs ce que j'ai fait en 1er. Malheureusement, sans résultat.

Hors ligne

#9 2016-08-03 18:18:46

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12364

Re: [Résolu] Icones administration (Fontello et images)

Guillaume C a écrit:

Ce qui est étrange, c'est que certaines icônes fontello et certaines images s'affichent correctement. Au départ, j'ai pensé que ça pouvait provenir d'une modif de ma part (javascript). J'ai donc désactivé tous les plugins mais rien n'y a fait.

Est-ce que cela veut dire que tu fais toutes tes modifs dans un plugin? (bravo) En tout cas, c'est la meilleure piste que je vois.

Guillaume C a écrit:

J'ai effectivement quelques erreurs et des avertissements dans la console sur la page d'accueil de l'admin pour fontello et les images.

C'est clair que tant que tu as ces erreurs dans la console, tu auras des icônes corrompues.


Dernier billet du blog Piwigo.com (18 mars 2020) Covid19 : allongement de la période d’essai pour les entreprises

Hors ligne

#10 2016-08-03 18:36:09

Guillaume C
Membre
Belgium
2014-04-08
184

Re: [Résolu] Icones administration (Fontello et images)

Non, ça signifie que j'ai déjà vérifié en désactivant les plugins (en commençant par les miens ou ceux qui contenaient du code perso) mais ça n'a pas solutionné le problème.

En plugins perso, il y a le footer (pour intégrer l'outil de statistiques en php et qui apparaît dans l'admin) et le bloc réseaux sociaux (mais qui n'apparaît pas dans l'admin). Pour le reste, j'ai utilisé les outils (plugins) existants et qui n'interfèrent ps avec l'admin.

Le bug date déjà d'un moment, je ne saurais plus dire s'il est apparu suite à une mise à jour ou lors de tests de GrayDragon (qui modifie l'apparence de l'admin).

Je sèche...

Questtion subsidiaire: est-ce que je pourrais passer par LocalFilesEditor pour court-circuiter le bug et solutionner le problème ? Si non, que pourrais-je modifier dans le css du thème admin pour contourner le problème ?

Hors ligne

#11 2016-08-04 14:54:40

Guillaume C
Membre
Belgium
2014-04-08
184

Re: [Résolu] Icones administration (Fontello et images)

C'est bon, j'ai trouvé !

Ca provenait de mon .htaccess Il restait un oubli de l'époque où j'ai tenté l'url rewriting mais abandonné car mon hébergeur ne prend pas en charge certaines règles par "mesures de sécurité".

Bref, .htaccess nettoyé, tout est revenu à la normale. Il faudra quand même m'expliquer pourquoi certaines icônes fontello et certaines icônes images s'affichaient correctement et d'autres non...

Hors ligne

  •  » Utilisation
  •  » [Résolu] Icones administration (Fontello et images)

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact