Annonce

  •  » Utilisation
  •  » Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

#1 2014-01-28 12:18:02

oliverfr
Membre
2013-04-27
158

Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Bonjour,

MISE A JOUR : Rebelote avec Piwigo 2.7.3, autant répondre dans le même thread, cf. ma réponse en bas de page pour les détails ;)

C'est mineur comme souci, j'ai remarqué que depuis la mise à jour à Piwigo 2.6 (et 2.6.1 itou), quand je clique pour ajouter un album (photos > add > create new album), dans la fenêtre que ça ouvre, il y a toujours, en "parent album", le dernier album uploadé précédemment.

Savez-vous si l'on peut personnaliser cela pour que cela propose plutôt l'option au-dessus, "-------", c'est à dire : pas d'album parent, en faire un nouvel album tout court ?

Je m'en remettrai si ça n'est plus possible par défaut, hein, mais je demande à tout hasard ;)

Dernière modification par oliverfr (2015-01-10 02:25:24)

Hors ligne

#2 2014-01-29 18:08:39

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12364

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Bonjour olivierfr,

Ça a toujours été comme ça (c'est plus logique) et c'est "codé en dur".


Dernier billet du blog Piwigo.com (18 mars 2020) Covid19 : allongement de la période d’essai pour les entreprises

Hors ligne

#3 2014-01-29 22:48:04

oliverfr
Membre
2013-04-27
158

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Ah bon ?!?
(merci, hein !)

O_o

Boooon, ben, c'était l'installation chez moi qui était "buggée", en ne proposant pas d'album parent par défaut, alors...

Je n'en reviens pas. Ou alors j'ai trouvé génialement tout seul le moyen de hard-coder le changement, et je ne m'en souviens même plus O_o

S'il te plaît Plg, existe-t-il un moyen de modifier cette option quelque-part, quitte à modifier le code source ?

Hors ligne

#4 2014-01-29 22:55:41

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12364

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

admin/themes/default/template/include/add_album.inc.tpl, ligne 13, remplacer :

Code:

        .val($albumSelect.val() || 0);

par

Code:

        .val(0);

Dernier billet du blog Piwigo.com (18 mars 2020) Covid19 : allongement de la période d’essai pour les entreprises

Hors ligne

#5 2014-01-29 23:05:06

oliverfr
Membre
2013-04-27
158

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Je le note précieusement.

Merci beaucoup ! :)

Hors ligne

#6 2015-01-10 02:23:31

oliverfr
Membre
2013-04-27
158

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Bonjour,

Je viens d'appliquer la toute dernière MAJ de sécurité de piwigo, en prenant l'archive contenant juste les nouveaux fichiers, et cela a changé le comportent de Piwigo pour l'ajout de nouveaux albums.

- auparavant, depuis la version 2.7, quand je fais Ajouter des photos, par défaut cela ne me propose aucun album, je tape le nom de l'album que je veux

- maintenant, avec la MAJ de sécurité de ce matin, cela prend par défaut le dernier album créé, et je me suis retrouvé à créer par accident un sous-album

S'il vous plaît, comment peut-on désactiver cela, sous Piwigo 2.7, pour que l'ajout de photos n'ait pas d'album présélectionné ?

La solution qui avait été donnée précédemment ne fonctionne plus, il n'y a plus de "val($albumSelect.val() || 0);" ni de ".val(0);" dans admin/themes/default/template/include/add_album.inc.tpl...

Merci BEAUCOUP si vous pouvez me dépanner :)

Hors ligne

#7 2015-01-10 10:09:21

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3556

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

c'est surtout que les versions précédentes 2.7 étaient buguées de notre point de vue

donc dans le même fichier, ligne 248

supprimer

Code:

data-default="first"

Hors ligne

#8 2015-01-10 11:41:08

oliverfr
Membre
2013-04-27
158

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Merci de ta réponse, Mistic100 !

Cependant, mon add_album.inc.tpl fait 25 lignes seulement...

J'ai cherché dans tout /admin /includes /plugins /template-extension /themes /tools et les fichiers à la racine, et je ne trouve nulle part de champ de texte contenant [ data-default ] ou [ ="first" ]

J'ai retéléchargé un piwigo tout neuf, refait mes recherches dans l'intégralité des fichiers (notepad++, *.*, mode normal ni étendu ni regex), et, pareil, ni data-default ni "first".

Pas non plus en BDD - par acquis de conscience.

S'il te plaît, par où faut-il regarder ?

EDIT : bordel de m*rde, en regardant juste au cas où, je l'ai trouvé, mais j'ai fait comment pour ne pas trouver avec les fonctions de recherche ?!? >_<

J'ai regardé dans le dossier parent du "include", et j'ai classé les fichiers par taille pour trouver lequel pourrait faire 248 lignes. Dans les candidats, photos_add_direct.tpl
Et là, j'ai trouvé data-default="first" à la ligne 308.

C'est très frustrant, il faut que j'y aille (enfants, trucs à Lille) sans avoir eu le temps de chercher pourquoi je n'ai rien trouvé et si ça règle ma question. Au moins, je rushe cet EDIT :(

EDIT2 ça doit être l'option sous-dossiers je dois l'avoir oubliée argh je dois y aller

Dernière modification par oliverfr (2015-01-10 11:47:42)

Hors ligne

#9 2015-01-10 14:30:56

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3556

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

oui pardon c'est dans photos_add_direct

Hors ligne

#10 2015-01-11 03:56:06

oliverfr
Membre
2013-04-27
158

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Me revoilà.

C'est vraiment embarrassant, d'avoir du partir au milieu de ce bazar, je suis désolé ! :(

Bon, sinon, oui, j'avais bien oublié de cocher de rechercher aussi dans les sous-dossiers. Snif.

Cela dit, pour en revenir au coeur du sujet, j'ai bien supprimé data-default="first", pour avoir ainsi les lignes 246, 247 et 248 :

Code:

      <span id="albumSelection" style="display:none">
      <select data-selectize="categories" data-value="{$selected_category|@json_encode|escape:html}"
        name="category" style="width:600px"></select>

Et, pourtant, quand je clique pour créer un nouvel album, cela part tout de même pour créer un album parent du dernier album créé, au lieu de ne pas avoir d'album parent et me proposer de créer un nouvel album tout court...

Je me suis déconnecté puis reloggé, rien n'y a fait.

Peut-être autre-chose que "first", plutôt qu'une suppression pure et simple ?

Dernière modification par oliverfr (2015-01-11 03:57:06)

Hors ligne

#11 2015-01-11 05:11:39

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14909

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Bonjour
Tu as purgé le template compilé ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#12 2015-01-11 11:45:28

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3556

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

il faut aussi enlever le "data-value"

attention qu'en faisant ça, si vous oubliez de mettre un album, l'upload va démarrer et planter sur la fin, et ça fera des photos orphelines

Hors ligne

#13 2015-01-11 16:38:49

oliverfr
Membre
2013-04-27
158

Re: Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Ah, ôter le champ data-value a fait le boulot !

Merci beaucoup !! :)

Hors ligne

  •  » Utilisation
  •  » Question relative à l'ajout de nouvel album, avec Piwigo 2.7.3 ?

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact