#1 2014-11-22 09:28:53

Maniack Crudelis
Invité

Error: Invalid file extension: sur les fichiers JPG

Bonjour,

Après mise à jour de piwigo, je suis confronté à un problème d'upload de photos avec le formulaire html5. Le formulaire me renvoi l'erreur "Error: Invalid file extension: image.JPG".
Et je constate à l'instant la même erreur avec les formats jpg, jpeg et png.

Je n'ai eu aucun problème avec le formulaire html simple, proposé encore par le plugin 'Upload 1 menu'.

Est-ce un bug côté serveur?

Cordialement.

Version de Piwigo: 2.7.2
Version de PHP: 5.4.34-0+deb7u1
Version de MySQL: 5.5.40-0+wheezy1
URL Piwigo: https://leclercq-shannon.dnset.com/piwigo/

#2 2014-11-22 19:03:27

flop25
Équipe Piwigo
2006-07-06
6477

Re: Error: Invalid file extension: sur les fichiers JPG

Bonjour
réuploader les fichiers via ftp en écrasant ceux existant d'abord

Hors ligne

#3 2014-11-22 21:22:55

Maniack Crudelis
Invité

Re: Error: Invalid file extension: sur les fichiers JPG

Bonjour,

merci de votre réponse, mais je n'ai plus de serveur ftp. Et surtout, les photos en questions ne sont pas encore sur Piwigo.
En l'état, je ne peux envoyer aucune photo via le formulaire html5, recevant systématiquement ce message d'erreur au moment de sélectionner une photo.

Le message se reproduit avec Firefox, Rekonq et Chromium (je n'en ai pas testé d'autres.), rendant impossible l'import de photos via ce formulaire.
Même résultat sous Windows avec Firefox, mais IE n'affichant pas la page correctement, le test est impossible avec ce dernier.

#4 2014-11-22 21:30:02

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3556

Re: Error: Invalid file extension: sur les fichiers JPG

comment ça vous n'avez plus de serveur FTP ?
comme ça ou autrement vous forcement un accès au stockage des fichiers

ce que voulais dire flop25 c'est de remplacer les fichiers de Piwigo, pas vos photos

Hors ligne

#5 2014-11-22 22:12:10

Maniack Crudelis
Invité

Re: Error: Invalid file extension: sur les fichiers JPG

Eh bien j'avais autrefois un serveur vsftpd, mais il est parti en retraite lors de la réinstallation du serveur.

Remplacer les fichiers de piwigo revêt une certaine logique, désolé, j'avais pas compris!

Et en effet, ça a fonctionné, j'ai recopié la version 2.7.2 et le formulaire refonctionne à nouveau.
Merci de votre aide.

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact