•  » Utilisation
  •  » Problème de connexion/cookies avec Internet Explorer 8

#16 2012-09-20 23:15:21

MisterGoupil
Membre
2010-02-05
78

Re: Problème de connexion/cookies avec Internet Explorer 8

Il est hébergé chez Free ;)

Hors ligne

#17 2012-09-21 11:02:12

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Problème de connexion/cookies avec Internet Explorer 8

Je ne m'y connais pas assez pour démêler cette histoire mais comment se fait-il que l'URL ne soit pas du style www.mon-site.free.fr ?


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#18 2012-09-21 14:24:14

MisterGoupil
Membre
2010-02-05
78

Re: Problème de connexion/cookies avec Internet Explorer 8

je fais une redirection sur free depuis mon nom de domaine. Ce qui est très fréquent ;)

Hors ligne

#19 2012-09-21 15:20:20

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Problème de connexion/cookies avec Internet Explorer 8

Cette fois, si je passe directement par Free pour afficher votre site, la connection s'opère correctement avec IE9
Dites-moi de votre coté si vous me confirmez la chose avec votre IE8


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#20 2012-09-21 21:00:31

MisterGoupil
Membre
2010-02-05
78

Re: Problème de connexion/cookies avec Internet Explorer 8

Bien vu ! En passant sans le nom de domaine et directement avec l'adresse Free aucun souci !

Que faut-il en déduire ?

Merci.

Hors ligne

#21 2012-09-21 21:15:05

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Problème de connexion/cookies avec Internet Explorer 8

MisterGoupil a écrit:

Bien vu ! En passant sans le nom de domaine et directement avec l'adresse Free aucun souci !

Que faut-il en déduire ?

Que vous utilisez une redirection par frame pour "lier" votre nom de domaine à votre hébergement chez Free. Cette méthode masque l'URL réelle (http://****.free.fr/piwigo) de votre galerie.
Cette dernière (votre galerie) génère un cookie lié à cette "vrai" URL qui, étant masquée par le frame de redirection, n'aboutit pas. D'où l'erreur affichée par le navigateur.

Firefox gère bien mieux les frames que IE, visiblement. J'ai, moi aussi, longtemps utilisé cette méthode de redirection pour lier mon nom de domaine à mon site chez Free mais je n'avais jamais remarqué de problème car utilisant toujours Firefox. C'est un utilisateur IE qui m'a fait remarquer le problème.

Il y a une astuce pour que les redirections par frame fonctionnent mieux avec IE mais je ne la retrouve plus. Je posterai le truc si cela me revient. ;-)

Hors ligne

#22 2012-09-21 21:26:46

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Problème de connexion/cookies avec Internet Explorer 8

Eric a écrit:

Il y a une astuce pour que les redirections par frame fonctionnent mieux avec IE mais je ne la retrouve plus. Je posterai le truc si cela me revient. ;-)

J'ai retrouvé ceci :
http://support.microsoft.com/kb/299331

Sinon, essayez de modifier le réglage de la confidentialité de IE8 comme sur capture jointe.


Images attachées

Hors ligne

#23 2012-09-22 12:28:18

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Problème de connexion/cookies avec Internet Explorer 8

Merci Eric.

J'avais donc bien cerné le problème ^^


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#24 2014-02-05 23:08:36

jeffvar
Invité

Re: Problème de connexion/cookies avec Internet Explorer 8

Même problème pour moi, j'ai purgé mes sessions depuis php admin, plus moyen de me connecter, "cookies bloqués ou non supporté.....etc" je suis sur safari, j'ai essayé sur firefox sur un autre ordo, mais pas plus de succès. Plus moyen d'accéder en tant qu'admin.....  en plus je me retrouve avec tout un tas de lettres remplacées par des signes bizarres !!!! C'est pas cool, si vous avez une solution, je suis preneur!!! Merci

#25 2014-02-06 00:55:45

flop25
Équipe Piwigo
2006-07-06
6475

Re: Problème de connexion/cookies avec Internet Explorer 8

merci d'ouvrir un autre fil de discussion, en précisant votre environnement, ce qui a changé juste avant, etc merci

Hors ligne

  •  » Utilisation
  •  » Problème de connexion/cookies avec Internet Explorer 8

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact