Annonce

  •  » Utilisation
  •  » afficher les albums avec leurs noms

#1 2013-10-07 22:43:20

22decembre
Membre
2012-06-21
62

afficher les albums avec leurs noms

Bonjour

Je pense que ce sujet est décrit quelque part dans la doc ou dans le forum, mais je ne le trouve pas. Donc je demande ici.

Je voudrais que mes albums soient affichés et accessibles par leur nom, comme des noms de dossiers en fait ! Et si possible que les sous-albums soient bien affichés comme des sous-dossiers.

exemple (pris sur mon site photos.22decembre.eu) :

adresse / France / Paris
                                / Saint Germain

                / Danemark / Aarhus
                                       / Horsens
                                       / Copenhague

                / Hugo

Je pense que ça a quand même plus la classe et c'est plus accessible que l'adresse par défaut qui donne :

http://photos.22decembre.eu/index.php?/category/10

D'ailleurs, si je puis faire une disgression... Pourquoi cette adresse par défaut ? On peut enlever le '?' et d'autres choses, donc ça veut dire que nativement, on pourrait construire des adresses un peu mieux fichues ! (Le '?' m'intrigue beaucoup !)

Hors ligne

#2 2013-10-07 23:15:46

Miklfe
Membre
Sarthe
2010-11-13
364

Re: afficher les albums avec leurs noms

Salut
regarde par

Hors ligne

#3 2013-10-08 07:35:44

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3556

Re: afficher les albums avec leurs noms

Tout ce qui est Après le ? Sont des paramètres du fichier index.php

A part configuration spéciale du serveur il n'est pas possible de l'enlever

Hors ligne

#4 2013-10-08 16:54:32

22decembre
Membre
2012-06-21
62

Re: afficher les albums avec leurs noms

Merci pour ces premières réponses. J'ai déjà supprimé le '?'.

Sinon,j'ai déjà un problème ! :D

Déjà, il semble que LocalFilesEditor n'arrive pas à enregistrer le fichier. Il me déclare un problème de syntaxe. J'ai vérifié, il a la permission d'écrire dans le repertoire ! Mais par contre les fichiers sont au format DOS - alors que je suis sur linux - peut-être une raison ?

Ensuite, en écrivant dans le fichier en console ( !!! ) la commande ci dessous :

$conf['category_url_style'] = 'id-name';

J'obtiens une page blanche (pas '404' ou 'Error' ou autre, non, blanche).

Et enfin, $conf['php_extension_in_urls'] = false; a besoin de l'option multiview d'apache, or je suis sous lighttpd. Est-ce que vous connaissez l'option équivalente ou pas (j'ai cherché, mais j'ai pas trouvé).

Merci !

Hors ligne

  •  » Utilisation
  •  » afficher les albums avec leurs noms

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact