Annonce

  •  » Plugins
  •  » [Résolu] Plugin piwigo-videojs des erreurs PHP

#1 2013-06-12 21:18:59

patfrwar
Membre
Tours
2011-05-24
164

[Résolu] Plugin piwigo-videojs des erreurs PHP

Bonjour à tous
en premier, je félicite l'équipe qui développe sans relâche  se beau produit
je m'étais penché il y a quelques temps sur l'utilisation de piwigo en auto hébergement Windows puis faute de temps j'avais laissé ma galerie en jachère .

et la après avoir promut le produit autour de moi , au vu des résultats j'ai décidé de reprendre ce projet

la mise en place de la 2.51 c'est passé super bien, l'intégration des photos en multiple taille, c'est super
mais la je bute sur quelque chose , c'est les vidéos, car on utilise de plus en plus son appareil photo pour faire des rush
j'ai donc installé le plugin videojs j'ai transformé une vidéo en .mp4 je l'ai placé dans un dossier nommé vidéo dans le dossier galerie
j'ai aussi placé un jpg pour représenter ma vidéo ensuite j'ai synchronisé en 1er avec l'outil piwigo il m'a dit avoir ajouté 2 photos
ensuite j'ai synchronisé avec le plugin videojs et la j'ai des message PHP ensuite l'écran normal du plugin qui me dit avoir trouvé 1 vidéo
ajouté une vidéo
donc on va dire que c'est normal ensuite je consulte ma galerie et si je lance la vidéo idem j'ai 2 message d'erreur php puis l'écran normal piwigo avec le player qui joue la vidéo

voir les 2 copies d'écran

de plus dans l'album ma vidéo est représenté par une icône et non par l'image que j'ai placé dans le même dossier

merci d'avance
cdlt
patrick


Images attachées

Dernière modification par patfrwar (2013-06-12 21:22:26)

Hors ligne

#2 2013-06-12 22:56:25

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14909

Re: [Résolu] Plugin piwigo-videojs des erreurs PHP

Bonjour,

Est ce que tu as pris la version compatible à ton installation ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2013-06-13 05:11:27

xbgmsharp
Invité

Re: [Résolu] Plugin piwigo-videojs des erreurs PHP

Bonjour,

Un autre utilisateur a decrit un probleme identique avec le plugin.
Je n arrive pas a reproduire l erreur et je pense que le probleme viens de la video.

Comment as tu transcoder la video?
Si tu as des videos prise avec iOS il suffit de renomer l extension de .MOV en .mp4 pour que ca marche.
Essaye avec une video de test genre 'Big Buck Bunny' ou 'Elephants Dream' trailer en MP4.
http://www.bigbuckbunny.org/index.php/trailer-page/

Concernant l image, le poster ne doit etre dans le meme dossier.
La documentation explique le layout pour avoir les porsters
A partir de la version 0.8 les posters peuvent etre generer par le plugin.
A partir de a version 0.9 (disponible ce week-end) cela devrais fonctionner aussi sous windows.
La documentation explique comment generer un poster manauellement
https://github.com/xbgmsharp/piwigo-videojs/wiki

#4 2013-06-13 14:50:04

patfrwar
Membre
Tours
2011-05-24
164

Re: [Résolu] Plugin piwigo-videojs des erreurs PHP

Bonjour

Merci pour vos réponses toujours aussi rapides

Donc l'explication est bien dans le format de la video

le format qui sort de mon appareil photo est du MOV (quicktime)
si je le transcode en MP4 alors la bug message d'erreur en copie d'écarn ( j'ai testé plusieurs réglages du transcodeur)
j'ai regardé le PHP en erreur et j'ai vu que ca traitait de l'entête du fichier video
donc, j'ai repris mon transcodeur, mon mov je l'ai transcodé en AVI , et ensuite j'ai transcodé l'AVI en MP4
après intégration dans piwigo plus de message d'érreur.

merci pour votre aide
à bientot

Hors ligne

  •  » Plugins
  •  » [Résolu] Plugin piwigo-videojs des erreurs PHP

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact