•  » Utilisation
  •  » [Résolu] Problème avec des photos de taille 640x480

#1 2012-08-25 11:47:10

Youp3
Membre
2010-06-22
23

[Résolu] Problème avec des photos de taille 640x480

Bonjour,

je viens de mettre sur ma galerie pour la première fois des photos issues d'un smartphone, dont les photos sont en 640x480.

Les photos verticales, en 480x640 ne posent aucun problème.

Par contre avec les photos horizontales, certaines tailles ne s'affichent pas, et à la place j'ai un beau message http://galerie.zamiz.net/galleries/Vaca … .56.18.jpg Image does not exist !!
Les tailles XXS, XS et Petit sont OK.
Les tailles Original (640x480) et celle définie par AutoSize (576x432) affichent le message d'erreur précédent.

Au début je pensais que c'était un problème lié au plugin autosize, mais si je le désactive, le problème reste présent pour la taille originale, même après avoir purgé le cache des photos.

D'où pourrait venir le problème ? De GD ? Voici la version installée chez mon hébergeur :
Bibliothèque graphique: GD bundled (2.0.34 compatible)

Piwigo 2.4.3

Ci-joint une image qui me pose problème


Images attachées

Dernière modification par Youp3 (2012-08-25 11:49:25)

Hors ligne

#2 2012-08-25 14:56:15

flop25
Équipe Piwigo
2006-07-06
6381

Re: [Résolu] Problème avec des photos de taille 640x480

Bonjour
Pouvez vous allez voir par ftp le nom du fichier image si c'est bien : 2012-08-06_20.56.18.jpg ?

Hors ligne

#3 2012-08-25 18:42:21

Youp3
Membre
2010-06-22
23

Re: [Résolu] Problème avec des photos de taille 640x480

Merci de vous intéresser à mon cas.
C'est bien ce nom oui. Pour info, je gère mes photos uniquement par ftp.

De toute façon, si le nom n'était pas bon, comment piwigo arriverait à générer les trois tailles qui fonctionnent ?

Dernière modification par Youp3 (2012-08-25 18:44:43)

Hors ligne

#4 2012-08-25 18:48:12

flop25
Équipe Piwigo
2006-07-06
6381

Re: [Résolu] Problème avec des photos de taille 640x480

Si vous avez un .htaccess à lar acine de piwigo, pouvez vous essayer de le renommer ?
Sinon peut on avoir accès aux photos qui posent problèmes comme celle que vous indiquez 20120806_Normandie/20120806_Bayeux/2012-08-06_20.56.18.jpg

Hors ligne

#5 2012-08-25 18:59:52

Youp3
Membre
2010-06-22
23

Re: [Résolu] Problème avec des photos de taille 640x480

Je viens de donner un accès à l'album. Il s'agit de Vacances / Bayeux.

J'ai aussi renommé le fichier htaccess.

Il s'agit quasiment des dernières photos de l'album, dans un restaurant.

Dernière modification par Youp3 (2012-08-25 19:00:49)

Hors ligne

#6 2012-08-25 19:04:58

flop25
Équipe Piwigo
2006-07-06
6381

Re: [Résolu] Problème avec des photos de taille 640x480

htacess renommé fichier retrouvé ^^ http://galerie.zamiz.net/galleries/Vaca … .56.18.jpg Voilà

Si le plugin Hotlink Compatibility est activé désactivez le, et sinon copiez collez le contenu du htaccess renommé ici merci

Dernière modification par flop25 (2012-08-25 19:05:16)

Hors ligne

#7 2012-08-25 19:12:16

Youp3
Membre
2010-06-22
23

Re: [Résolu] Problème avec des photos de taille 640x480

Effectivement ^^'

Voici le contenu du fichier htaccess que j'avais dû trouver ici sur le forum.

Code:

<IfModule mod_rewrite.c>
RewriteEngine on
## redirect <2.4 thumbnails hotlinks to i.php
RewriteRule ^upload/(.*)/thumbnail/TN-(.*)\.([a-z0-9]{3,4})$ i.php?/upload/$1/$2-th.$3 [L]
RewriteRule ^galleries/(.*)/thumbnail/TN-(.*)\.([a-z0-9]{3,4})$ i.php?/galleries/$1/$2-th.$3 [L]

## redirect <2.4 high-def hotlinks to original file
RewriteRule ^upload/(.*)/pwg_high/(.*)\.([a-z0-9]{3,4})$ upload/$1/$2.$3 [L]
RewriteRule ^galleries/(.*)/pwg_high/(.*)\.([a-z0-9]{3,4})$ galleries/$1/$2.$3 [L]

## redirect <2.4 low-def hotlinks to i.php
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?www\.zamiz\.net/.*$ [NC]
RewriteRule ^upload/(.*)/(.*)\.([a-z0-9]{3,4})$ i.php?/upload/$1/$2-me.$3 [L]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?www\.zamiz\.net/.*$ [NC]
RewriteRule ^galleries(.*)/(.*)\.([a-z0-9]{3,4})$ i.php?/galleries/$1/$2-me.$3 [L]
</IfModule>

Hors ligne

#8 2012-08-25 19:13:52

flop25
Équipe Piwigo
2006-07-06
6381

Re: [Résolu] Problème avec des photos de taille 640x480

Trouvé ?? essayez de télécharger le plugin dont je parlais , et voyez ce que ça fait avec le nouveau htaccess qu'il produira

Hors ligne

#9 2012-08-25 19:14:12

Youp3
Membre
2010-06-22
23

Re: [Résolu] Problème avec des photos de taille 640x480

Ah j'oubliais ! Dans un fichier htaccess à la racine de mon  hébergement, j'ai ceci :

Code:

#interdire le listing des dossiers sans fichier index.php
Options -Indexes

Edit : Ok, je regarde pour le plugin

Dernière modification par Youp3 (2012-08-25 19:14:47)

Hors ligne

#10 2012-08-25 19:18:13

Youp3
Membre
2010-06-22
23

Re: [Résolu] Problème avec des photos de taille 640x480

Voici le nouveau fichier htaccess qui semble ne pas poser problème lui :

Code:

<IfModule mod_rewrite.c>
RewriteEngine on
## redirect <2.4 thumbnails hotlinks to i.php
RewriteRule ^upload/(.*)/thumbnail/TN-(.*)\.(jpg|jpeg|png|gif)$ i.php?/upload/$1/$2-th.$3 [NC,L]
RewriteRule ^galleries/(.*)/thumbnail/TN-(.*)\.(jpg|jpeg|png|gif)$ i.php?/galleries/$1/$2-th.$3 [NC,L]

## redirect <2.4 high-def hotlinks to original file
RewriteRule ^upload/(.*)/pwg_high/(.*)\.(jpg|jpeg|png|gif)$ upload/$1/$2.$3 [NC,L]
RewriteRule ^galleries/(.*)/pwg_high/(.*)\.(jpg|jpeg|png|gif)$ galleries/$1/$2.$3 [NC,L]

## redirect <2.4 low-def hotlinks to i.php
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?galerie\.zamiz\.net/.*$ [NC]
RewriteRule ^upload/(.*)/(.*)\.(jpg|jpeg|png|gif)$ i.php?/upload/$1/$2-me.$3 [NC,L]
RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?galerie\.zamiz\.net/.*$ [NC]
RewriteRule ^galleries(.*)/(.*)\.(jpg|jpeg|png|gif)$ i.php?/galleries/$1/$2-me.$3 [NC,L]
</IfModule>

Hors ligne

#11 2012-08-25 19:20:18

flop25
Équipe Piwigo
2006-07-06
6381

Re: [Résolu] Problème avec des photos de taille 640x480

Ben parfait alors
Bonne soirée

Hors ligne

#12 2012-08-25 19:21:21

Youp3
Membre
2010-06-22
23

Re: [Résolu] Problème avec des photos de taille 640x480

Merci pour votre aide.

Bonne soirée

Hors ligne

  •  » Utilisation
  •  » [Résolu] Problème avec des photos de taille 640x480

Pied de page des forums

Propulsé par FluxBB