Annonce

#1 2011-02-22 12:59:52

Gotcha
Equipe Piwigo, Modérateur
Lieu: Pierrelatte (26)
Date d'inscription: 2007-03-14
Messages: 13265
Site web

[2.2.0.RC2] Installation et CSS

Sur l'écran d'installation, avec IE7 et IE8 je constate le même bug que [Bugtracker, bug 2193, fixed] Display Admin Panel with IE7 + Win XP

Si j'applique la correction que j'ai préparé, il n'y a aucun effet.

Patch
Dans local_head.tpl ajouter les lignes :

Code:

<!--[if IE 7]>
  <link rel="stylesheet" type="text/css" href="{$ROOT_URL}admin/themes/default/fix-ie7.css">
<![endif]-->

Dans (nouveau fichier) \admin\themes\default\fix-ie7.css :

Code:

/* fix IE7 footer */
#the_page { min-height:100%; position:relative; padding:0; margin:0; } 
#menubar { margin: 0; }
#footer { left: 0; }

A savoir qu'il est toujours possible de passer en force en exploitant les hacks CSS des navigateurs mais c'est assez moche...

Comment corriger le problème pour l'étape d'installation ?
Je précise que je vide le répertoire ./local/combined/
Merci.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#2 2011-02-22 18:35:58

cljosse
Équipe Piwigo
Date d'inscription: 2006-11-12
Messages: 1166
Site web

Re: [2.2.0.RC2] Installation et CSS

Gotcha a écrit:

Sur l'écran d'installation, avec IE7 et IE8 je constate le même bug que [Bugtracker, bug 2193, fixed] Display Admin Panel with IE7 + Win XP

Si j'applique la correction que j'ai préparé, il n'y a aucun effet.

Patch
Dans local_head.tpl ajouter les lignes :

Code:

<!--[if IE 7]>
  <link rel="stylesheet" type="text/css" href="{$ROOT_URL}admin/themes/default/fix-ie7.css">
<![endif]-->

Dans (nouveau fichier) \admin\themes\default\fix-ie7.css :

Code:

/* fix IE7 footer */
#the_page { min-height:100%; position:relative; padding:0; margin:0; } 
#menubar { margin: 0; }
#footer { left: 0; }

A savoir qu'il est toujours possible de passer en force en exploitant les hacks CSS des navigateurs mais c'est assez moche...

Comment corriger le problème pour l'étape d'installation ?
Je précise que je vide le répertoire ./local/combined/
Merci.

Chez moi c'est ok.
local_head.tpl :
 

Code:

{if $load_css}
<!--[if lt IE 7]>
  <link rel="stylesheet" type="text/css" href="{$ROOT_URL}admin/themes/default/fix-ie5-ie6.css">
<![endif]-->

<!--[if IE 7]>
  <link rel="stylesheet" type="text/css" href="{$ROOT_URL}admin/themes/default/fix-ie7.css">
<![endif]-->
{/if}

A+

Hors ligne

#3 2011-02-22 18:55:31

Gotcha
Equipe Piwigo, Modérateur
Lieu: Pierrelatte (26)
Date d'inscription: 2007-03-14
Messages: 13265
Site web

Re: [2.2.0.RC2] Installation et CSS

Avec IE7 ?? Même pour l'installation ??

En tous cas j'ai déjà commité ces changements ^_^


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#4 2011-02-22 19:32:57

cljosse
Équipe Piwigo
Date d'inscription: 2006-11-12
Messages: 1166
Site web

Re: [2.2.0.RC2] Installation et CSS

Heuu...
J'ai été un peu trop vite dans mes tests,
je n'étais pas sur le bon projet.

A+

Hors ligne

#5 2011-02-23 08:42:49

cljosse
Équipe Piwigo
Date d'inscription: 2006-11-12
Messages: 1166
Site web

Re: [2.2.0.RC2] Installation et CSS

suite.
  Petite précision la modif était dans le fichier admin/theme/default/local-layout.css.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

À propos de ce site web · Faire un don · Contact projet Piwigo © 2002-2014