•  » Outils
  •  » ploader et openSUSE

#16 2010-11-16 23:17:21

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

plg a écrit:

C'est normal et c'est la façon que Clément a probablement utilisé pour déterminer la liste des modules Debian à installer. En lisant le message d'erreur  "missing library ..." puis en cherchant dans les paquets Debian le module Perl correspondant il a établi la liste des paquets Debian qui permet d'utiliser pLoader sans erreur. C'est un peu pénible, mais une fois cette recherche réalisée, tous les utilisateurs d'openSUSE en profitent.

à priori ce n'est pas ca, la liste que j'ai vu c'était des rpm variés (pas du perl ou pas seulement), et s'il faut chercher une centaine de paquets, ce n'est pas pratiquable.

on verra demain :-)

Hors ligne

#17 2010-11-16 23:22:31

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12345

Re: ploader et openSUSE

Si tu utilises la version source de pLoader, 32bits ou 64bits, cela n'aura pas d'importance, et tu pourras oublier les histoires de liens symboliques d'une version de la library vers une autre (ce qui est complètement impraticable comme solution)


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#18 2010-11-17 00:04:07

Clément
Membre
Lyon
2010-01-11
35

Re: ploader et openSUSE

Bonsoir,

je vais essayer de donner ma démarche pour faire fonctionner pLoader.
On va suivre le tuto déjà cité dans ce fil de discussion.

Tu copies les sources (via svn, c'est le plus rapide et plus pratique), tu te places ensuite dans le dossier adéquate :
svn export http://piwigo.org/svn/extensions/pLoader/tags/1.6/ pLoader
cd ~/pLoader/src/

et tu lances

perl ploader.pl

Les messages d'erreurs devront te donner les fichiers manquants, que tu trouveras en installant les rpm contenant ces fichiers. Généralement ces informations sont contenues dans les informations du paquets (je suppose que c'est aussi vrai pour les rpm), en cherchant sur le web avec le nom du fichier, tu devrait trouver sans problème les dépendances manquantes au fonctionnement de pLoader.

Par exemple le fichier "Heavy.pm", donc une recherche sur le web "Heavy.pm opensuse" devrait rapidement te donner le nom du paquet à installer. Tu réitères l'opération jusqu'à ce que pLoader se lance.

Comme l'a dit plg, c'est un peu long, j'en ai fait l'expérience, mais après, ça rocks ^^.

Hors ligne

#19 2010-11-17 13:09:50

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

Je crains que ce soit désespéré. Je n'arrive pas à installer wxwidget (j'ai une foule de modules, très peu ont leurs dépendances résolues), avec wx.pm récupéré sur le web j'ai une erreur de compilation, mais anonyme (pas de détails utilisable):

perl ploader.pl
Can't locate loadable object for module Wx in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.12.1 /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.1 /usr/lib/perl5/5.12.1/i586-linux-thread-multi /usr/lib/perl5/5.12.1 .) at ploader.pl line 23
Compilation failed in require at ploader.pl line 23.
BEGIN failed--compilation aborted at ploader.pl line 23.
Out of memory!
Erreur de segmentation

Hors ligne

#20 2010-11-17 13:27:45

Clément
Membre
Lyon
2010-01-11
35

Re: ploader et openSUSE

À mon avis, c'est une très mauvaise idée de copier les fichiers un à un depuis le web. Tu ferrais mieux d'installer les paquets correspondants. Pour wx.pm, il semble que ce soit perl-Wx.
Regarde sur ce site, je pense que tu trouveras facilement tous les paquets dont tu as besoin :
http://rpm.pbone.net/
Tu fais une recherche avancée avec comme distribution opensuse et comme mot clé le nom du fichier et tu trouveras toutes les dépendances.

Hors ligne

#21 2010-11-18 17:48:11

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

Clément a écrit:

À mon avis, c'est une très mauvaise idée de copier les fichiers un à un depuis le web. Tu ferrais mieux d'installer les paquets correspondants. Pour wx.pm, il semble que ce soit perl-Wx.
Regarde sur ce site, je pense que tu trouveras facilement tous les paquets dont tu as besoin :
http://rpm.pbone.net/
Tu fais une recherche avancée avec comme distribution opensuse et comme mot clé le nom du fichier et tu trouveras toutes les dépendances.

installer les paquets correspondants, c'est impraticable, ils n'ont pas les mêmes noms sous ubuntu et ailleurs, quand seulement ils existent...

Mais j'ai deux pistes qui avancent. Utiliser la version windows de ploader avec wine, ca marche presque... sauf que ploader ne trouve pas le web. J'a ouvert un rapport de bug chez wine, tout le reste marche.

Mais ma méthode de recopier les librairies marche presque. En plus j'ai trouvé wxWidget en source et j'ai pu le compiler.

Donc, actuellement, ploader (version ubuntu9.10) se lance, se connecte à la galerie, récupère les tags et la liste des catégories, je peux sélectionner des images et le téléchargement commence... puiis j'ai un message "transfert annulé" au moment de l'upload de la miniature. En effet il y a bien une image "resized.jpg" et aussi dans wxthumbnails, mais pas dans thumbnail (dans le réperrtoire de travail de ploader, ~/.pLoader).

messages de log:

Code:

./ploader 
_set_site_resized_file /home/jdd/.pLoader/resize/resized.jpg
Exception 420: NoDecodeDelegateForThisImageFormat `/home/jdd/data/multimedia/photo/originaux/numeriques/2010/20101109/P1000700.JPG' @ constitute.c/ReadImage/530 at Uploader/ImageList.pm line 596.
CreateResized failed . Use ResizeCallback
Exception 420: NoDecodeDelegateForThisImageFormat `/home/jdd/.pLoader/resize/resized.jpg' @ constitute.c/ReadImage/530 at Uploader/ImageList.pm line 665.
Exception 410: NoImagesDefined `Resize' @ Magick.xs/XS_Image__Magick_Mogrify/6524 at Uploader/ImageList.pm line 675.
Exception 410: NoImagesDefined `Strip' @ Magick.xs/XS_Image__Magick_Mogrify/6524 at Uploader/ImageList.pm line 684.
/home/jdd/.pLoader/thumbnails/thumbnail.jpg: Does not exist at Uploader/PWG/WebServices.pm line 535
read_file '/home/jdd/.pLoader/thumbnails/thumbnail.jpg' - sysopen: Aucun fichier ou dossier de ce type at Uploader/PWG/WebServices.pm line 624
Attempt to free unreferenced scalar: SV 0x9cc5024, Perl interpreter: 0x8057008 at Uploader/GUI/Frame.pm line 1693.

Dernière modification par jdd (2010-11-18 17:49:04)

Hors ligne

#22 2010-11-18 17:54:00

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

et je viens de vérifier que ploader peut bien créer une nouvelle catégorie (je la vois sur la galerie), il ne doit pas manquer grand chose...

Hors ligne

#23 2010-11-18 17:57:19

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12345

Re: ploader et openSUSE

(je te conseille de tester shotwell avec le connecteur Piwigo [Forum, topic 19044] de Shotwell vers Piwigo, plugin à beta-tester, dans ton cas ça pourrait être plus simple que d'essayer de faire marcher pLoader sous openSUSE)


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#24 2010-11-18 18:22:26

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

plg a écrit:

(je te conseille de tester shotwell avec le connecteur Piwigo [Forum, topic 19044] de Shotwell vers Piwigo, plugin à beta-tester, dans ton cas ça pourrait être plus simple que d'essayer de faire marcher pLoader sous openSUSE)

il n'a pas l'air de faire plus que le plugin digikam, c'est à dire bien moins que ploader

Je n'ai pas de besoin réel de ploader, j'utilise le ftp. Mais j'essaie de faire marcher ce qui le devrait :-)

Hors ligne

#25 2010-11-19 10:14:15

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

Bon. on avance

j'ai réussi à faire marcher ploader sur une openSUSE 11.3, mais pour l'instant en 32bits seulement (la même manoeuvre en 64bits ne marche pas) - reste à identifier clairement quelle est la config minimale pour ce résultat :-)

Hors ligne

#26 2010-11-19 15:23:16

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

Voilà les instructions pour faire marcher pLoader sur une openSUSE 11.3 *32 bits*. Sur 64 bits, j'ai encore une erreur avec le même fonctionnement.

Pour simplifier, je suis parti d'une installation très basique: l'installation avec xfce (ni kde, ni gnome). Il faut compiler deux applications, et donc installer l'environnement de compilation comme indiqué, puis créer quelques liens. C'est tout, ca prends 1/2h.

Instructions:
Départ, installation openSUSE 11.3 32 bits, xfce.
Dans le menu "autres", installer logiciels, sélectionner le schéma "développement de bureau"

sur:
http://www.imagemagick.org/
télécharger la dernière archive pour Linux et la compiler.
De préférence dans /usr/src/packages/sources.
http://www.imagemagick.org/script/insta … e.php#unix
./configure
make
et comme root
make install

sur www.libtiff.org
télécharger la dernière version de libtiff (tiff-4?)
./configure
make
et comme root
make install

faire un lien
ln -s /usr/local/lib/libtiff.. (dernière version) /usr/lib/libtiff.so.4

Faire un lien
ln /usr/lib/libMagickCore.so.3 /usr/lib/libMagickCore.so.2
ln /usr/lib/libMagickWand.so.3 /usr/lib/libMagickWand.so.2

et ca doit marcher

Dernière modification par jdd (2010-11-19 17:05:06)

Hors ligne

#27 2010-11-19 18:30:16

Clément
Membre
Lyon
2010-01-11
35

Re: ploader et openSUSE

jdd a écrit:

installer les paquets correspondants, c'est impraticable, ils n'ont pas les mêmes noms sous ubuntu et ailleurs, quand seulement ils existent...

Si tu suis la méthode que je t'ai donné, il n'y a pas besoin d'avoir les noms des paquets Ubuntu. De plus, tu évites de t'embêter avec la compilation et les liens symboliques.

Hors ligne

#28 2010-11-19 23:12:47

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

et je sais comment quels paquets chercher si je ne regarde pas les paquets ubuntu? la seule méthode complète que j'au vue demandfait une cinquantaine de paquets, dont la plupart inexistants pour openSUSE.

J'ai à peu près tout essayé.

Pour partir des sources de ploader il me faudrait savoir quel est l'environnement de compilation d'origine, là les messages d'erreur ne donnent aucun détail du tout

Hors ligne

#29 2010-11-20 00:17:36

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12345

Re: ploader et openSUSE

jdd a écrit:

Pour partir des sources de ploader il me faudrait savoir quel est l'environnement de compilation d'origine, là les messages d'erreur ne donnent aucun détail du tout

L'environnement de compilation d'origine c'est Ubuntu, avec les paquets que Clément a listé dans son tutoriel pour lancer pLoader à partir des sources.

Dans la mesure où pLoader est écrit en Perl (langage de programmation interpreté), de toute façon la meilleure façon de l'utiliser est de le lancer à partir des sources (et encore mieux si pLoader pouvait s'installer avec un paquet Debian ou openSUSE). Les grosses versions binaires sont surtout utiles sous Windows/MacOS car elles embarquent Perl et l'environnement graphique et qu'il n'est pas possible de demander aux utilisateurs d'installer un environnement Perl sur un Windows, alors que sous Linux, Perl est toujours installé par défaut ou alors simplissime à installer.


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#30 2010-11-20 00:29:37

jdd
Membre
Toulouse
2009-12-20
374

Re: ploader et openSUSE

plg a écrit:

Si tu utilises la version source de pLoader, 32bits ou 64bits, cela n'aura pas d'importance, et tu pourras oublier les histoires de liens symboliques d'une version de la library vers une autre (ce qui est complètement impraticable comme solution)

c'est pourtant la solution standard, le plus souvent les anciennes libraries ne sont que des liens vers les nouvelles :-) (il suffit de voir le nombre de liens dans /usr/lib)

Hors ligne

  •  » Outils
  •  » ploader et openSUSE

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact