•  » Styles
  •  » [Résolu] Simple, Meta et tag

#1 2010-07-19 14:06:22

rio
Équipe Piwigo
Paris
2006-07-24
1589

[Résolu] Simple, Meta et tag

Bonjour,
J'effectue encore des vérifications sur un Piwigo en local en version 2.1.2, mais les premiers tests semble confirmer un problème entre le template Simple et l'activation ou non des options d'affichage des meta et/ou des tags.
Cela fonctionne correctement avec d'autres templates dont celui de Piwigo par défaut.

Quelqu'un pourrait confirmer?
Merci

(problème remonté sur le forum italien de Piwigo)

:-))


-> /<Ä®¿M <-
http://riohome.free.fr
Il forum è anche in ITALIANO

Hors ligne

#2 2010-07-19 14:24:55

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Simple, Meta et tag

en fait, j'ai également vérifié, lorsqu'on désactive l'option de visualisation des meta donnée, avec le thème "simple-black", la redirection est bien vide (cf Href) mais le lien est toujours présent.

Code:

<div id="randomButtons">
      <ul>
                <li><a href="" title="Mostrare i metadati del file" rel="nofollow">Montrer les méta-données du fichier</a></li>
      </ul>
    </div>

Hors ligne

#3 2010-07-19 14:28:24

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Simple, Meta et tag

datajulien a écrit:

en fait, j'ai également vérifié, lorsqu'on désactive l'option de visualisation des meta donnée, avec le thème "simple-black", la redirection est bien vide (cf Href) mais le lien est toujours présent.

Code:

<div id="randomButtons">
      <ul>
                <li><a href="" title="Mostrare i metadati del file" rel="nofollow">Montrer les méta-données du fichier</a></li>
      </ul>
    </div>

Dans le ficher picture.tpl du thème "simple" on peut modifier la ligne 58 par :

Code:

{if isset($U_METADATA) }
        <li><a href="{$U_METADATA}" title="{'Show file metadata'|@translate}" rel="nofollow">{'Show file metadata'|@translate}</a></li>
    {/if}

Dernière modification par datajulien (2010-07-19 14:30:38)

Hors ligne

#4 2010-07-19 19:23:58

rio
Équipe Piwigo
Paris
2006-07-24
1589

Re: [Résolu] Simple, Meta et tag

Merci datajulien pour la réponse.
Je vais solliciter saimon pour une correction rapide du problème.


-> /<Ä®¿M <-
http://riohome.free.fr
Il forum è anche in ITALIANO

Hors ligne

#5 2010-07-19 22:12:47

saimon
Membre
2006-12-04
367

Re: [Résolu] Simple, Meta et tag

merci, c'est corrigé sur la version de dev !

Hors ligne

#6 2010-07-19 22:23:15

rio
Équipe Piwigo
Paris
2006-07-24
1589

Re: [Résolu] Simple, Meta et tag

:-))


-> /<Ä®¿M <-
http://riohome.free.fr
Il forum è anche in ITALIANO

Hors ligne

#7 2010-07-20 23:58:38

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Simple, Meta et tag

j'ai pas regarder la version de dev, as tu penser a faire de même pour toutes les autres options?

Hors ligne

#8 2010-07-21 00:14:29

saimon
Membre
2006-12-04
367

Re: [Résolu] Simple, Meta et tag

ah non, j'ai juste reporté rapidement la modif que tu indiquais ...
si tu te sens, l'idéal serait un petit patch (fichier de différence) avec les bonnes modifs ;-)

Hors ligne

  •  » Styles
  •  » [Résolu] Simple, Meta et tag

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact