•  » Installation
  •  » [Résolu] Problème après upgrade en 2.1

#31 2010-05-18 19:37:01

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [Résolu] Problème après upgrade en 2.1

mmh... oui.

Pour tous les plugins :
1/ la procédure d'upgrade doit normallement désactiver automatiquement tous les plugins
2/ suite à upgrade en 2.1.0, NE PAS REACTIVER LES PLUGINS (Gotcha, j'écris en majuscules c'est normal ;))
3/ via le gestionnaire de plugins, désinstaller complètement Grum Plugin Classes-2 : pour le passage à piwigo 2.1.0 j'ai réécrit complètement le plugin et celui n'est plus compatible avec la nouvelle version de Piwigo
4/ installer le plugin GrumPluginClasses-3 (qui n'est pas le même que le 2...)
5/ une fois le plugin GrumPluginClasses-3 installé, faire la mise à jour de tous les plugins via le gestionnaire de plugins => le gestionnaire de plugin sait gérer les versions : si une mise à jour n'est pas disponible via le gestionnaire de plugin, on ne tente pas de l'installer manuellement... A noter qu'il n'est normallement pas nécessaire de désinstaller les plugins pour la mise à jour (le statut "désactivé" suffit)
6/ une fois toutes les mises à jour effectués, réactiver les plugins

c'est une procédure un peu lourde que j'ai pas écrit.... je vais essayer de trouver le temps d'ici la 2.2 (çà devrait me laisser du temps) de toucher au gestionnaire de plugin pour gérer les dépendances entre plugins...


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#32 2010-05-18 22:28:50

chrisncy
Membre
Nancy
2008-05-15
315

Re: [Résolu] Problème après upgrade en 2.1

Bonjour
Je viens de suivre les étapes décrites
En effet, en supprimant par ftp le Grum Plugin Classes-2, j'ai réussi à installé le classes3, par l'onglet "autres plugins dispo"

Une fois chargée, c'est là qu'il faut l'installer
Et là j'obtiens ce message

Fatal error: Class 'CommonPlugin' not found in /mnt/138/sda/1/e/christiane.bastien/plugins/GrumPluginClasses/gpc_install.class.inc.php  on line 24

J'ai seulement Localfiles Editor et piwigo AutoUpgrade comme autre plugin actif

Ai je raté quelque chose ?

Avec mes remerciements


https://www.chrisncy.com/PWG/index.php
Piwigo 2.10.1 - PHP: 7.3.11 - MySQL: 5.7.27-log
Bibliothèque graphique: ImageMagick 6.8.9-9

Hors ligne

#33 2010-05-18 22:40:15

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [Résolu] Problème après upgrade en 2.1

chrisncy a écrit:

Ai je raté quelque chose ?

non.
méga boulette de ma part :-)

je viens de mettre en ligne la version 3.1.1 qui devrait résoudre le soucis ^^;


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#34 2010-05-19 07:28:34

chrisncy
Membre
Nancy
2008-05-15
315

Re: [Résolu] Problème après upgrade en 2.1

Comme d'hab', c'est génial ce forum...
Merci, ça fonctionne

Par contre, deuxième question qui s'est crée à la suite
J'ai voulu installer AMetaData
En installation automatique, cela n'a pas été possible. J'ai eu un message d'erreur genre : impossible de traiter l'archive
Qu'à cela ne tienne. J'ai téléchargé l'archive, et j'ai transféré son contenu en ftp
Je l'ai alors installé depuis piwigo. OK
mais quand j'ai voulu l'activer, paf ! message suivant :

Fatal error: Class 'DateTime' not found in /mnt/138/sda/1/e/christiane.bastien/plugins/AMetaData/JpegMetaData/Common/ConvertData.class.php on line 296

Encore un petit coup de main ?
Merci d'avance


https://www.chrisncy.com/PWG/index.php
Piwigo 2.10.1 - PHP: 7.3.11 - MySQL: 5.7.27-log
Bibliothèque graphique: ImageMagick 6.8.9-9

Hors ligne

#35 2010-05-19 07:42:58

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème après upgrade en 2.1

Grum_plugins_classes-3 est installé ?


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#36 2010-05-19 07:49:50

chrisncy
Membre
Nancy
2008-05-15
315

Re: [Résolu] Problème après upgrade en 2.1

eh oui, c'était l'objet du message précédent où grum avait répondu que c'était une boulette de sa part...


https://www.chrisncy.com/PWG/index.php
Piwigo 2.10.1 - PHP: 7.3.11 - MySQL: 5.7.27-log
Bibliothèque graphique: ImageMagick 6.8.9-9

Hors ligne

#37 2010-05-19 09:33:42

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème après upgrade en 2.1

Activé?


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#38 2010-05-19 12:18:25

oualid
Membre
2009-09-07
59

Re: [Résolu] Problème après upgrade en 2.1

Tous mes soucis sont réglés après les dernières mises à jour de certains plugins : Grum, additionnal pages, PWG, ...

Reste que FCK editor qui pose problème : les zones de saisie disparaissent après activation du plugin.


Merci pour le support.

Hors ligne

#39 2010-05-19 19:42:05

chrisncy
Membre
Nancy
2008-05-15
315

Re: [Résolu] Problème après upgrade en 2.1

VDigital a écrit:

Activé?

oui, activé effectivement. J'avais oublié de préciser.


https://www.chrisncy.com/PWG/index.php
Piwigo 2.10.1 - PHP: 7.3.11 - MySQL: 5.7.27-log
Bibliothèque graphique: ImageMagick 6.8.9-9

Hors ligne

#40 2010-05-19 20:45:29

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [Résolu] Problème après upgrade en 2.1

chrisncy a écrit:

Fatal error: Class 'DateTime' not found in /mnt/138/sda/1/e/christiane.bastien/plugins/AMetaData/JpegMetaData/Common/ConvertData.class.php on line 296

ta version de PHP qui n'est pas adaptée... ?
cf. [Forum, post 137307 by grum in topic 17324] [plugin] Grum Advanced Metadata (beta) => la version minimum de PHP requise est la 5.2

PS: merci d'ouvrir un nouveau topic pour chaque nouveau problème ;-)


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#41 2010-05-20 00:16:38

chrisncy
Membre
Nancy
2008-05-15
315

Re: [Résolu] Problème après upgrade en 2.1

Arf, je suis chez free pour le site de test, et je ne sais pas la version de php.
Je vais donc voir cela avec mon site principal
Merci bien

Pour le nouveau topic, mes plus plates excuses, vu que je continuais le sujet en cours, je ne pensais pas devoir en faire un nouveau


https://www.chrisncy.com/PWG/index.php
Piwigo 2.10.1 - PHP: 7.3.11 - MySQL: 5.7.27-log
Bibliothèque graphique: ImageMagick 6.8.9-9

Hors ligne

#42 2010-05-20 08:29:32

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13325

Re: [Résolu] Problème après upgrade en 2.1

chrisncy a écrit:

Arf, je suis chez free pour le site de test, et je ne sais pas la version de php.
Je vais donc voir cela avec mon site principal
Merci bien

Pour le nouveau topic, mes plus plates excuses, vu que je continuais le sujet en cours, je ne pensais pas devoir en faire un nouveau

Un sujet [Résolu] ne sert justement qu'à la lecture. Par exemple pour trouver de l'aide. Le préfixe [Résolu] est utile afin de concentrer les effort de l'équipe sur des sujets qui n'ont pas trouvés de réponses (donc pas résolus).

Par exemple, ce sujet est [Résolu] depuis un moment, je ne le regardais pas, mais comme il remonte, j'ai du faire l'effort de lire.

Bref, il ne faut pas hésiter à créer son propre sujet bien à soit ;-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#43 2010-05-20 19:51:43

chrisncy
Membre
Nancy
2008-05-15
315

Re: [Résolu] Problème après upgrade en 2.1

OK, bien compris, désormais...


https://www.chrisncy.com/PWG/index.php
Piwigo 2.10.1 - PHP: 7.3.11 - MySQL: 5.7.27-log
Bibliothèque graphique: ImageMagick 6.8.9-9

Hors ligne

#44 2010-05-22 23:16:32

tosca
Former Piwigo Team
Cévennes (Gard)
2006-09-23
3818

Re: [Résolu] Problème après upgrade en 2.1

grum a écrit:

mmh... oui.

Pour tous les plugins :
1/ la procédure d'upgrade doit normallement désactiver automatiquement tous les plugins
2/ suite à upgrade en 2.1.0, NE PAS REACTIVER LES PLUGINS (Gotcha, j'écris en majuscules c'est normal ;))
3/ via le gestionnaire de plugins, désinstaller complètement Grum Plugin Classes-2 : pour le passage à piwigo 2.1.0 j'ai réécrit complètement le plugin et celui n'est plus compatible avec la nouvelle version de Piwigo
4/ installer le plugin GrumPluginClasses-3 (qui n'est pas le même que le 2...)
5/ une fois le plugin GrumPluginClasses-3 installé, faire la mise à jour de tous les plugins via le gestionnaire de plugins => le gestionnaire de plugin sait gérer les versions : si une mise à jour n'est pas disponible via le gestionnaire de plugin, on ne tente pas de l'installer manuellement... A noter qu'il n'est normallement pas nécessaire de désinstaller les plugins pour la mise à jour (le statut "désactivé" suffit)
6/ une fois toutes les mises à jour effectués, réactiver les plugins

c'est une procédure un peu lourde que j'ai pas écrit.... je vais essayer de trouver le temps d'ici la 2.2 (çà devrait me laisser du temps) de toucher au gestionnaire de plugin pour gérer les dépendances entre plugins...

Suite à ma question [Forum, topic 17789] Procédure de mise à jour de plugins, pourrais-tu mettre une mention dans PEM (avec un lien sur le forum le  cas échéant) de manière à ce que l'on puisse trouver l'info facilement.

Dernière modification par tosca (2010-05-22 23:17:13)

Hors ligne

#45 2010-05-25 20:50:27

webinter
Membre
France
2009-03-27
18

Re: [Résolu] Problème après upgrade en 2.1

VDigital a écrit:

oualid a écrit:

Fatal error: Class 'CommonPlugin' not found in /home/xxxx/www/xxx/plugins/grum_plugins_classes-2/gpc_aim.class.inc.php  on line 21

/plugins/grum_plugins_classes-2

Grum est informé.

Supprime ./plugins/grum_plugins_classes-2/ par ftp

Installe et active le nouveau plugin "Grum plugins classes-3".

il se trouve que j'ai piwigo version 2.1.1,
Grum Plugin Classes 3.1.1  et je ne peut pas l'activer
j'obtient une page d'erreur avec plein de warning du style
Warning: include_once() [function.include-once]: Unable to access ./plugins/GrumPluginClasses/classes/CommonPlugin.class.inc.php in /mnt/101/sda/4/8/photosthemes/plugins/grum_plugins_classes-2/gpc_install.class.inc.php on line 20

et certains autres plugins réclame la version 3.0.0 (bizarre que tout ceci).
bon le prob est résolue en désinstallant et réinstaller le plugin.

Dernière modification par webinter (2010-05-25 21:11:52)

Hors ligne

  •  » Installation
  •  » [Résolu] Problème après upgrade en 2.1

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact