•  » Utilisation
  •  » [Résolu] Problème de tri par défaut

#1 2009-08-30 22:01:57

Monsieur Dusnob
Membre
2005-06-06
9

[Résolu] Problème de tri par défaut

Bonjour

dans mes catégories, mes images ne sont pas triées correctement. Comme tri par défaut, j'ai écrit dans le LocalFiles Editor :

Code:

$conf['order_by'] = ' ORDER BY file ASC, date_available ASC, id ASC';

ce qui devrait donner un tri primaire sur le nom de fichier (alphabétique), ce que je souhaite. Pourtant, à l'affichage d'une catégorie pour laquelle le tri par défaut est sélectionné, l'image DSC04741.JPG apparaît avant DSC04583.JPG (mais ce n'est pas non plus un tri inversé).

Si, pour cette catégorie, je sélectionne explicitement un tri par nom (que ce soit au moment de l'affichage des miniatures de la catégorie ou en éditant les informations de la catégorie), alors les images apparaissent dans le bon ordre... Le problème est que je n'ai pas envie de faire ça pour chacune de mes catégories et que j'aimerais tout simplement que le comportement soit celui documenté...

En fait, il semble qu'avec le tri par défaut mes images soient classées alphabétiquement dans chaque « vague » de synchronisation, mais que ces vagues de synchronisation soient elles-mêmes classées par ordre chronologique inverse (j'espère être clair).

Quelqu'un aurait-il une idée pour m'aider ? Mes autres paramètres du fichier de config semblent correctement pris en compte.

Je précise que je suis chez Free avec Piwigo 2.0.3 (après multiples migrations depuis d'anciennes versions, je ne sais pas depuis quand ce problème se manifeste)...

Merci pour vos idées...

Hors ligne

#2 2009-08-30 23:06:45

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème de tri par défaut

Problème résolu (recherche sur le forum)


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#3 2009-08-30 23:28:32

Monsieur Dusnob
Membre
2005-06-06
9

Re: [Résolu] Problème de tri par défaut

J'ai trouvé (pas évident car une recherche à propos du tri des images renvoie une tripotée de sujets...

Je résume pour ceux qui passeraient par ici et seraient confrontés au problème : dans le fichier juste après la clause $conf['order_by']... il faut ajouter la ligne

Code:

$conf['order_by_inside_category'] = $conf['order_by'];

et tout marche bien après.

Merci VDigital.

Hors ligne

#4 2009-08-31 20:01:23

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] Problème de tri par défaut

C'était pourtant marqué dans le wiki ^^


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#5 2009-08-31 22:05:06

Monsieur Dusnob
Membre
2005-06-06
9

Re: [Résolu] Problème de tri par défaut

Exact, j'avais zappé cet item, tout comme la la référence dans le fichier de config par défaut. Pour ce qui est du wiki, j'ai en fait regardé le sommaire et constaté que la page intitulée « Trier les photos » n'existait pas et je n'ai pas cherché plus loin...

Désolé du dérangement...

Hors ligne

#6 2009-08-31 22:19:20

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème de tri par défaut

Pas de dérangement... Cela arrive à tout le monde.

Je sais que personne ne la voit mais une fonction de recherche existe également dans le Wiki...
;-)


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

  •  » Utilisation
  •  » [Résolu] Problème de tri par défaut

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact