#1 2006-02-13 18:10:49

Reflex
Membre
2005-10-16
290

[Photos par auteurs] Ca marche encore ?

Voilà, j'ai un peu modifié ma gallerie mais avant je n'avais pas vérifié si cette fonction fonctionnait encore.
Là je viens d'essayer hors, si chaque nom d'auteur est bien cliquable, le lien m'amène sur une galerie vide de photos.
Est-ce que des manips dans picture.php ont pu provoquer ce dysfonctionnement ?

Hors ligne

#2 2006-02-14 18:09:16

Reflex
Membre
2005-10-16
290

Re: [Photos par auteurs] Ca marche encore ?

Alors, ça marche chez vous ?

Hors ligne

#3 2006-02-14 18:40:23

rvelices
Équipe Piwigo
2005-12-29
1417

Re: [Photos par auteurs] Ca marche encore ?

Peux-tu donner un lien ?

Hors ligne

#4 2006-02-14 19:13:48

Reflex
Membre
2005-10-16
290

Re: [Photos par auteurs] Ca marche encore ?

http://www.cichlids-reflex.info/categor … 20BOCHENKO

Si je clique sur le nom de l'auteur, je n'accède pas à l'ensemble de ses photos, comme c'était le cas avant, mais à une galerie vide...

Dernière modification par Reflex (2006-02-28 14:41:58)

Hors ligne

#5 2006-02-14 19:39:45

rvelices
Équipe Piwigo
2005-12-29
1417

Re: [Photos par auteurs] Ca marche encore ?

C'est a cause du "é" dans le prenom. Sans l'accent ca marche.

Je ne sais pas exactement pourquoi ca ne marche pas, mais c'est un probleme qui a ete discute N fois et a ma connaissance c'est sans solution jusqua maintenant (encodage du navigateur, collation dans mysql, php, etc...)

Hors ligne

#6 2006-02-14 19:57:20

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12277

Re: [Photos par auteurs] Ca marche encore ?

Cela va changer en branche 1.6, les auteurs seront identifiés numériquement, éliminant ce genre de problème.

Hors ligne

#7 2006-02-16 09:07:52

Reflex
Membre
2005-10-16
290

Re: [Photos par auteurs] Ca marche encore ?

Alors là je suis + qu'étonné car sur la 1.4.1, celà fonctionnait avec un auteur qui s'appelait Benoît, et le même Sébastien (moi-même)...
Cela dit je viens effectivement de faire le test avec un autre auteur dont le nom ne porte pas d'accent et c'est vrai que ça marche.

Hors ligne

#8 2006-02-16 09:09:43

Reflex
Membre
2005-10-16
290

Re: [Photos par auteurs] Ca marche encore ?

z0rglub a écrit:

Cela va changer en branche 1.6, les auteurs seront identifiés numériquement, éliminant ce genre de problème.

Cela veut-il dire que ça permettra de remplir le champs "Auteur" avec un clic souris qui suggèrera les auteurs déjà existants ?

Hors ligne

#9 2006-02-16 10:12:00

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12277

Re: [Photos par auteurs] Ca marche encore ?

Reflex a écrit:

Cela veut-il dire que ça permettra de remplir le champs "Auteur" avec un clic souris qui suggèrera les auteurs déjà existants ?

oui

Hors ligne

#10 2006-05-30 11:25:35

Reflex
Membre
2005-10-16
290

Re: [Photos par auteurs] Ca marche encore ?

z0rglub a écrit:

Reflex a écrit:

Cela veut-il dire que ça permettra de remplir le champs "Auteur" avec un clic souris qui suggèrera les auteurs déjà existants ?

oui

Salut, je vois que sur la 1.6.0RC2, ce n'est pas encore le cas, les noms d'auteurs n'étant carrément plus du tout cliquables dans le picture.php...
Est-ce abandonné pour la 1.6 finale ?  :/

Hors ligne

#11 2006-05-30 14:48:01

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12277

Re: [Photos par auteurs] Ca marche encore ?

Oui, c'est mis de côté jusqu'à la 1.7 maintenant. Désolé, pas eu le temps... Je proposerai une solution dégradée pour la 1.6.1 peut-être.

Hors ligne

#12 2006-05-30 18:29:38

Reflex
Membre
2005-10-16
290

Re: [Photos par auteurs] Ca marche encore ?

Ok vivement la 1.7 alors !
Juste pour préciser que quand je met en nom d'auteur "Sébastien" au lieu de "Sébastien", soit la lettre accentuée en code html, ça fonctionne parfaitement. Je suppose que vous le saviez déjà, mais des fois que ça aide... :D

Hors ligne

#13 2006-05-30 18:43:27

Reflex
Membre
2005-10-16
290

Re: [Photos par auteurs] Ca marche encore ?

Ma dernière remarque concerne la 1.5.2.

Hors ligne

#14 2006-05-30 23:03:34

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12277

Re: [Photos par auteurs] Ca marche encore ?

Reflex a écrit:

Juste pour préciser que quand je met en nom d'auteur "Sébastien" au lieu de "Sébastien", soit la lettre accentuée en code html, ça fonctionne parfaitement. Je suppose que vous le saviez déjà, mais des fois que ça aide... :D

Oui, mais c'est une mauvaise solution ;-). La bonne solution, c'est de gérer proprement les auteurs avec des identifiants numériques et d'anéantir les traces d'entités HTML.

Hors ligne

#15 2006-05-31 14:49:39

Reflex
Membre
2005-10-16
290

Re: [Photos par auteurs] Ca marche encore ?

z0rglub a écrit:

Reflex a écrit:

Juste pour préciser que quand je met en nom d'auteur "Sébastien" au lieu de "Sébastien", soit la lettre accentuée en code html, ça fonctionne parfaitement. Je suppose que vous le saviez déjà, mais des fois que ça aide... :D

Oui, mais c'est une mauvaise solution ;-).

C'est bien pour ça que j'avais hâte que ce soit règlé !  ;)

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact