•  » Installation
  •  » 2.9.10 avec netinstall ou en mode classique

#1 2019-10-09 09:52:12

Katryne
Membre
Provence
2016-12-03
514

2.9.10 avec netinstall ou en mode classique

Bonjour

J'ai essayé d'installer Piwigo 2.9.10 avec netinstall et je rencontre un souci :

Warning: mysqli::__construct(): (HY000/1045): Access denied for user 'gabandjo'@'localhost' (using password: YES) in /var/www/legtux.org/users/gabandjo/www/piwigo/piwigo/include/dblayer/functions_mysqli.inc.php on line 52
Warning: mysqli::set_charset(): Couldn't fetch mysqli in /var/www/legtux.org/users/gabandjo/www/piwigo/piwigo/include/dblayer/functions_mysqli.inc.php on line 88

Que dois-je faire ? Merci.

https://gabandjo.legtux.org/piwigo/

Dernière modification par Katryne (2019-10-09 11:28:30)


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#2 2019-10-09 11:26:28

Katryne
Membre
Provence
2016-12-03
514

Re: 2.9.10 avec netinstall ou en mode classique

Je détruis mon piwigo dont les fichiers se sont correctement installés.
Je détruis les tables Piwigo qui existaient d'une ancienne installation.

J'essaie une installation classique avec upload du zip dézippé.
Je lance l'install , je complète le formulaire avec les infos, et j'obtiens une "Connexion au serveur impossible" avec ce message d'erreur :

Warning: mysqli::__construct(): (HY000/1045): Access denied for user 'gabandjo'@'localhost' (using password: YES) in /var/www/legtux.org/users/gabandjo/www/piwigo/include/dblayer/functions_mysqli.inc.php on line 52
Warning: mysqli::set_charset(): Couldn't fetch mysqli in /var/www/legtux.org/users/gabandjo/www/piwigo/include/dblayer/functions_mysqli.inc.php on line 88

Après une demi -ouzaine d'essais, j'ai enfin réussi à installer la 2.9.10 chez Legtux, mais pas directement : J'ai installé une 2.9.5 et je l'ai mise à jour en 2.9.10.

L'installation y est impossible en 2.9.10.

Mes informations de connexion sont correctes, puisque j'ai installé en 2.9.5.
Quel est donc le problème ?

Dernière modification par Katryne (2019-10-09 11:27:39)


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#3 2019-10-09 13:23:43

Katryne
Membre
Provence
2016-12-03
514

Re: 2.9.10 avec netinstall ou en mode classique

Je n'arrive pas à activer Bootstrap Darkroom dans Piwigo 2.10. Je pense qu'il a besoin de Bootstrap default qui n'est pas dispo pour 2.10.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#4 2019-10-09 13:28:02

dreamer
Membre
St Cyr/mer (83)
2006-02-26
626

Re: 2.9.10 avec netinstall ou en mode classique

Katryne a écrit:

Je n'arrive pas à activer Bootstrap Darkroom dans Piwigo 2.10. Je pense qu'il a besoin de Bootstrap default qui n'est pas dispo pour 2.10.

A-tu essayé d'installer bootstrap darkroomen 2.9.5 et ensuite de faire la mise à jour ??


beauxvoyages.fr/photos (photos), beauxvoyages.fr/jukebox (musiques) et tout nouveau beauxvoyages.fr/galerie (camping-car) le tout en version 2.10

Hors ligne

#5 2019-10-09 13:35:41

Katryne
Membre
Provence
2016-12-03
514

Re: 2.9.10 avec netinstall ou en mode classique

Hello !
J'ai installé Bootstrap Default depuis une vieille sauvegarde et ça commence à marcher ! Sauf erreur, je crois qu'il faut les deux,  Darkroom semblant être un thème enfant de Default.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#6 2019-10-10 15:40:50

Katryne
Membre
Provence
2016-12-03
514

Re: 2.9.10 avec netinstall ou en mode classique

Hello Hello !
Quelqu'un a-t-il déjà le même signalement que moi : je n'ai pas pu faire une installation complète nouvelle de Piwigo 2.10. Il a fallu que je fasse une install de 2.9.5 et que je lance l'upgrade pour obtenir une 2.10.

Je crois que tous les retours d'expérience sur ce forum et sur l'anglais concernent des mises à jour, personne ne cause d'installation nouvelle.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#7 2019-10-11 10:59:21

k5
Équipe Piwigo
lieu
2014-01-26
465

Re: 2.9.10 avec netinstall ou en mode classique

Bonjour,
Comment avez vous fait la mise à jour ?
Cordialement
K5


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#8 2019-10-11 12:13:23

Katryne
Membre
Provence
2016-12-03
514

Re: 2.9.10 avec netinstall ou en mode classique

K5, une mise à jour via le lien de l'admin se passe très très bien.
Ce que je n'ai pas pu faire, c'est une installation nouvelle complète indépendante de Piwigo 2.10.
Pour installer un nouveau Piwigo sur un nouvel hébergement, j'ai dû :
1/ installer un Piwigo tout neuf tout complet en v 2.9.5
2/ Mettre à jour ce Piwigo 2.9.5 par le lien présent dans l'admin.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#9 2019-10-11 14:02:45

k5
Équipe Piwigo
lieu
2014-01-26
465

Re: 2.9.10 avec netinstall ou en mode classique

Mes premières impressions ou mon avis, c'est quand il y a une nouvelle version majeure de piwigo et quand le thème par défaut change. Peut-être que je me trompe.
Là j'ai testé une nouvelle installation neuve chez free et tout fonctionne bien. Je testerai les hébergeurs après :)
Cordialement
K5


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#10 2020-01-19 13:23:34

Katryne
Membre
Provence
2016-12-03
514

Re: 2.9.10 avec netinstall ou en mode classique

Bonjour !
Je rencontre exactement la même erreur que dans mon post initial du 9 octobre. J'essaye de déménager un Piwigo d'un hébergement mutualisé à un autre, tous les deux dans mon compte 1&1-Ionos. J'utilise pour le moment pour url le domaine-système, car je ne transposerai le domaine d'un hébergement à l'autre que quand les 5 sites du domaine seront fonctionnels. Piwigo est le n°2 et il fait des caprices. Qu'est-ce que j'ai loupé ?

Une fois la sauvegarde du site mise en connexion avec l'import de la BDD, j'ai pu faire la mise à jour de 2.9.5 vers 2.10.1, puis j'ai mis à jour les plugins et les ai activés. Cela a un peu marché, puis, une modif en local et cette belle erreur :

Warning: mysqli::__construct(): (HY000/2002): No such file or directory in /homepages/1/xxx/htdocs/piwigo/include/dblayer/functions_mysqli.inc.php on line 52
Warning: my_error(): Couldn't fetch mysqli in /homepages/1/xxx/htdocs/piwigo/include/dblayer/functions_mysqli.inc.php on line 848
Warning: my_error(): Couldn't fetch mysqli in /homepages/1/xxx/htdocs/piwigo/include/dblayer/functions_mysqli.inc.php on line 848
Piwigo encountered a non recoverable error
[mysql error ]
Can't connect to server
#1 my_error /homepages/1/xxx/htdocs/piwigo/include/common.inc.php(113)
#2 include_once /homepages/1/xxx/htdocs/piwigo/index.php(11)

J'ai remis la version de sauvegarde du dossier /local, puis j'ai essayé de passer de php 7.4 à 7.3.

Rien ne marche.

Merci de votre aide.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#11 2020-01-19 16:12:03

Katryne
Membre
Provence
2016-12-03
514

Re: 2.9.10 avec netinstall ou en mode classique

Comme je n'arrivais à rien et que je ne comprends pas, j'ai relancé l'install en remettant un dossier /local du pack en téléchargement. C'est un peu long pour boucler la config que je dois refaire de A à Z, mais il semble que j'ai retrouvé toutes mes billes.
Mais j'aimerais bien comprendre ce que j'ai fait que j'aurais pas dû. Ça peut venir que de moi, n'est-ce pas ?

Dernière modification par Katryne (2020-01-19 16:12:22)


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

  •  » Installation
  •  » 2.9.10 avec netinstall ou en mode classique

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact