Annonce

  •  » Installation
  •  » Les cookies en 2.9.4 : c'était mieux avant

#1 2018-07-15 08:55:52

Katryne
Membre
Provence
2016-12-03
537

Les cookies en 2.9.4 : c'était mieux avant

Bonjour

C'est quoi ce message depuis le passage en 2.9.4 ?

Les cookies sont bloqués ou non supportés par votre navigateur web. Vous devez activer les cookies pour vous connecter.

Je me retrouve à la porte de mon site, sans possibilité de me connecter.  Sauf à modifier ma politique de cookies pour ce site. Qui est le mien. C'est drôle, non ? Alors qu'auparavant, avec la même configuration de cookies, le même navigateur dans la même version, je me connectais direct.

Je ne veux pas imposer à mes visiteurs de poser des cookies sur leur ordinateur, alors que moi je le refuse habituellement. Je trouve que c'est une régression par rapport à la version 2.9.3 et une mauvaise application du RGPD : sous prétexte d'information sur la pose des cookies, je place mes visiteurs en otage, je leur fais du chantage : ou t'acceptes ou tu dégages.

Comment puis-je rectifier mon site pour que ce message ne s'affiche pas ? Dois-je le repasser en 2.9.3 ?

Merci

Edit : sur http://photos.katrynou.fr:, j'ai 3 cookies posés : cool_cookie, (sur katrynou.fr, en fait), pwg_id et pwg_remember

Dernière modification par Katryne (2018-07-15 09:07:48)


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.10.2 -  Système d'exploitation: Linux - Hébergeur 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#2 2018-07-15 11:02:30

Katryne
Membre
Provence
2016-12-03
537

Re: Les cookies en 2.9.4 : c'était mieux avant

Une heure après avoir "examiné" les cookies, sans intervention autre, en arrivant sur le site j'étais connectée automatiquement. Que s'est-il passé ?

PS : j'ai reçu une notification de réponse, mais elle ne s'affiche pas ici, peut-être à cause d'une copie d'écran qui était jointe. En réponse à Guillaume, j'ai essayé de corriger l'affichage de menu, maintenant que j'ai pu entrer en admin. Merci du signalement.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.10.2 -  Système d'exploitation: Linux - Hébergeur 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#3 2018-07-15 18:28:44

Guillaume C
Membre
Belgium
2014-04-08
191

Re: Les cookies en 2.9.4 : c'était mieux avant

Oui, j’ai supprimé le message parce que je ne réussissais pas à insérer la pièce jointe et c’était également hors sujet. Je me suis dit que tu aurais de toute façon le message via le mail de notification.

Content que tes 2 problèmes soient résolus 😉

Hors ligne

#4 2018-07-16 19:13:05

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12364

Re: Les cookies en 2.9.4 : c'était mieux avant

Katryne a écrit:

Je ne veux pas imposer à mes visiteurs de poser des cookies sur leur ordinateur, alors que moi je le refuse habituellement. Je trouve que c'est une régression par rapport à la version 2.9.3 et une mauvaise application du RGPD [...]

Les cookies posés par Piwigo sont conformes au RGPD. Il s'agit de cookie d'identification technique, en gros pour que l'application web côté serveur puisse faire le lien entre le visiteur et la "session" stockées côté serveur.

Le RGPD vise à éviter les "cookiers tiers" sans obtenir le consentement des visiteurs. Par "cookies tiers" on entend les données qui partent vers des services externes et il ne s'agit pas que des cookies. C'est une simplification de langage. Par exemple, charger un javascript sur, au hasard, Google Analytics, pour faire du suivi des visites, sans obtenir le consentement des visiteurs, ça c'est problématique par rapport au RGPD. Ce n'est absolument pas ce que fait Piwigo, qui au contraire respecte, et ce bien avant beaucoup de monde, l'esprit du RGPD.


Dernier billet du blog Piwigo.com (18 mars 2020) Covid19 : allongement de la période d’essai pour les entreprises

Hors ligne

#5 2018-07-16 19:38:51

Katryne
Membre
Provence
2016-12-03
537

Re: Les cookies en 2.9.4 : c'était mieux avant

Mes excuses, Pierrick. J'ai été surprise après l'install de la 2.9.4 par l'affichage d'un message que je n'avais jamais vu. La nouvelle version m'a déconnectée, alors qu'auparavant, dès que j'arrivais sur le site, j'étais toujours connectée automatiquement (selon mon choix et la pose du cookie que mon choix implique). Et pendant plus d'une heure, sur plusieurs navigateurs, je n'ai pas pu me reconnecter, ce message s'affichant en permanence. J'ai pourtant vérifié la présence des cookies sur les navigateurs, mais rien à faire.

Je ne sais toujours pas ce qui s'est passé.

Tout fonctionne parfaitement maintenant. Et merci pour la mise à jour.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.10.2 -  Système d'exploitation: Linux - Hébergeur 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#6 2019-01-03 01:42:39

flop25
Équipe Piwigo
2006-07-06
6477

Re: Les cookies en 2.9.4 : c'était mieux avant

ha c'est "marrant" j'ia le même soucis

Hors ligne

#7 2019-01-03 01:44:49

flop25
Équipe Piwigo
2006-07-06
6477

Re: Les cookies en 2.9.4 : c'était mieux avant

j'étais redirigé vers "//gallerie/identification.php" mais impossible de reproduire et donc de savoir comment j'ai atterri là

Hors ligne

#8 2019-01-04 10:23:40

nicolas
Former Piwigo Team
2004-12-30
1535

Re: Les cookies en 2.9.4 : c'était mieux avant

Je rencontre le même problème et c'est difficile à reproduire. Je ne suis qu'au début des investigations mais j'ai constaté que le problème n'est pas systématique et dépend du nom de domaine (localhost, 127.0.0.1, alias, ou vrai nom de domaine). Je n'ai pas encore bien compris ce qui posait problème. Cela ne semble pas lié directement à Piwigo ni forcément php. Enfin je n'ai pas l'impression.


Donnez du peps à vos tags
Laissez vos visiteurs vous aidez à tagger vos images avec user_tags

Hors ligne

#9 2019-01-12 16:42:43

nicolas
Former Piwigo Team
2004-12-30
1535

Re: Les cookies en 2.9.4 : c'était mieux avant

Par hasard ceux qui ont le problème utilisent-ils nginx au lieu d'apache comme serveur http ?

Le message apparaît lorsqu'on essaie de se connecter (sur la page d'identification) après avoir soumis le formulaire et que le cookie de session n'est pas trouvé (peu importe qu'une session anonyme soit créée cela n'a pas d'incidence). La fonction cookie_path qui essaie de déterminer le chemin correct du cookie (de session dans le cas qui nous intéresse) ne renvoie pas toujours une valeur correcte et du coup le cookie n'est pas créé.

Avec apache aucun soucis, qu'on fasse des réécritures d'url ou pas.
Mais avec nginx, les variables $_SERVER['REDIRECT_SCRIPT_NAME'] et $_SERVER['REDIRECT_URL'] n'existe pas et du coup la fonction essaie d'exploiter la variable $_SERVER['SCRIPT_NAME'] mais celle-ci ne contient pas un URI mais un chemin physique de fichier et forcément cela n'aboutit pas à un résultat correct.


Donnez du peps à vos tags
Laissez vos visiteurs vous aidez à tagger vos images avec user_tags

Hors ligne

#10 2019-01-12 16:54:04

Katryne
Membre
Provence
2016-12-03
537

Re: Les cookies en 2.9.4 : c'était mieux avant

Non pour moi, le serveur est Apache.
Mais depuis le premier signalement, je n'ai plus eu le souci.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.10.2 -  Système d'exploitation: Linux - Hébergeur 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

  •  » Installation
  •  » Les cookies en 2.9.4 : c'était mieux avant

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact