•  » Utilisation
  •  » [iOS app] connexion https mais contenu en http ?

#1 2017-07-29 11:19:30

yarez0
Membre
2017-07-29
1

[iOS app] connexion https mais contenu en http ?

Bonjour,

Comment fonctionne l'application et l'affichage des albums / photos / vidéos ?

J'ai le serveur en docker sur un NAS synology
le port 80 du docker est redirigé sur le 9443 en http du syno
je reverse proxy mon nom de domaine photo du port 443 vers le 9443 du synology

Je n'ai pas de problème sur l'interface web, uniquement avec l'app iOS, je me connecte en https mais les miniatures  photos n'apparaissent pas, l'app se connecte, liste bien les albums, les photos et les vidéos mais rien de s'affiche.

Au départ j'ai tenté le plugin FORCE_HTTPS mais je bouclais donc je suis parti sur du reverse proxy (de toute façon les ports 443 et 80 sont utilisés par le syno de base donc reverse obligatoire)

J'ai donc tenté plusieurs redirection :

http port 80 vers https 443 sur mon nom de domaine
https 443 vers 9443 local

Sauf que j'ai bypass le 443 avec ces 2 règles et j'ai fini par faire du 80 vers 9443 et comme les 2 règles étaient actives je ne m'en suis pas rendu compte, l'appli iOS fonctionnait avec l'url https et en web je tapais l'adresse en https à cause du cache.

Quand je me suis rendu compte que le site était accessible en full http j'ai commencé a me replonger dans la conf.

Aujourd'hui je n'ai qu'une règle reverse qui redirige mon domaine https 443 vers 9443 local, ça fonctionne en web mais plus avec l'app iOS.

J'ai donc l'impression qu'en réalité l'app, même si elle est capable de se connecter avec des urls https, n'affiche le contenu qu'en http.

Est ce que quelqu'un a de quoi vérifier de son côté ? j'ai ouvert un album de test si vous voulez regarder.

Merci


https://yarez0photos.ddns.net

Piwigo 2.9.1
Système d'exploitation: Linux
PHP: 5.4.45-0+deb7u7 (Montrer les informations) [2017-07-28 22:57:17]
MySQL: 5.5.55 [2017-07-28 22:57:17]
Bibliothèque graphique: External ImageMagick 6.7.7-10

Hors ligne

#2 2017-08-07 08:24:37

cryopad
Membre
2017-06-25
22

Re: [iOS app] connexion https mais contenu en http ?

Bonjour,

Merci pour l'album de test.
Effectivement, il y a un problème avec l'accès aux vignettes et une nouvelle version qui résout ce problème est e cours de préparation.

Désolé pour ce bug


Vous utilisez Piwigo pour iOS ?
Des commentaires ou suggestions ? Tell us on GitHub…
Pas encore dans votre langue? Aidez-nous à traduire…

Hors ligne

#3 2017-08-16 21:39:32

cryopad
Membre
2017-06-25
22

Re: [iOS app] connexion https mais contenu en http ?

Ce problème est maintenant résolu avec la version 2.1.
Je me suis finalement rendu compte que le serveur renseignait des adresses http aux requêtes https (adresses des vignettes par exemple). Maintenant, l'application corrige ce problème si nécessaire.

Merci pour ce retour qui a permis d'améliorer l'app.


Vous utilisez Piwigo pour iOS ?
Des commentaires ou suggestions ? Tell us on GitHub…
Pas encore dans votre langue? Aidez-nous à traduire…

Hors ligne

  •  » Utilisation
  •  » [iOS app] connexion https mais contenu en http ?

Pied de page des forums

Propulsé par FluxBB