#1 2017-06-26 23:42:49

coptere
Membre
2017-06-26
2

GD librarie graphique manquante

Bonsoir,

Je viens de passer en version 2.9 et je me retrouve avec un message d'erreur lorsque je veux ajouter une photo qui m'indique que la librairie graphique GD est manquante pourtant je ne l'utilise pas.

La configuration est positionnée sur auto, et voici ce que j'ai dans maintenance :

    Piwigo 2.9.1
    Système d'exploitation: Linux
    PHP: 5.6.30-0+deb8u1 (Montrer les informations) [2017-06-26 23:39:49]
    MySQL: 5.5.5-10.0.30-MariaDB-0+deb8u2 [2017-06-26 23:39:49]
    Bibliothèque graphique: ImageMagick 6.8.9-9

donc j'utilise imagick et je l'ai tjs fait.

Je me souviens que sur la version 2.8.X j'avais aussi eu du mal et il me semble que j'avais du modifier des fichiers pour que cela marche, mais bien évidement je n'ai rien noté....

est-ce que quelqu'un a une idée ?

Merci d'avance pour votre aide.

Hors ligne

#2 2017-06-26 23:58:52

coptere
Membre
2017-06-26
2

Re: GD librarie graphique manquante

bon je me réponds à moi-même car cela pourra en aider certains, j'ai retrouvé le code à modifier:

dans admin/include/photos_add_direct_prepare.inc.php, il faut commenter ces lignes :

//if (!function_exists('gd_info'))
//{
//  $setup_errors[] = l10n('GD library is missing');
//}

ce qui me parait normal puisque je n'utilise pas gd, la fonction gd_info n'existe pas....

Bug ou j'ai mal compris le code ?

Merci

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2018 · Contact